Hello Guest it is October 22, 2020, 10:48:50 PM

Author Topic: G31 Probe  (Read 301 times)

0 Members and 1 Guest are viewing this topic.

G31 Probe
« on: September 06, 2020, 05:01:13 PM »
Need help.
Mach3 Version  3.043.062
CSMIO/IP-S
DMM DYN2 Servo

Machine runs fine and has for years. Wanted to do some Straight Probe to measure.
The G Code

G1G31Z-3.2F25.
G1G91Z.1F25.
G1G90G31Z-3.2F5.
G1G90Z0F50.
M30

In Single Block it feeds down in Z in first block until it trips Probe Switch.
Z Stops and displays Probe Hit OK
I hit Start and I get an e-Pid error.
Sometimes no movement at all and sometimes the Z will jerk up and fault.
With version 3.043.062 the Run LED stays on always.

So I switch to Version 3.043.044 That version is recommended by CS Labs for use with the CSMIO/IP-S
Got it all set up and running using same settings.
Loaded the above program, turned on single block just to make sure all my setting are good. Hit Start and executed
Each line one at a time and all worked. I’m happy thinking I got this. Turn single block off and hit Start.
Z moves until Probe switch is hit and e-Pid fault again.
The only difference I can see between Mach3 V .044 and .062 is in .044 the Run LED turns off when stepping through the program in single block.

So I started the machine back up using Mach3 V .062 and it faults in single block unlike V .044

Any ideas would be much appreciated.


Offline Graham Waterworth

*
  • *
  •  2,186 2,186
  • Yorkshire Dales, England
    • View Profile
Re: G31 Probe
« Reply #1 on: September 06, 2020, 08:43:36 PM »
Try taking the G1 out of the G31 lines, G31 is a feed command and may not like the G1 on the line
Without engineers the world stops
Re: G31 Probe
« Reply #2 on: September 16, 2020, 02:44:09 PM »
It was suggested by CS Labs to use Mach3 version .022 - .044 and to put the G Code into VB Script. I wrote an M code as follows.
Code”G31G90Z-2.8F25.”
While(IsMoving)
Wend

Code”G1G91Z.1F50.”
While(IsMoving)
Wend

Code”G31G90Z-2.8F25.”
While(IsMoving)
Wend

Code”G0G90Z0”
While(IsMoving)
Wend

It worked perfectly. My only complaint would be Single block doesn’t work in an M Code so it executed the whole script without stopping.

Offline TPS

*
  •  1,721 1,721
    • View Profile
Re: G31 Probe
« Reply #3 on: September 16, 2020, 03:56:04 PM »
It worked perfectly. My only complaint would be Single block doesn’t work in an M Code so it executed the whole script without stopping.

Single block in macros is not working!
BTW: the code is redicoulous anyway.
anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.