Hello Guest it is October 21, 2021, 11:32:21 PM

Author Topic: Probe  (Read 2613 times)

0 Members and 1 Guest are viewing this topic.

Probe
« on: February 04, 2019, 12:45:01 PM »
Below is a script i made with machscreen v1.7. but it tells me the the command is too long and points to the block(first line).
hope someone can help me. Thanks


'probe on Z axis 
Probe = 1.89  'probe height
Depth = -1.5   'z negative travel 
Feed = 4
Code "G20 G31 Z" & Depth & " F" & Feed
While IsMoving()
Wend
SetOEMDRO(802,Probe)
While IsMoving()
Wend
Code "G91 G00 Z.2"
While IsMoving()
Wend
Code "G90"
End
 
 
Kenneth
Re: Probe
« Reply #1 on: February 04, 2019, 12:50:07 PM »
64 bit
win 10 pro
24g ram
3.4g processor
Kenneth
Re: Probe
« Reply #2 on: February 04, 2019, 01:08:14 PM »
sorry, using Mach 3
Kenneth

Offline Tweakie.CNC

*
  • *
  •  8,835 8,835
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Probe
« Reply #3 on: February 05, 2019, 01:58:16 AM »
I don't know if it helps but the line;

SetOEMDRO(802,Probe)

Should read;

Call SetOEMDRO(802,Probe)
KEEP SAFE !
Re: Probe
« Reply #4 on: February 05, 2019, 05:58:54 AM »
Thanks Tweakie.CNC, i tried that and same error. i think there may be something that
tells the code that there's an end of line.since the error includes the first two lines.
i also have a corner probe button without the "Call" inserted and works fine.
i'm at a lost but will keep looking. Thanks for your info !
Kenneth

Offline TPS

*
  •  2,202 2,202
    • View Profile
Re: Probe
« Reply #5 on: February 05, 2019, 11:05:14 AM »
try to copy the code from machsreen Editor to an other Editor like Notepad++, just to see that there is a correct CRLF at the
end of each line.
anything is possible, just try to do it.
if you find some mistakes, in my bad bavarian english,they are yours.
Re: Probe
« Reply #6 on: February 05, 2019, 11:23:53 AM »
there are no CRLF at the end of any line. does have NUL at end of file.
THANKS TPS
Kenneth
Re: Probe
« Reply #7 on: February 07, 2019, 01:15:20 PM »
Hi Kenneth

When do you get that error message? When entering use data and close, or when you close MachScreen?

Klaus
The brain isn't a soap, it doesn't shrink when used.
Re: Probe
« Reply #8 on: February 07, 2019, 01:18:50 PM »
i get the error message when i use the button in mach3.
its in the error label. where the estop message is.
Thanks Klaus !
Kenneth
Re: Probe
« Reply #9 on: February 07, 2019, 01:29:28 PM »
Hi Kenneth,

did you try to debug your script in Mach3 with the script debugger?

Select your page with the button
Menu Operator -> Edit button script
click the flashing button of interest


Klaus
The brain isn't a soap, it doesn't shrink when used.