Hello Guest it is December 07, 2019, 03:02:43 PM

Author Topic: Issues with VistaCNC P2-S USB pendant and Mach4  (Read 472 times)

0 Members and 1 Guest are viewing this topic.

Issues with VistaCNC P2-S USB pendant and Mach4
« on: November 27, 2018, 04:27:44 PM »
I have a new VistaCNC P2-S USB pendant. I have updated the firmware and it shows "imach4" on the pendant. I am however having stability issues with Mach4 and this pendant. When I use the jog wheel and reverse direction (usually small increments) I find that the system becomes unstable. Basically no matter what axis I jog it then starts sending steps to the axis under command and another axis. If I jog say my X and do a small increment on the wheel (one notch) and reverse direction, it moves rapidly back and forth (once - like a hiccup) and then also sends tiny uncommanded steps to my Y (or Z). Once Mach4 is in this state I have to restart to get it out of this state of small but scary uncommanded moves. I can see the drives on other axis are receiving steps (led flashes) when this happens.

The plugin is all enabled in Mach4. Although there is no configuration screen despite the plugin entry in the top menu. I'm not sure if this is because it needs configuring elsewhere?

As it stands I only test this pendant with the belts off as it feels unsafe to do it any other way given the issues I have experienced.

Aside from this pendant the system is stable. It never get's into this state without the pendant.
Re: Issues with VistaCNC P2-S USB pendant and Mach4
« Reply #1 on: November 27, 2018, 05:07:46 PM »
Hi,
I have a VistaCNC P1A and it works well, I struggled a bit at the beginning but its OK now.

The VistaCNC Mach4 plugin is a bit cranky. You are correct, it does not have a configuration screen.
VistaCNC is the only pendant manufacturer, to my knowledge, that have produced a Mach4 plugin, so while
the plugin may be buggy they deserve thanks for making the investment in time an resources to do it.

It seems, yours is not the first post, that its the screen on the pendant that causes the issue. My pendant does not have
one and it works fine, in fact anyone who has a screen-less VistaCNC pendant is OK.

I would suggest you contact VistaCNC.

It may be possible to disable the screen and therefore avoid the buggy bit of code.

There have been several threads about this but without the forum search function its very time consuming trying to fin them.

Craig
My wife left with my best friend...
     and I miss him!
Re: Issues with VistaCNC P2-S USB pendant and Mach4
« Reply #2 on: November 28, 2018, 05:23:01 PM »
The VistaCNC Mach4 plugin is a bit cranky. You are correct, it does not have a configuration screen.
VistaCNC is the only pendant manufacturer, to my knowledge, that have produced a Mach4 plugin, so while
the plugin may be buggy they deserve thanks for making the investment in time an resources to do it.

It seems, yours is not the first post, that its the screen on the pendant that causes the issue. My pendant does not have
one and it works fine, in fact anyone who has a screen-less VistaCNC pendant is OK.

I would suggest you contact VistaCNC.

It may be possible to disable the screen and therefore avoid the buggy bit of code.

There have been several threads about this but without the forum search function its very time consuming trying to fin them.

Craig

Thanks for the help Craig. I have contacted VistaCNC and they have requested I load the firmware again and ensure I have the correct plugin in the Mach4 folder. I will do exactly what they have asked. That all being said, it reads "iMach4" on the screen (prior to the update it read "iMach3") so the firmware update appears successful.

At this point in time it's unlikely I will hack the pendant to disable the screen. I would rather send it back if this model pendant does not work with Mach4. At least then I could buy one that is known (P1A ?) to work with Mach4.
Re: Issues with VistaCNC P2-S USB pendant and Mach4
« Reply #3 on: November 28, 2018, 05:43:42 PM »
Hi,

Quote
At this point in time it's unlikely I will hack the pendant to disable the screen.

That's not quite what I meant.  My observation on the posts which have been made is that it's the code associated with the screen
that causes the trouble. I suspect the rest of the code is indentical to the code for my P1A.

I wondered if you ignored the screen....does the rest of it work? I presume the pendant must somehow indentify itself to the
plugin and the plugin will deliver the firmware code to the pendant. If the pendant were to identify itself as a P1A then I would
anticipate (pure guesswork!!!) that your pendant would work OK....less the screen of course.

I did make this suggestion to another bloke on this board about two months ago and he was not impressed! If he couldn't have the screen
and everything working he wasn't going to have any thing......and he was going to complain and whinge about it!

Anyway....it might be a way for you to progress, it would not require that you physically disable the screen. You might even ask VistaCNC whether
my conjecture about the firmware code is correct. My impression is that the bloke there was pretty decent about trying to get customers
up and running.

Craig
My wife left with my best friend...
     and I miss him!

Offline HoY

*
  •  17 17
    • View Profile
Re: Issues with VistaCNC P2-S USB pendant and Mach4
« Reply #4 on: November 30, 2018, 10:21:49 PM »
I use the P4-SE Pendant with Mach 4, and it has a screen as well. I have not had any issues with it since day one. I would have recommended you re-flash the mach 4 firmware to yours and try again before anything else as well, and hopefully that takes care of it for you.

Offline thosj

*
  •  368 368
    • View Profile
Re: Issues with VistaCNC P2-S USB pendant and Mach4
« Reply #5 on: December 02, 2018, 05:30:23 PM »
I have a P2S and it mostly works, and WITH the screen, in Mach4. Here is my humble assessment. Lee Neuman of VistaCNC needs to write a new plugin that works. He promised one an August, last August. So.....I would remove all plugins you don't use. Remove, not disable. I think the keyboard plugin is where the conflict is but I'm not the expert. If you don't use the Mach4 keyboard plugin, remove it. One thing I know is, in my case, I can't edit keyboard shortcuts with the Vista plugin even in the folder.. Remove it, edit keyboard shortcuts, put it back, keyboard shortcuts stick and the pendant works. Hence my theory on the keyboard plugin conflicting.

Other than that, we're waiting for Lee!

Tom
Re: Issues with VistaCNC P2-S USB pendant and Mach4
« Reply #6 on: November 09, 2019, 04:57:08 PM »
I just installed Mach4 and can't get my P2S (with LCD) to work at all. 
I have an ESS with G540

I followed the instructions in the P2S manual and installed the plugin and firmware located here:

http://www.vistacnc.com/manual_download/user_files/P2S_Mach4_upgrade.zip

After flashing the P2S, the LCD reads
"VistaCNC
iMACH4"

I enabled the plugin in Mach4 but the P2S just flashes E-STOP and can't be cleared.

Is there any other configuration required?

Offline thosj

*
  •  368 368
    • View Profile
Re: Issues with VistaCNC P2-S USB pendant and Mach4
« Reply #7 on: November 09, 2019, 05:16:02 PM »
Just to be sure, the Estop on the P2S is released, and your Estop loop in Mach4 is released such that you can run the machine OK without the P2S connected?
Re: Issues with VistaCNC P2-S USB pendant and Mach4
« Reply #8 on: November 09, 2019, 05:20:17 PM »
That's correct, the e-stop on the P2S and the e-stop on the G540 are both released... in fact, I tried engaging and disengaging each e-stop to no effect. 

Everything works fine if I unplug the P2S

Offline thosj

*
  •  368 368
    • View Profile
Re: Issues with VistaCNC P2-S USB pendant and Mach4
« Reply #9 on: November 10, 2019, 08:21:58 AM »
I guess I'm stumped them! An email to Lee at VistaCNC might be in order. support at vistacnc.com