Hello Guest it is August 23, 2019, 02:39:46 PM

Author Topic: MDI stops working - cannot enter input  (Read 988 times)

0 Members and 1 Guest are viewing this topic.

MDI stops working - cannot enter input
« on: February 18, 2018, 07:22:42 PM »
Hi

I'm trying to do some general MDI milling but after a few commands the input function stops working...

I spin my mill up eg. S10000, M3 enter a command in the MDI line eg. Z0 & all is good.

Then i jog around the wood using arrow keys; now i try to enter anything into the MDI input & while i can type out the command eg. Y50 i can't 'enter' it... the enter key literally doesn't work.

From here i have to restart Mach3 (which fixes it) & try again.

Any ideas why this could be happening?


Cheers
Re: MDI stops working - cannot enter input
« Reply #1 on: February 19, 2018, 01:00:16 PM »
I have the same problem with MACH3 but have been able to see it is correlated with another issue in mach. I'm not sure if it will be the same for you, but here is my experience/solution

Do you notice that sometimes when jogging with shift held down (for fast jog) the shift key acts as if it is stuck down even when you are not holding it down? ie  you do a fast jog, then try to do a slow jog, but the machine still jogs fast? if  so maybe you have similar issue to me...

if you hit tab to look at the mpg you see a little green square usually go on or off with the shift key pressed/not but sometimes when shift key is not pressed this square is still green and the machine will still fast jog.

When I have mach3 in a state where you I am not pushing shift, but it thinks I am, the MDI will act exactly like you described for me, you can type but not "enter".

so to solve this just tap shift a few times and it will correct itself as to whether or not shift is held down. You can verify by looking at the mpg that pops up when you hit tab that it is cleared, but very reliably 2 taps seems to solve the problem for me at least.

so if you can t hit "enter" to get it to accept the mdi input, just tap shift twice then hit enter again.

i think this may be your issue to since you specified jogging, then after jogging mdi does not work.

« Last Edit: February 19, 2018, 01:02:14 PM by fredeflint »
Re: MDI stops working - cannot enter input
« Reply #2 on: February 20, 2018, 03:11:35 PM »
Great thank you - hitting shift seems to fix it.


Cheers
Re: MDI stops working - cannot enter input
« Reply #3 on: February 20, 2018, 09:06:57 PM »
A warning here.  Using the shift key to get high speed jog can be deadly!  Mach 3 has a known bug where the axis you are jogging just takes off and goes and nothing will stop it.  Scared the heck out my grandson when I was trying to teach him to run the machine and it ran away breaking off a tool!  This bug has been discussed and reported by others.  It happens on machines using the parallel port, on the motion board I have and also with the smoothstepper.  It has happened to me often enough I don't use the shift jog funvtion anymore.  The only reason it has not damaged my machine is because being the trusting person that I am NOT, my limit switches kill all power to drives directly, not through software.  I can home by holding in the reset button until the homing finishes.
Re: MDI stops working - cannot enter input
« Reply #4 on: February 20, 2018, 11:47:32 PM »
I have never had Mach just run off in 1 direction but the shift key problem is bad enough and has broken many tools for me ;)