Hello Guest it is June 02, 2023, 10:05:00 PM

Author Topic: "Software Limits" in Status during Ref All Home  (Read 9143 times)

0 Members and 1 Guest are viewing this topic.

"Software Limits" in Status during Ref All Home
« on: September 09, 2016, 04:23:47 PM »
Hello there,

I'm as new to CNC/Mach3 as a bouncing 8 pound…..    Setting up my new Zen Kit (assembly & wiring my me…a very meticulous sick-o).

In Diagnostics - checked each limit & home switch  Yellow lights where they should be.   Next, in "Ref All Home"   "Z" went fine.  "Y" went to Y-Limit ??- weird  and   "TILT" - flashing "Reset" and "Software Limits" showed in Status;  no nothing clears that. not even closing, rebooting.  Big brain-cramp.   

"Software Limits" ….is that, like - my Win-XP needs to go to the IR ????   A new purchase - has been rock solid all these years.

BTW, I've been working at the setup/controls of Mach3/Zen for a couple of days, testing, jogging, and a few minutes engraving in walnut and granadillo (hard as a rock)……wonderful quality - with the grain, across grain!!!

Thanks a lot,
Re: "Software Limits" in Status during Ref All Home
« Reply #1 on: September 09, 2016, 07:43:20 PM »
A couple of things:

First, can you provide more details?  Are you using shared home/limit switches or does each switch have a different pin assigned?  Which light(s) are active when you trigger a given switch?  How do you have your port and pins configured? etc.

Secondly, when the "Software Limits" is showing in the status line, it sounds like you may have the Soft Limits button active when you are trying to Ref All Home.  I believe you should have that turned off during a Ref All Home operation.

Try making sure Soft Limits is not active when you do a Ref All Home and let us know if that makes any difference.  I've not messed much with Soft Limits yet so I'm not sure if I'm off track here or not, but if that's not it we'll need to look more closely at your configuration.

Stephen "Highspeed" Kruse
Re: "Software Limits" in Status during Ref All Home
« Reply #2 on: September 09, 2016, 09:17:51 PM »
HS1964    Thank you!
3 limits & EStop on pin 10 .     X-home  on 11, Y-home on 12, & Z-home on 13.   Trigger any limit:  yellow lights on M1++ & M1--  x M2 & M3  (6 yellow lights).   Ports & Pins:   All lines enabled from top down to include ZHome (9 green checks.    Pin numbers from top line down incl Zhome  10 10 11 10 10 12 10 10 13  …..& EStop enabled and pin 10.    Emulated column:  All red x.  

Until your reply, I didn't know about a "Soft Limits Button" ….took a minute to find it.  If it was on, Mach3 turned it on.

After a 2 hr break Mach3 was active - wasn't locked in Software Limits.  I unchecked Soft Limits & tried Ref All again.   Went to Z-Home, then went to Y limits (False eh?)  and triggered the switch and "Reset" & freeze.

I'd like my Ports and Pins settings looked at; often get a Reset and the message that there's an external influence or limit switch(s) triggered.  And to reverse Low Active settings.  Or Mach3 can fix it for you and un-checks a  bunch of low actives and it freezes again.

Thanks for your help, Stephen    
Re: "Software Limits" in Status during Ref All Home
« Reply #3 on: September 12, 2016, 11:37:40 AM »
Not sure how that wiring would work out with the limits on the E-Stop.  My machine has a each axis with the limit switches (and no separate home switch) wired to the respective pin for each axis.  I've wired my switches in series on the NC contact with an active HIGH setting for safety (a broken wire or loose connection would also trigger a limit stop) and pins assigned as 11 11 11 12 12 12 13 13 13.  This way the machine knows which axis triggered the limit.  You could possibly use the setup you have since it sounds like you have a separate home switch, but that may be what's causing your Y limit to trigger a stop.

However, in a homing condition you'd expect it to trigger the home switch before reaching the limit so this should work out fine.  Have you checked the home switches on the diagnostic screen to make sure they are working as well?  I'd suspect that is where your final trouble might be.  I can look at your port and pins configuration if you post the XML file, but if it's mechanical this wouldn't be of much help.

Let me know what you see when you trigger the home switch for each axis on that diags page.

Stephen "Highspeed" Kruse
Re: "Software Limits" in Status during Ref All Home
« Reply #4 on: September 12, 2016, 02:01:50 PM »
Sorry, my first line should have read:…"I trigger each of the 6 switches in turn and get proper yellows in Diag".   My wiring is per a ZEN diagram.  Have checked wiring very carefully - Hope problems are in the settings & buttons.

When I do the "Ref All Home" it does "Z" Home just fine, then heads to "Y" Limit at the front of machine - ya-but, that's a tilt, eh?  :-), and of course then the "Reset".    I want Home (the spindle) to be at left, front of the machine...therefore "Y" home switch located at rear?

XML?  Not sure about attachments - posting files here;  I'm only on net and email with my Macs.  Cheap way to keep Windows out of the hospital.  I tried to list my Ports & Pin settings on my Sep 09 -  06:43 post.

Perhaps you can help me easier when knowing my primary (at least for now) usage of CNC:  Engraving 36pt (½"), 2mm deep, 1 or 1.5mm bit….  letters - one or two words on .5"x5"x5" hardwood pieces.  Do I need Home switches?  But perhaps the current glitch won't allow any control of the machine?  
I've taken great care (started in mid July) in assembly/wiring, and the jogging/engraving of some doodles really has me enthused; so this is frustrating.  I appreciate your help!

Re: "Software Limits" in Status during Ref All Home
« Reply #5 on: September 12, 2016, 05:24:58 PM »
So firstly, the .XML file is in your Mach3 directory.  It will have the name of the profile you use to start up Mach3.  To post the file, if you can get it to your Mac, then you can attach it if you click "Reply" (the "Quick Reply" will not work for this) and then "Additional Options" under the text block in that window.  The will be a button to "Choose File" there that you can then use to attach it to the message.

Secondly, I appreciate the clarification on your switch indications on the diags screen.  So on the Y axis, is the home switch positioned closer in than the limit switch?  Somehow, it seems like the home is getting ignored and the axis continues until the limit is hit.  You _could_ run your machine without referencing home but this is not recommended since it puts your machine in a state where it doesn't know the true Machine Coordinates and other functions rely on knowing the correlation between MC (Machine Coordinates) and WC (Workpiece Coordinates).  We'll get this figured out hopefully and you wouldn't need to worry about these issues.

If possible, could you somehow get a diagram of the switch layout on your machine posted as well as the .XML file?  That may help us figure it out better.

Re: "Software Limits" in Status during Ref All Home
« Reply #6 on: September 12, 2016, 11:54:22 PM »
Limit switch wiring:  3 red wires from NO terminals to Pin 10 on TB6560 bob.  3 black wires from COM terminals to Gnd on bob.
Home switch wiring:  "X" Home: red wire from NO to Pin 11.  black wire from COM to Gnd.  Switch on top of left gantry.   "Y" Home:  red wire from NO to Pin 12.  Black wire from COM to Gnd.  Switch mounted on back rail of machine base.  "Z" Home:  red wire from NO to Pin 13.  Black wire from COM to Gnd. Switch mounted on top of rack holding spindle carriage.   Limit switches mounted on opposite extremities.  The "Y" axis switches are 14" apart….perpendicularly from front rail to back rail.

EStop button: Red wire to Pin 10.  Black wire to Gnd.  This could be incorrect. I've struggled with incomplete, reversed, contradictory, or non-existent wiring & settings info from ZEN from the beginning.

During the "Ref All Home", after completing the "Z", the "Y" stepper starts moving the table (from the middle of the machine) in the wrong direction towards the front rail which holds the "Y" Limit switch.  On contact it goes "Reset"; probably doing what it's supposed to do….only not during a Homing process?  :-)

HighSpeed, After we finish this "War & Peace" length manuscript, we can sit back with a cool beverage and share the publishing proceeds.    I really appreciate your help,

Re: "Software Limits" in Status during Ref All Home
« Reply #7 on: September 13, 2016, 01:29:59 PM »
Ah, ok.   So what you have is a switch for each "upper" limit (x, y, z in the positive direction) all wired together and a dual home/limit switch on the lower end (axis moving in the negative direction) for a shared limit/home switch on each individual axis.  So what I believe you would want to do is set the ports and pins configuration to:

X++: 10
X - -: 11
X Home: 11
Y++: 10
Y - -: 12
Y Home: 12
Z++: 10
Z - -: 13
Z Home: 13

Remember, there are two limits - one for each direction - that must be accounted for.  Usually, a shared switch arrangement would have the two limit switches wired together and connected to the respective axis input pin (i.e. 11 for X, 12 for Y and 13 for Z) and then putting all three signals on Ports and Pins to the same pin number.  So your pins would be 11, 11, 11, 12, 12, 12, 13, 13, 13.  However, the way you have it should work, you just need to change the pin assignments as I listed above.

And yes, the Y axis moving in the wrong direction is what is triggering the Reset button flashing and halting on you.  A limit switch that is shared with the home signal (as is the case with your lower limit) will be ignored in a homing operation but if it is not shared like you have for the + limit, that will not be ignored.  The Y axis moving in the wrong direction will trigger the limit in this arrangement.  We need to get that axis (and possibly the X axis since we haven't yet gotten that far) moving in the correct direction for homing.  So what you'll need to do is go to Config | Home Limits and set the Home Negative opposite of what it is currently set to for each axis that is homing in the wrong direction.  Since your Y axis is moving in the wrong direction, that one definitely needs to be changed.  (i.e. if it has a red "X" change it to a green Check Mark and vice-versa.)

Try that and let me know how it goes.

(As for the "Novel" length discussion, I've seen much longer War and Peace discussions on this board.  That's just the nature of troubleshooting so don't feel like this is unique!)  ;D

« Last Edit: September 13, 2016, 01:34:55 PM by Highspeed1964 »
Re: "Software Limits" in Status during Ref All Home
« Reply #8 on: September 13, 2016, 01:39:07 PM »
Actually, I need to amend the above information.  The Z-Axis will probably be homing in the positive direction so it should be set up as:

Z++: 13
Z - -: 10
Z Home: 13

Re: "Software Limits" in Status during Ref All Home
« Reply #9 on: September 14, 2016, 01:09:26 AM »
Mid afternoon I set Pin numbers as you listed,  Clicked Apply, O.K. & Reset.  Noted that "Soft Limit is off".  Clicked Ref All Home.   Tool moves upward (Z-axis) and triggers Z-Home and backs off but not enough to clear the switch.  But, the table then moves (Y axis) toward front -  wrong direction).  I click stop and go to Input Signals to reverse which of the 3 Y settings.  You say "Go to Config|Home Limits and set Home Negative opposite to     I don't see either of those  Home Lim  or Home Neg.   Which one do I reverse?  I have a choice of Y Home, Y++, or Y--     Highspeed,  I've only typed (one finger- very slow) this much.  But have gone on to try many settings (trial & error/guessing on the Y reverse choice),  Y Home didn't fix it,  etc.

So tonight I tried again with more trial-guesses & then write this.

BTW, when the limit switch is triggered and Reset is flashing, the machine is sitting on the switch, How do I reset the software to move the machine off the switch without closing the session, unplugging the machine power, and twisting the rod?

Constantly get the "Failed Reset" box. It reads, in part: "Reset command is failing due to an external influence"  & more about limit switches, etc.  Then asks "Fix this for me?"   I've tried that and also gone into Input settings to make another guess.  

Each of these posts represents at least an hour of resetting/trying machine results and reading and rereading and typing.  I don't see any progress; this could go on for days.  How can I get on the phone with a Mach3 tech.   I've been there and done that for probably hundreds of calls (TurboCad, PhotoShop, Epson Wide Format) all since 2001.   I'm sure you know the drill - the tech can know the settings, and the results of each action and understand the software's feedback notes all in real time and therefore knows right what to do to solve the problem, AND simultaneously, graphically shows the beginner (the paying customer) the path to operate or the path to fix.

This is very, very frustrating;  I've been in this process since 1981 (Apple II+ & IIe) and to date I've purchased or received, w/hardware purchases, over 40 programs and only counted those on the list those which I have learned at least well enough to operate.  No games, video, streaming or entertainment…I'm a project guy.

I'll drop one on you:  Circa 1982  I purchased a Hayes MicroModem card & installed it in my Apple IIe.   On the computer, the Hayes MM dialed my son at his apartment and I was able to type a message, B/W, 40 characters to the line, 20 lines to a screen.  He could see my message on his IIe  and then type a response message; both sides of the messages on both screens.  Of course the transmission was slooooooow.  Those Apples were 64K & later 128K, w/dos.   :-)

How do I get some results in what surely is a fundamental - setting up the control of a CNC with Mach3?   What about testing the latest Input Pin settings on Diag to see if the yellow lights show correctly?