Hello Guest it is October 18, 2019, 12:53:06 AM

Author Topic: One last problem  (Read 2235 times)

0 Members and 1 Guest are viewing this topic.

One last problem
« on: June 13, 2016, 03:41:51 PM »
Hi
Finally almost there on my set up, one last issue. I have a rectangle work area 24" x 96" my home is the bottom left corner. When I ref all, all axis home fine to the home spot. I load the road runner to test out the system it loads in the bottom left corner fine. I push start and the machine try's to move in opposite direction of the work, and out of my table workspace.
Went to homing and limits page  to uncheck and reverse X but all it does is move my home to right hand corner. How or what do I change to orient my movement in the proper direction. I don't know if this issue is affecting my Y and Z because off the direction movement it trips my limits right away.
Many thanks Bill
Re: One last problem
« Reply #1 on: June 13, 2016, 04:54:01 PM »
Hi
Is it possible that the gcode in the roadrunner sample is written to move the axis in a certain direction and were I have chosen my home is not compatible/
Bill

Offline Tweakie.CNC

*
  • *
  •  7,951 7,951
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: One last problem
« Reply #2 on: June 14, 2016, 05:21:31 AM »
In the MDI screen, zero the X axis DRO, then input G0 X10
Press Return.
Does the X axis move in the + direction (to the right) and the DRO subsequently read +10.0000 ?

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: One last problem
« Reply #3 on: June 14, 2016, 03:25:19 PM »
Hi
I did as you instructed and the X moved to the left but did read +10.000
Bill
Re: One last problem
« Reply #4 on: June 14, 2016, 05:34:27 PM »
Ya' gotta be thinkin' which way the *TOOL* moves in relation to the table; not which way the table moves. ;D
Milton from Tennessee ya'll.
Re: One last problem
« Reply #5 on: June 14, 2016, 06:05:04 PM »
Hi
Sorry if I didn't explain it correctly, By machine I meant my Gantry, I assume I need to change a setting to reverse the tool direction  so when it is moving in the + direction the tool is moving to the right not left
Thanks Bill

Offline Tweakie.CNC

*
  • *
  •  7,951 7,951
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: One last problem
« Reply #6 on: June 15, 2016, 01:38:07 AM »
Go into Config. / Ports & Pins / Motor Outputs and change the Direction Low Active state for your X axis. This will reverse it's direction of travel.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: One last problem
« Reply #7 on: June 15, 2016, 11:58:49 AM »
Thanks
There are two, direct low active and step low active do I change both.
Thank you for the help
Bill

Offline Tweakie.CNC

*
  • *
  •  7,951 7,951
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: One last problem
« Reply #8 on: June 15, 2016, 12:18:16 PM »
No, just the Direction Low Active should be changed.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: One last problem
« Reply #9 on: June 15, 2016, 12:57:39 PM »
Hi
I changed the direct active low , the X moves to the + direction but the X now homes to the right side of the table. Is this were I must make may home when I Ref all home
Bill