Hello Guest it is April 13, 2021, 08:56:14 AM

Author Topic: Smooth movement while motor tuning, stall when jog  (Read 1584 times)

0 Members and 1 Guest are viewing this topic.

Smooth movement while motor tuning, stall when jog
« on: June 10, 2016, 08:03:52 AM »
Hi,

First post. Been using Mach3 for a couple of years with Gerry's 2010 screen set on my large router. Awesomeness!

Today I have a problem. I am converting my small CNC router to be Mach3 compatible via parallel port. I removed the USB motion controller to use it on another machine.
When I do the motor tuning the axis moves smooth as expected - I have tested a range of velocities and acceleration all with no problem.
As soon as I close the motor tuning window and try to jog or run gcode the axis moves with grinds, jerking and stalls.

Any ideas?

Offline Tweakie.CNC

*
  • *
  •  8,692 8,692
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Smooth movement while motor tuning, stall when jog
« Reply #1 on: June 13, 2016, 01:49:52 AM »
Run the Driver Test (Mach3 folder) and see if the results are OK.

Tweakie.
KEEP SAFE !
Re: Smooth movement while motor tuning, stall when jog
« Reply #2 on: June 13, 2016, 02:51:06 PM »
I did. Not 100% sure what I should be looking for? It says system excellent but apparently that is not a real indication? The line is flat but not super smooth, at 25kHz it has small bumps all over, at 100kHz only a few.

At 25kHz I get max variation between 3 and 7us.
At 100kHz between 2.4 and 3.0us on average.

I am running on a Win7 32bit box. My other machine runs on XP. I tried the Vista registry patch but it did not make a difference.
Thinking I should try another PC, maybe see if I still have an XP install...
Re: Smooth movement while motor tuning, stall when jog
« Reply #3 on: June 16, 2016, 08:17:06 AM »
Hi,
hope this does not upset you.. but I want to ask that when you go back to the motor tuning page whether
the settings you had previously made are still there.
When I was learning this stuff I on too many occasions would forget to 'save axis settings' before moving on
and then scratch my head when the axis movement didn't appear to change. I mean how dumb can I get!
In more recent times I don't change those settings often if at all and if I did would still too often forget to
do so!

Craig
My wife left with my best friend...
     and I miss him!
Re: Smooth movement while motor tuning, stall when jog
« Reply #4 on: June 16, 2016, 05:00:50 PM »
Quote
hope this does not upset you..
Not at all. Thanks for the reply.

Quote
motor tuning page whether the settings you had previously made are still there
Yes they have been saved. I have made this mistake before but not this time...