Hello Guest it is December 08, 2019, 07:32:37 PM

Author Topic: Problem with Mach3 Camera Plugin?  (Read 13166 times)

0 Members and 1 Guest are viewing this topic.

Re: Problem with Mach3 Camera Plugin?
« Reply #10 on: October 23, 2019, 05:04:55 AM »
Good Morning Klaus,

I am using:
   Windows 7- 64 bit- Service Pack 1
   Mach 3 Version R3.043.067
   Plug In Camera V3.09
   Andonstar A1 (2.0 USB) Camera.
All settings are default, as I can not get an unfrozen image to make any changes. No other cameras on the system. Upon starting the plug in, the video immediately freezes. Terminating and restarting the plug in yields the same result. Restarting the Mach 3 software has no effect either. The camera works fine on this computer and my laptop with out going through the Mach3 software. Different USB ports do not make any difference.
« Last Edit: October 23, 2019, 05:08:49 AM by rphilli22 »
Re: Problem with Mach3 Camera Plugin?
« Reply #11 on: October 23, 2019, 06:26:35 AM »
can you set the CONFIG?
Menu Config -> Config Plugins
In dialog "Plugin Control and Activation" CONFIG

when it freezes, is the camera-window blank? Could it be a messagebox is overed by another window and awaiting an action?
Could you please show the logfile content. if you installed the plugin with default settings you can find it       C:\Cameralugin_KD\CameraPlugin-KD.log.

Klaus 
The brain isn't a soap, it doesn't shrink when used.
Re: Problem with Mach3 Camera Plugin?
« Reply #12 on: October 23, 2019, 06:33:54 AM »
Yes, I will check. I did not see any other pop up windows or messages. I did minimize the Mach3 screen to be sure. I will be back in the shop on 10/25.
Re: Problem with Mach3 Camera Plugin?
« Reply #13 on: October 25, 2019, 07:31:48 PM »
Klaus,

I have found the source of my woe with the camera today. I decided to double check the downloads and drivers for error. None found, until I noticed in the windows device manager the camera was no longer listed. It had not been unplugged or uninstalled. I removed the camera from the CNC and started over with the camera on my desk. It worked flawless until I touched any metal of the CNC. This would cause the camera to freeze in Mach3 and drop off the device manager list. The camera has a metal housing and I mounted it in an aluminum bracket.
I isolated the camera with a plastic bracket and resolved the camera issue. I may need to work on the grounding and bonding of the CNC. Thank you very much for your rapid response to my original post.
Re: Problem with Mach3 Camera Plugin?
« Reply #14 on: October 26, 2019, 03:09:14 AM »
well done, this is good news.

Klaus
The brain isn't a soap, it doesn't shrink when used.