Hello Guest it is July 12, 2020, 12:01:42 AM

Author Topic: When I Hold Feed then Start Cycle, A axis abruptly turns;-(  (Read 2550 times)

0 Members and 1 Guest are viewing this topic.

Offline Frank1959

*
  •  34 34
  • Do it, it´ll free your mind.
    • View Profile
    • Monumental Sculpture
When I Hold Feed then Start Cycle, A axis abruptly turns;-(
« on: February 16, 2016, 08:25:25 AM »
Hi all!
I´m at present doing 4 axis machining of polystyrene foam, using DESKPROTO  to generate g-codes, and an A axis to spin the part.
I´ve just noticed something strange and problematic in MACH3 when I need to pause in the middle of a routine.

I touch the FEED HOLD button  on the MACH screen, and within a few seconds (probably MACH needs time to reference where it is to ready itself for starting again)…MACH  pauses, as if on Hold. Fine up to here.

But when I wish to re-commence, and I click on the Cycle Start button on the MACH screen, the A axis mysteriously and abruptly spins to Machine Zero, no matter what angle the routine has been working at, and milling commences.

Attached a Screen Shot: you can see the a axis is now at 1.9125º, bt it should be at 0º. (which it this case is actually 0º at Machine Coordinates)
And if it had been working at say 270º, as happened some days ago, it still spins abruptly to Machine Zero for that (A) axis.

Am I doing something wrong here??

Thanks!!

If its not obvious, I´m pretty much of a new-comer

Offline ger21

*
  • *
  •  6,282 6,282
    • View Profile
    • The CNC Woodworker
Re: When I Hold Feed then Start Cycle, A axis abruptly turns;-(
« Reply #1 on: February 16, 2016, 09:08:37 AM »
parallel port, or motion controller?
What version of Mach3?
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: When I Hold Feed then Start Cycle, A axis abruptly turns;-(
« Reply #2 on: February 16, 2016, 09:23:58 AM »
Now that I think about it, when I was milling my pistol grips, this happened to me.  I was cutting a 3d code with no A axis movements from Aspire.
Motion controller is a USB Smooth stepper.
mach version is either .061 or .066  Dont remember exactly right now.

Offline Frank1959

*
  •  34 34
  • Do it, it´ll free your mind.
    • View Profile
    • Monumental Sculpture
Re: When I Hold Feed then Start Cycle, A axis abruptly turns;-(
« Reply #3 on: February 16, 2016, 01:28:00 PM »
Its a USB port Im using, so I suppose...Motion Controller?

As for the version of MACH3, I will chk tomorrow, Im not at the workshop now.

Thanks!!!

frank

Offline Frank1959

*
  •  34 34
  • Do it, it´ll free your mind.
    • View Profile
    • Monumental Sculpture
Re: When I Hold Feed then Start Cycle, A axis abruptly turns;-(
« Reply #4 on: February 18, 2016, 03:50:18 AM »
Sorry, busy day yesterday ;- (

My MACH 3 version is R3.043.066.

And the controller uses a USB Interface plugin by CNC Robotica, see http://www.machsupport.com/software/plugins/

BTW, Ive discovered another strange behaviour in MACH3, this time  when using the Reverse Run. Conditions are similar; if I click on Feed Hold, the on Reverse Run (thats the order, right?), so as to go back over the area just milled,  sometimes it works, but sometimes my Yaxis goes wandering off to an area not indicated in the g-codes, other times it happens with the Z axis. Very frustrating. Thankfully, Im milling foam, so no tools broken, no danger, but lots of frustration.

Any ideas?
Thanks,

Frank Norton.
www.franknorton.com
https://www.facebook.com/Cosas3D/

Re: When I Hold Feed then Start Cycle, A axis abruptly turns;-(
« Reply #5 on: February 18, 2016, 06:35:54 AM »
Hi Frank,
  It's been strongly suggested that you do not use 066 as there are some issues with it.
I'd try an earlier release. I use Version R3.043.062

Also, Rev Run, among other features, will not work in Demo mode.

Offline Frank1959

*
  •  34 34
  • Do it, it´ll free your mind.
    • View Profile
    • Monumental Sculpture
Re: When I Hold Feed then Start Cycle, A axis abruptly turns;-(
« Reply #6 on: February 18, 2016, 07:27:59 AM »
Thanks Overoladed,

My MACH is licenced, so that rules out the Rev Run anomaly?

I will try the earlier version to see if the Feed Hold then Cycle Start issue resolves itself.

F

Offline ger21

*
  • *
  •  6,282 6,282
    • View Profile
    • The CNC Woodworker
Re: When I Hold Feed then Start Cycle, A axis abruptly turns;-(
« Reply #7 on: February 18, 2016, 08:19:41 AM »
If changing to 3.043.062 does not help, contact the manufacturer of your motion controller and ask if these are known issues with their board and plugin.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: When I Hold Feed then Start Cycle, A axis abruptly turns;-(
« Reply #8 on: February 18, 2016, 08:40:58 AM »
Hi Gerry,
  Looking at the CNC Robotica board on their website, it looks to be just a USB interface, not an actual motion controller.
Not sure though as there isn't much info there about it.

http://www.cnc-robotica.com/index.php?language=en&osCsid=132e0beedb1e8bb8b1dbef28fb28da2f

Russ

Offline ger21

*
  • *
  •  6,282 6,282
    • View Profile
    • The CNC Woodworker
Re: When I Hold Feed then Start Cycle, A axis abruptly turns;-(
« Reply #9 on: February 18, 2016, 09:16:04 AM »
The manual shows how to select it as the motion controller.
And it has a plugin.
http://www.cnc-robotica.com/images/manual-interface-usb-web.pdf
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html