Hello Guest it is May 08, 2021, 12:18:57 AM

Author Topic: Version 2803 Problems  (Read 8517 times)

0 Members and 1 Guest are viewing this topic.

Version 2803 Problems
« on: December 22, 2015, 03:35:14 AM »
**** Reference all Axis Home ****

HI everyone,

Can you confirm if the reference all home should be working the same as Mach3.

Currently my system does reset the DRO's to Zero , but does not motor over to find home switches.

Are there any other settings that I need to set befor this will work? or do I have to code this in the button script?

Or is this a future Mach4 enhancement?

Kind Regards

Mark

Offline DazTheGas

*
  •  753 753
  • DazTheGas
    • View Profile
Re: Version 2803 Problems
« Reply #1 on: December 22, 2015, 03:42:01 AM »
Firstly I would make sure you havnt set the home in position located in the config.

DazTheGas
Theres always time for a choccy biccy
Re: Version 2803 Problems
« Reply #2 on: December 22, 2015, 04:46:05 AM »
**** Reference all Axis Home ****

Hi Daz, Thanks for the quick response.

Are you referring to the "Home in place" tick box in the Homing/ Soft Limits Tab?

I presume your system does motor over to find the home switches?

Cheers

Mark

Offline DazTheGas

*
  •  753 753
  • DazTheGas
    • View Profile
Re: Version 2803 Problems
« Reply #3 on: December 22, 2015, 07:25:49 AM »
Perhaps it would help if you posted your machine.ini there is so much information in this file as to how your machine is setup. Another way which is better is to use the profile packager and upload, Please note it will make a file with the extension M4PROF so you will need to change the extension to .zip

DazTheGas
Theres always time for a choccy biccy

Offline Pedio

*
  •  200 200
    • View Profile
Re: Version 2803 Problems
« Reply #4 on: December 22, 2015, 11:13:44 AM »
Mine motors over to the home switches.

Have you looked at the machine diagnostics tab to make sure that your home switches are not active; e.g., LEDs are lit.

You also have to identify what inputs your home switches are connected to in the input setup tab. I am not sure but suspect if you have not identified the input for the home switch then MACH 4 probably thinks you don't have a home switch on your system and does not move at all.

Let us know if you solve this problem.
Re: Version 2803 Problems
« Reply #5 on: December 22, 2015, 12:44:08 PM »
 might want to look at your motion controller plugin for settings too..... I thought homing was done in the motion controller ... I may be wrong on that though.
Re: Version 2803 Problems
« Reply #6 on: December 23, 2015, 03:51:37 AM »
Hi,

Here is my config file, which program do you use to view it?

Kind Regards

Mark
Re: Version 2803 Problems
« Reply #7 on: December 23, 2015, 03:52:58 AM »
Sorry forgot to mention, have checked the limit leds in the debug pannel,they do seem to be working

Offline DazTheGas

*
  •  753 753
  • DazTheGas
    • View Profile
Re: Version 2803 Problems
« Reply #8 on: December 23, 2015, 06:08:07 AM »
Unfortunately I cannot assist on this one as its using the Darwin Plugin and my machines are all 64bit and unable to use the plugin, so this is really a topic for those using Darwin.

DazTheGas
Theres always time for a choccy biccy
Re: Version 2803 Problems
« Reply #9 on: December 23, 2015, 03:39:49 PM »
Here is my config file, which program do you use to view it?
I use Notepad and Mach4.  Here is what I see:

Motor0 is the only motor that is enabled.
The X axis is the only axis that is enabled, and it has Motor0 assigned to it.
In the homing order you have the X axis as #1 (first axis to home).

So far so good.

Looking at the "Configure->Mach", "Input Signals" tab, you have the Darwin/xlimit signal assigned to:
- Input #5
- Motor 0 Home
- Motor 0++
- Motor 0 - -

Disclaimers: I know very little about the Darwin plug-in.  And I don't currently have access to our PC that has Darwin installed, so I can't test any of this.  Some plug-ins totally ignore the settings in the "Configure-> Mach" dialog.  I don't know if the Darwin driver ignores them or uses them.  That said...

If the Darwin plug-in had a signal called "xlimit", I would presume it also has a signal called "xhome".  Homing is indeed handled entirely in the plug-in, all Mach4 does it tell the plug-in "Home this axis and tell me when you are done".  It is **possible** that the Darwin plug-in will only home an axis if there is an input signal assigned to its "xhome" signal, if indeed it does have an "xhome".

OR...

I see in the Darwin section of the Machine.ini file that Motor0's home signal *might* be assigned to Darwin input #29 (I'm guessing as to the meaning of the line "Motor_0_HomeSig=29").  If that really does mean the home signal is Darwin input signal #29, looking further down the INI file, "Input_29" is disabled and has no name.  So, as above, perhaps Darwin is refusing to home that axis because there is no input assigned as the home signal.

You might be able to verify this by enabling the Mach4 log window.  Go to the "Diagnostic" menu and select "Logging".  Then click on the little play button to start the log.  Now try to home the machine.  See what messages show up in the log window.

Those are my best semi-educated guesses.

Bob