Hello Guest it is May 16, 2021, 05:25:57 AM

Author Topic: Version 2803 Problems  (Read 8548 times)

0 Members and 1 Guest are viewing this topic.

Re: Version 2803 Problems
« Reply #30 on: December 30, 2015, 10:20:11 AM »
Are you still using the simulator as your motion device?  If so, all it does when homing an axis is wait 1 second, set that axis position to zero and set the axis to "homed" (green indicator next to "RefX" button).  In fact, the simulator ignores the "Home Offset" setting in the "Homing/SoftLimits" configuration tab.

If you are using the ESS as the motion device, check that you don't have the "Home In Place" setting checked (go to the "Configure" menu and select "Mach..", then click on the "Homing/SoftLimits" tab).  There may also be further homing settings in the ESS plug-in config, but someone familiar with the ESS plug-in will have to help you there.

Bob
Re: Version 2803 Problems
« Reply #31 on: December 30, 2015, 01:05:48 PM »
Hello Bob,

thank you for reply.
The Motion-Device is ESS. Thats sure.
Place in Home is not checked.
If i klick to "REF" nothing happens on the machine.
Axis can be moved with buttons in MACH
Axis can be moved with keyboard.

Klick to "REF" will change the screen, in the status bar is written: "Homing"
Nothing happens.

Gerhard
Re: Version 2803 Problems
« Reply #32 on: December 30, 2015, 01:23:33 PM »
Here the log from the "Homing".

Re: Version 2803 Problems
« Reply #33 on: December 30, 2015, 02:14:42 PM »
Next issue:  :'( :'(

Create a new profile
Machine-Name: NewMachine
Screen: wx6.set

During starting the new profile you will be asked for the moton device
select ESS with right IP
Configure ESS
Close Mach4

Start Mach4
Enable ESS in Plugins
Enable Keyboar in Plugins
Configure ESS- > Close Mach4 after doing this, otherwise the application will crash!
Configure Keyboard

Try to move axis -> nothing will happen

Close Mach4

Restart Mach4

Enable Simulator - Newfragled Solutions
Try to move axis -> axis will move

Try home axis -> nothing will happen.


best regards, gerhard

« Last Edit: December 30, 2015, 02:18:27 PM by Gerhard Grasser »
Re: Version 2803 Problems
« Reply #34 on: December 30, 2015, 09:13:58 PM »
Here the log from the "Homing".
From the log it appears that something is preventing the ESS from actually homing.  I'm not familiar enough with the ESS config screens to be of any more help here.  BTW, there is also ESS specific help on the Warp9 support forums (http://www.warp9td.com).

A polite suggestion - instead of putting all of your ESS & machine configuration/operation issues in the thread that was originally about build 2308 problems, please start another thread (or several more threads) with subjects lines that make it clear that your issues are at least partially ESS related.  That way people who know a bit about the ESS plug-in may be more likely to *find* the thread and jump in the help.

Bob
Re: Version 2803 Problems
« Reply #35 on: December 30, 2015, 09:20:01 PM »
Next issue:  :'( :'(

<snip lots of config stuff>

Enable Simulator - Newfragled Solutions
I'm not sure about the other issues, but I do know that you should *never* enable the simulator along with any other motion plug-in (i.e. ESS).  I can't explain why doing so caused your ESS to then start moving motors.  But I *DO* know that enabling the simulator plug-in often causes erratic behavior in other plug-ins.

Bob.

Offline dude1

*
  •  1,253 1,253
    • View Profile
Re: Version 2803 Problems
« Reply #36 on: December 31, 2015, 12:39:04 AM »
it a good idea to just remove sim it can save 10 tonne of issues for ya tissue
Re: Version 2803 Problems
« Reply #37 on: December 31, 2015, 12:23:27 PM »
The Motiodevice is not enabled.
It's yust in the list.
Re: Version 2803 Problems
« Reply #38 on: December 31, 2015, 01:37:47 PM »
The Motiodevice is not enabled.
It's yust in the list.

That shows that the simulator is not selected as the motion device.  It does NOT show whether the simulator plug-in is enabled or disabled, which it what I was referring to.  For that, go to the "Configure" menu and select "Plugins..".  There should be a red "X" in the "Enabled" column on the "Simulator" line.

Bob

Offline DazTheGas

*
  •  753 753
  • DazTheGas
    • View Profile
Re: Version 2803 Problems
« Reply #39 on: December 31, 2015, 02:05:29 PM »
have you set the homing in the ess config as well as the mach config?

DazTheGas
Theres always time for a choccy biccy