Hello Guest it is August 06, 2020, 06:44:44 AM

Author Topic: Mach ignoring limit switch broke my machine :(  (Read 9412 times)

0 Members and 1 Guest are viewing this topic.

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Mach ignoring limit switch broke my machine :(
« Reply #10 on: March 14, 2015, 08:22:22 PM »
I know and what I am saying is on my machines I have extended the trigger so that it goes active and stays active if I travel further in that direction.

My controllers/drives can handle that situation and back off if I request a home and the switch is active. I do not think the ESS supports that feature but it may but also as mentioned there is an option in General Config which may work by telling you its active and not homing.

Other option is to alter the VB in the RefAll button and have it look at the LED for the Z Home, if it is active have it pop a message telling you and then have it stop any homing happening before it starts.

Hood

Offline jevs

*
  •  315 315
    • View Profile
Re: Mach ignoring limit switch broke my machine :(
« Reply #11 on: March 14, 2015, 08:25:54 PM »
I do have single unused home switches on X and Y. I suppose I could use those to make it safer for those axis. Then wire the limits to the E stop or something.

See attached. There are several unused switches in the Z. Maybe I can tie one of those in with the cutting area Z home. Then it would stop before hitting the limit. Then just wire the limits to the E stop also or something.

Not sure how you will move off the switches if it is tripping E stop. I guess you would need a manual toggle switch for override on the control panel.

Offline jevs

*
  •  315 315
    • View Profile
Re: Mach ignoring limit switch broke my machine :(
« Reply #12 on: March 14, 2015, 08:29:16 PM »
I know and what I am saying is on my machines I have extended the trigger so that it goes active and stays active if I travel further in that direction.

My controllers/drives can handle that situation and back off if I request a home and the switch is active. I do not think the ESS supports that feature but it may but also as mentioned there is an option in General Config which may work by telling you its active and not homing.

Other option is to alter the VB in the RefAll button and have it look at the LED for the Z Home, if it is active have it pop a message telling you and then have it stop any homing happening before it starts.

Hood

I got you. However I cannot do this. My mechanics would not allow Z to go all the way down if I had a rod keeping that switch active. I will have to think about this.

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Mach ignoring limit switch broke my machine :(
« Reply #13 on: March 14, 2015, 08:31:10 PM »
Not a good idea to have a toggle for physical limit overrides, use a momentary push button, that way you can never accidentally leave it on. Thats what I use, you will see it in the pic I attached, near the top, just to the right.

Hood

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Mach ignoring limit switch broke my machine :(
« Reply #14 on: March 14, 2015, 08:32:59 PM »
Ok so the switch is fixed on your machine and the trigger travels?

Hood

Offline jevs

*
  •  315 315
    • View Profile
Re: Mach ignoring limit switch broke my machine :(
« Reply #15 on: March 14, 2015, 08:38:22 PM »
Yeah, there is a plate with a bunch of dogs that hit all the switches so originally it would know the start and stop of the tool change, home and limits.

I will have to think about this more tomorrow. At least I got all the welding and grinding and repair done today.

What stinks is that this is completely not what I needed to be getting done this weekend :(

Now, I have to make this thing 100% bullet proof safe though.
« Last Edit: March 14, 2015, 08:40:04 PM by jevs »

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Mach ignoring limit switch broke my machine :(
« Reply #16 on: March 14, 2015, 08:42:58 PM »
Could you possibly set things up so the switch is always triggered when in normal  operation and only goes off the trigger when it reaches the Home position?
That way you would just have to change the active Hi/lo setting for your Home.

Hood

Offline jevs

*
  •  315 315
    • View Profile
Re: Mach ignoring limit switch broke my machine :(
« Reply #17 on: March 14, 2015, 09:08:02 PM »
First off. Do you agree I should take all the limits and tie them to the E-stop (enable relay)?
I can make this my first priority tommorow. At least then I can't crash it figuring out the rest

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Mach ignoring limit switch broke my machine :(
« Reply #18 on: March 14, 2015, 09:11:26 PM »
It is definitely wise to have the limits working via hardware rather than software only, especially on bigger machines and is something I always do.

Hood

Offline jevs

*
  •  315 315
    • View Profile
Re: Mach ignoring limit switch broke my machine :(
« Reply #19 on: March 14, 2015, 09:15:06 PM »
I am not sure of I can wire them to disable the drives and also still report as limits to Mach. I will have to look into it.