Hello Guest it is July 05, 2020, 05:05:29 PM

Author Topic: Mach ignoring limit switch broke my machine :(  (Read 9273 times)

0 Members and 1 Guest are viewing this topic.

Offline jevs

*
  •  315 315
    • View Profile
Re: Mach ignoring limit switch broke my machine :(
« Reply #20 on: March 15, 2015, 12:09:14 PM »
Alright. I am ready to fix this thing now.
Any ideas how I can wire the limits so that it either still reports to Mach in the diagnostics screen or lights an LED on my panel?
I can put them in series with the e-stop, but that won't specifically tell me a limit is tripped for diagnostics of what has gone wrong.
I suppose I could use a relay, but that will add a tiny more delay.
« Last Edit: March 15, 2015, 12:11:36 PM by jevs »

Offline BR549

*
  •  6,932 6,932
    • View Profile
Re: Mach ignoring limit switch broke my machine :(
« Reply #21 on: March 15, 2015, 01:30:18 PM »
You don't have to report to MACh3 as a limit hit even though you can. Just output a signal from the estop circuit to mach3 and from there activate a BIG FLASHY led to signal the OP that a LIMIT hit has occured.  No need to worry about what Mach3 is doing as the axis's are dead at that point . To resume you will have to totally reset mach3 and Refhome the machine again.

(;-) TP

Offline jevs

*
  •  315 315
    • View Profile
Re: Mach ignoring limit switch broke my machine :(
« Reply #22 on: March 15, 2015, 01:59:57 PM »
The problem is that there is no way to "output a signal from the e-stop circuit" from what I have.
If I wire the limits in series with the e-stop, then it Is just a string of NC switches.

On another note, using the machines original home switches is going to put my home in the opposite corner to what I had it set. Basically the spindle will be in the back right corner of the table. Is this normal?
I had it set so the head is in the front left corner when home. This seems more logical to think the head is moving from 0 to positive x and y values.
I think this may be why I did not use them in the first place.....

Offline BR549

*
  •  6,932 6,932
    • View Profile
Re: Mach ignoring limit switch broke my machine :(
« Reply #23 on: March 15, 2015, 03:48:57 PM »
Most relays HAVE 2 channels NO NC just use the one you are not using to control the Estop and map it to Mach3.

HOME can be anywhere you want it to be independant from the Home switch position. JUST set the offset. then when it refhome it sets HOME to wherever you want it to be on the table.

Just a thought, (;-) TP

Offline jevs

*
  •  315 315
    • View Profile
Re: Mach ignoring limit switch broke my machine :(
« Reply #24 on: March 15, 2015, 04:32:59 PM »
Have to think about that. The bad thing about that is that it will indicate a limit hit if you hit the E-stop. When in fact it has not been.
I had something that I thought was going to work. It seems that adding them with the E stop and trying to indicate a limit issue only when the limits are tripped and not the E-stop is the challenge (without adding more parts).

Just checked and my enable relay that kicks on the main relay is switching AC...so using that won't work.

One thing I might be able to do is run the 24 volts for the enable relay through all my limits, but I kind of hate to have the coil current on them all the time. I have no idea what their rating is. They are big and heavy duty looking with sealed connections etc, but I have no idea their rating.
« Last Edit: March 15, 2015, 04:38:17 PM by jevs »

Offline BR549

*
  •  6,932 6,932
    • View Profile
Re: Mach ignoring limit switch broke my machine :(
« Reply #25 on: March 15, 2015, 04:58:37 PM »
(;-) When you have to hit ESTOP you have lost all use of MACH3 anyway until you reset and re reference the machine so  I am not sure why you are worried about a LED flashing a warning. It will be very obvious that a problem has occured and IF you simply LOOK at the table it will be obvious where the problem is.

Just a thought, (;-)TP

Offline jevs

*
  •  315 315
    • View Profile
Re: Mach ignoring limit switch broke my machine :(
« Reply #26 on: March 15, 2015, 05:30:19 PM »
My mach is still reporting switch conditions etc even when E-stop is hit. E-stop kills the drives and stuff in my machine, but the IO board and computer are still on. Hitting the E-stop kills the enable output from the IO board that goes to the enable relay which kills the drives and anything that moves like the coolant, cabinet fans, way oiler. Mach is still active, just in E-stop mode, it just gets a signal on pin 10 that the E-stop was hit.

So, my thought was that it would be much easier to just look at the diagnostics screen and see the limits tripped and know instantly where the issue is. Sure I can figure it out, but it would be nice if Mach just said the limit was hit.

Offline jevs

*
  •  315 315
    • View Profile
Re: Mach ignoring limit switch broke my machine :(
« Reply #27 on: March 15, 2015, 07:14:29 PM »
EstopInput - Z Limit - Y Limit - Z Limit - E-Stop - E-stop output(+24 when circuit is open)
                                                       ^
                                                    Pin 1-15

This works.
Pin 1-15 will see 24V coming through the E-stop if any limit opens and the E-stop has not been pressed. This will light up the limit switch inputs in mach.
EstopInput will see an e-stop if anything opens and kill the drives.

The only thing is you will not see the limit active in mach if you hit the E-stop. This will open up 1-15 no matter what.

This could be a little tricky to diagnose, but in real life, if you hit the limit while moving it will show in diagnostics. At this point E-stop has been activated for you and your probably not going to hit the real E-stop since it already stopped.

Worst case scenario is that you do hit the E-stop and then the limit lights are not on in mach. You  might not figure it out until you undo e-stop and then they show lit again and nothing happens.

This does require a momentary enable switch across the limits if you ever want to move off the switch. You will have to hold the enable and reset mach and the E-stop if you pressed it. Then you can make a move.

The good thing is that Mach cannot ignore limits during a home sequence. If I have an axis past the home switch for some reason and reference home, the worst that will happen is an emergency stop.
« Last Edit: March 15, 2015, 07:29:19 PM by jevs »

Offline jevs

*
  •  315 315
    • View Profile
Re: Mach ignoring limit switch broke my machine :(
« Reply #28 on: March 15, 2015, 09:23:13 PM »
So it is all done now. Working like a charm. No more limit crashing ever! My override button works perfect and everything. I must have been thinking ahead, because I had 3 extra terminal blocks open to do everything and I had already labeled all the home switch wires I was not using :)

So, now when you turn off soft limits and jog z above home, then hit a reference all, Z will travel up and hit the limit. Mach ignores it (which is dumb), but it overrides everything and kills the drives anyway.

The only thing is, mach never thinks it went into an E-stop or anything happened and the Z numbers just climb forever unless you hit the E stop. It still thinks it is moving Z. Not a big deal, but if anyone knows a way to force it to acknowledge it has stopped, I am open to making it so it does know it was stopped.

Offline jevs

*
  •  315 315
    • View Profile
Re: Mach ignoring limit switch broke my machine :(
« Reply #29 on: March 15, 2015, 09:36:08 PM »
I do have a problem now that I am not sure how to fix. For some reason the natural home for this machine is at what would normally be it's positive extremes. The spindle is over the back right corner of the table.
Unless I change something, all machining will be negative.