Hello Guest it is June 17, 2019, 03:23:48 AM

Author Topic: Safer connection from Mach3 to X200 VFD?  (Read 6191 times)

0 Members and 1 Guest are viewing this topic.

Re: Safer connection from Mach3 to X200 VFD?
« Reply #10 on: February 17, 2015, 10:24:34 AM »
Pressing STOP in Mach3 should STOP the axis dead in their tracks NO movement.

(;-)TP


That's the way mine works.... pressing "STOP" kills any axis movement and raises the Z axis to home position. If your axis is still moving something is wrong or maybe you are using "Feed Hold" which will continue movement until the buffer is empty. I use "Stop" and "Run From Here" instead of "Feed Hold" to prevent tool crashing.
Re: Safer connection from Mach3 to X200 VFD?
« Reply #11 on: February 17, 2015, 06:05:56 PM »
Yeah I think I meant "feed hold".  I think that's the case where it shut down the spindle first but kept moving the axes.

Help me out here.  Feed hold can take a LONG time to stop, too long if there's a problem, even if the spindle getting stopped early wasn't happening.  But if I hit Stop, that can make the machine lose its position.  At least that's what the ESS plugin says.  It raises an error message in Mach3 that the Smoothstepper ran out of data and the position may be lost.  So it's no better than E-Stop in that regard.  Plus the Stop message is super-annoying, it throws itself on the screen and must be "OK"'ed manually to continue.

It's not unusual to see a problem with the work getting loose or realizing a hole was being drilled too deep.  I don't want to lose the machine's position here, that usually means ditching the stock and starting over again.  Is there any way to make it slow to a stop much sooner?  I did set the "lookahead" to 200 lines, but that doesn't change anything, does it?
« Last Edit: February 17, 2015, 06:12:41 PM by MechanoMan »

Offline BR549

*
  •  6,871 6,871
    • View Profile
Re: Safer connection from Mach3 to X200 VFD?
« Reply #12 on: February 17, 2015, 06:34:34 PM »
Bring the look ahead down to 10 or 20 that will speed UP the Stop process on feedhold as the buffer is not so large.

Just because you STOP and loose position  does NOT mean you cannot RESTART the program . IF you had refhomed the machine at startup then you simple refhome it again and start from a safe spot in the gcode with Run from Here.

(;-) TP

Re: Safer connection from Mach3 to X200 VFD?
« Reply #13 on: February 17, 2015, 07:36:21 PM »
The LookAhead is actually the buffer size that must be emptied?  Wow.  I thought that was just the lookahead for trajectory planning.

I was manually homing.  The machine doesn't have homing switches yet.  So losing machine position is kinda fatal.
Re: Safer connection from Mach3 to X200 VFD?
« Reply #14 on: February 17, 2015, 08:58:50 PM »
Ok... now getting more info as to the REAL problem. The ESS running out of data and losing position fault message is not a Mach 3 problem. It's a result of the ESS not configured correctly.

First... make sure you have the latest ESS plugin from the Warp 9 site.

1) Go to the ESS config page and change the Data Rate (upper left hand side) from the default 4Khz to 1Khz or 2Khz.
2) Calculate the ESS motor step frequency (right under the data rate box) and set for lowest frequency equal to or just above the calculated value. The Warp9 website has the procedure to figure this number. Or set the motor step freq number to the lowest one which I believe is 32khz.  
3) In Mach 3 set the kernel rate for 25Khz. The ESS does all the step calculations independent of Mach 3 so setting the kernel above 25khz just wastes PC CPU time and resources and adds absolutely nothing.  Also... it's been reported setting the kernel higher than 25Khz can result in Mach 3 calculation, DRO and trajectory errors with ESS.
4) Use Mach 3 ver 0.62. This version works with ESS and is recommend by Warp9. Do NOT, repeat NOT use V0.66... it has problems and should be avoided.
5) Set Mach 3 Look Ahead to 200.
6) Set CV to ON and turn off all other CV settings such as CV Dist, CV Speed, CV Stop angle. CV speed and dist is broken in Mach 3 anyway.

The Ess "Running out of data fault" is caused because the ESS buffer is running out of data (make sense right?)... the PC can't supply it fast enough. If you are still getting the fault change the ESS data rate to 1Khz. BTW... if you are wondering, increasing the Mach 3 kernel rate and the look ahead will NOT fix this problem.  

Now... run a G-code program and hit Mach 3 "Stop"... I bet the machine stops dead, G-code stops, Z axis goes up to home, VFD shuts off and no ESS error messages. Do NOT use Feed Hold. Then use Run From Here command... the program will start right where the Stop command was issued.

The Feed Hold function doesn't really work as one would assume unless you are running a very small look ahead buffer like 5... but this just creates other problems.

I have a ESS and run Mach 3 V0.62 with a VFD and it works good. I was getting running out of data faults after running 25 or 30 lines of code. Once I configured the ESS correctly... no more problems.    



  
« Last Edit: February 17, 2015, 09:13:55 PM by geh7552 »
Re: Safer connection from Mach3 to X200 VFD?
« Reply #15 on: February 18, 2015, 02:31:26 AM »
OK, tried all that.  Feedhold takes like 2 sec to stop on 3D carving with a lot of vectors.

Stop takes a full second- and still generates the "Smoothstepper ran out of data and probably lost position" error.

Played with the field of whether Mach3 or Smoothstepper implements Feedhold- no difference I can see.
« Last Edit: February 18, 2015, 02:44:43 AM by MechanoMan »
Re: Safer connection from Mach3 to X200 VFD?
« Reply #16 on: February 18, 2015, 07:26:33 AM »
Why are you STILL using Feed Hold?? Only use the stop command. Are you sure you set up the ESS correctly.

Open the ESS config page.... in the lower left hand set "Line PreCalculated" to 2000. 
« Last Edit: February 18, 2015, 07:28:55 AM by geh7552 »
Re: Safer connection from Mach3 to X200 VFD?
« Reply #17 on: February 18, 2015, 07:51:05 PM »
The Feed Hold name is misleading and the function should be removed from Mach 3 or made to work properly. With Mach 4 somewhat released all hope of fixing any Mach 3 bugs are a lost cause. I refuse to pay $200 for the privilege of installing an incomplete Mach 4 so I have no idea if Feed Hold works any better.  

What happens from my observations is it stops Mach 3 G-code processing but never send a stop command to the external motion controller. So... the external motion controller simply runs out of data when the Mach 3 buffer empties. This is the motion delay you are seeing. In the case of ESS, without a "stop" command being sent and runs out of data, it triggers a data failure and stops all motion. Same happens using Feed Hold with a PP... motion continues until Mach 3's buffer empties. This is dangerous IMO.

Using the Mach 3 "STOP" command an actual stop signal is sent to ESS so its not expecting more data and all motion immediately suspended until a "Run From Here" and then "Start" is received. That's why I said not to use Feed Hold... but for some reason you are insistent to keep using it.

The definition of insanity is doing the same thing over and over and expecting different results. (Albert Einstein)  
« Last Edit: February 18, 2015, 07:53:19 PM by geh7552 »
Re: Safer connection from Mach3 to X200 VFD?
« Reply #18 on: February 18, 2015, 08:13:24 PM »
I only mentioned Feed Hold for information.  I just want a Stop ASAP, without losing position, which means following the acceleration rules.  It might also necessitate having to complete the current G-code line (which could in some cases be a long move) if the program doesn't want to get too complicated.

But it's not doing that.  It's keeping a LONG buffer of operations around that it has to do through- for this 3D carving, there's a lot of moves in the 1 sec it takes to Stop, and yet still seems to fail to use acceleration rules, assuming the error message that comes up is accurate.

Knowing FeedHold takes even longer- 2 sec- is stranger knowing that it's taking longer than the commands already buffered.  But FeedHold seems to be the only way to accomplish a "correct" pause, provided the reason for the pause isn't too urgent.  Pushing "Stop" seems little different than "E-Stop" right now- you lose position, which seems to make it useless.

BTW, also, hitting FeedHold THEN Stop doesn't cause the "ethernet SmoothStepper ran out of data and probably lost position" error.  For what it's worth.

Re: Safer connection from Mach3 to X200 VFD?
« Reply #19 on: February 19, 2015, 02:44:32 AM »
Well I played with it some more tonight.  Nothing makes it Stop without error, or FeedHold soon enough.

The time to stop does scale with the reciprocal of Data Rate for both FeedHold and stop.  If I select 4KHz, FeedHold does stop within like 1 sec.  Which is better, but still not all that usable.  And the Stop still generates an ESS error, of course.