Hello Guest it is December 16, 2019, 07:18:12 AM

Author Topic: Safer connection from Mach3 to X200 VFD?  (Read 6481 times)

0 Members and 1 Guest are viewing this topic.

Re: Safer connection from Mach3 to X200 VFD?
« Reply #20 on: February 19, 2015, 10:50:40 AM »
What kind of stepper driver are you using? i.e. Gecko or a Chinese unit? I have a Gecko 540. Chinese TB6550 steppers do strange things and most never work right or fail all together.  

I'm out of suggestions. I'm convinced something in your Mach or ESS setup is not right. I have a old clunker Dell 6400 running XP home addition, 2gig memory... Mach V0.62. My ESS setup for 1khz data rate, 32Khz for steppers, precalc of 2000 and my system works without any issues. When I first started using ESS with the default setting of 4Khz I would get a out of data error after 20 or 30 lines of code especially with long x and y axis movement.

Pressing Mach "STOP"... x,y motion stops instantly, Z retracts to home, VFD shuts off.  G-code stops at the line the STOP command was issued. Then doing a "Run From Here" ---> "Start", it continues right where it left off. No ESS errors. I've run 3D Aspire files of 180,000 lines no problem.  

Feed Hold function in Mach 3 is a broken function and dangerous it should be fixed or removed. Maybe one of these years ArtSoft will have a version of Mach 4 where Feed Hold and CV actually work.  

The definition of insanity is doing the same thing over and over and expecting a different result. - Albert Einstein
« Last Edit: February 19, 2015, 10:56:09 AM by geh7552 »

Offline ger21

*
  • *
  •  6,291 6,291
    • View Profile
    • The CNC Woodworker
Re: Safer connection from Mach3 to X200 VFD?
« Reply #21 on: February 19, 2015, 11:29:30 AM »
I just want a Stop ASAP, without losing position, which means following the acceleration rules.

The only way to do that is to use Feedhold, followed by Stop (after motion stops).
Using Stop by itself will ALWAYS result in loss of position.

Get some home switches, and use EStop if you need to stop quickly. With home switches, you can quickly restart where you left off.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Safer connection from Mach3 to X200 VFD?
« Reply #22 on: February 19, 2015, 01:47:11 PM »
I just want a Stop ASAP, without losing position, which means following the acceleration rules.

The only way to do that is to use Feedhold, followed by Stop (after motion stops).
Using Stop by itself will ALWAYS result in loss of position.

Get some home switches, and use EStop if you need to stop quickly. With home switches, you can quickly restart where you left off.
So it's broken "for sure" then?  There's actually no way to make it come to a stop right away without ignoring acceleration and losing position?
« Last Edit: February 19, 2015, 01:55:32 PM by MechanoMan »
Re: Safer connection from Mach3 to X200 VFD?
« Reply #23 on: February 19, 2015, 04:20:49 PM »
Open the ESS config page and make sure the "Feed Hold Controlled by Mach 3" is checked. Do not use Controlled by ESS. The verify you setup ESS and Mach as I suggested several postings back.

Using stop will NOT result in a loss of position. When you are ready to resume cutting select "Run From Here" then "Start". A pop up window will open warning the axis is about to move, select OK, then select "Start" again. Note the G-code line number when Stop was pressed and again when "Run From Here" is selected.  If Mach and ESS are setup correctly cutting will start exactly when it left off.

On my system when I hit "Stop" (not E-stop)... x,y axis stop dead... Z retracts. Using the above steps I can resume cutting right where I left off... done it many times without issue.

Home switches will not solve your problem. Again, I'm convinced you have something setup incorrectly because you are all over the map troubleshooting, making changes, fixated on Feed Hold and acceleration for some reason. Could be your profile is corrupt. If you post your XML file I will take a look.    

As I said a few times... Feed Hold does not function as one would assume and it should be removed from Mach to prevent confusion and broken tool bits.



  
« Last Edit: February 19, 2015, 04:22:50 PM by geh7552 »
Re: Safer connection from Mach3 to X200 VFD?
« Reply #24 on: February 19, 2015, 05:14:31 PM »
I'm "fixated" on FeedHold only in that it's the one that actually operates without losing the position at the moment.

I tried both "Feed Hold controlled by Mach3" and "Feed Hold controlled by SmoothStepper".  Neither worked better.  

Not sure who to listed to.  ger21 says the opposite here, that Stop never worked without killing position.

My XML is not very complicated here.

How do you set it up to Z-retract?  Mine just stops dead where it is.  Z-retract seems to be a significant thing, because it sounds like it needs an arbitrary Z-height to go to.  Hmm that's a thing because often it's easier to zero the Z-axis on the work surface and carve in reference to that; if you did that with exceptionally thick material and used work coordinates the Z-retract could hit the machine's z-height limit.  geh7552, you clearly have something different going on, I'd like to know more.

Offline ger21

*
  • *
  •  6,291 6,291
    • View Profile
    • The CNC Woodworker
Re: Safer connection from Mach3 to X200 VFD?
« Reply #25 on: February 19, 2015, 05:30:37 PM »
Unless the Smoothstepper treats Stop as a feedhold, Stop will lose position, because it doesn't decelerate.

Feedhold is not "broken", it's just the way it works in a buffered system. It can't stop until the buffer is empty.

Go to Config > Safe Z and check the box to go to Safe Z on Stop. Safe Z must be enabled for it to work.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Safer connection from Mach3 to X200 VFD?
« Reply #26 on: February 19, 2015, 05:36:56 PM »
With all due respect, it's utter b.s. that a buffered system HAS to work that way.  World's full of buffered systems that alter the plan partway through, and for a realtime control system, it needs to be able to do so.

It's also not explaining why Stop still has to run out of data and lose its position. 





Offline ger21

*
  • *
  •  6,291 6,291
    • View Profile
    • The CNC Woodworker
Re: Safer connection from Mach3 to X200 VFD?
« Reply #27 on: February 19, 2015, 05:51:49 PM »
Stop loses position because it doesn't decelerate. That's why there's a Feedhold.
Fwiw, Feedhold in Mach4 is supposed to be instant. Unfortunately, mach4 has already taken 2 years too long.

I can't tell you why the SS doesn't work with Stop.

Mach3 has lots of minor issues like this that will never be fixed. That's why there's a Mach4.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Safer connection from Mach3 to X200 VFD?
« Reply #28 on: February 19, 2015, 08:24:12 PM »
Ok... let's start again from the beginning. BTW... I'm using Ger21 screen set which should have nothing to do with the problem.

Post your XML file please and are you using a custom screen set or Mach's standard screen set?

1) Create a NEW clean profile. I've seen profiles get flaky after making a bunch of changes even though it shouldn't. Don't worry about the VFD plugins for now.

2) You are using a Ethernet SS right....? Not the USB version. Make sure you are using Mach V0.62 and latest ESS plugin.

3) What type of PC and Windows are you using?

4) What make/model of stepper driver are you using?

5) What is you steps per unit settings and speeds?

6) In Mach set the kernel speed for 25khz. Make sure "Safe Z on stop" is checked.

7) Open ESS config page: Set data rate for 1khz, motor freq for 32Khz, Number of Lines PreCalc=2000.  
 
Let me know the above info and we can work from there.
Re: Safer connection from Mach3 to X200 VFD?
« Reply #29 on: February 20, 2015, 06:01:16 AM »
Hmm I tried again with 4KHz on the Data Rate.  It's... hey it's doing what I want!  The Stop is pretty immediate, and it's NOT giving the "position lost" error.

Also, bonus... I have the XHC wireless pendant.  It's been "great to have" but the response through Mach3 was super-laggy.  NOW it's behaving MUCH better!

I swore I tested it with 4KHz before.  I wonder if I could have reset the Data Rate before but somehow forgot to reboot Mach3?  Maybe power on the SmoothStepper had to be cycled and that wasn't mentioned?  Dunno but it's looking great!

I think the 4KHz Data Rate is important here.  It reduces the buffer's time length a lot.

It's a 48v G540 with 381oz-in steppers, rack-and-pinion.  That was moving at 1200 ipm no problem.  Toned it down to 600 ipm because there wasn't a reason to be doing that.

Grey Cary of Warp9 just emailed me back- unless you do a FeedHold, Stop will always cause some loss of DATA, and that it stems from Mach3's mechanics and can't be fixed except with Mach4.  I interpret that as saying position may not be lost, but it won't necessarily pick up in exactly the right place to follow the exact same path as if Stop had not been used.  Probably quite small.
« Last Edit: February 20, 2015, 06:12:54 AM by MechanoMan »