Hello Guest it is December 08, 2019, 06:26:33 AM

Author Topic: tuning motors  (Read 4655 times)

0 Members and 1 Guest are viewing this topic.

Offline sdow

*
  •  67 67
    • View Profile
tuning motors
« on: June 06, 2014, 11:47:51 AM »
Hi

When connected my drive to cs-mio/ip-a  .... my motor started to run .... why ? Can you help me ?   When i try to click on auto tuning PID  ... i have error ...ePID....

Thanks

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: tuning motors
« Reply #1 on: June 06, 2014, 05:04:06 PM »
Try reversing  the encoder in the plugin, see screenshot.
Hood

Offline sdow

*
  •  67 67
    • View Profile
Re: tuning motors
« Reply #2 on: June 07, 2014, 01:10:52 PM »
hu hood

my pid is good when Stop button is not activated my motor mont run ... but when i click on Stop ... the motor start to run +-40rmp/min ?

Offline sdow

*
  •  67 67
    • View Profile
Re: tuning motors
« Reply #3 on: June 07, 2014, 03:24:31 PM »
or when i close  mach3 my motor start to run +-40rmp/min

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: tuning motors
« Reply #4 on: June 08, 2014, 09:59:53 AM »
Your servo drives should only be enabled when Mach is in control. If they are moving when Mach is in Reset or fully closed then you do not have the servo drives controlled properly.
Hood

Offline sdow

*
  •  67 67
    • View Profile
Re: tuning motors
« Reply #5 on: June 08, 2014, 06:59:02 PM »
yes my drive have enable where i need to connect it on cs-mio

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: tuning motors
« Reply #6 on: June 09, 2014, 01:31:32 PM »
You can either use the enables in Mach itself or use the ones in the CSMIO plu8gin (Misc I/O page)

Hood

Offline sdow

*
  •  67 67
    • View Profile
Re: tuning motors
« Reply #7 on: June 09, 2014, 01:35:14 PM »
Can you give me the picture where i can find the configuration for enable the drivers ....exemple i would connect all my drivers to I/O 3 on csmio

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: tuning motors
« Reply #8 on: June 09, 2014, 01:43:29 PM »
It will depend on what signal your servo drives expect for their enable. If it is simply a positive 24v signal then you could just connect any output to the drive and configure that as an enable in Mach or CSMIO plugin. You can link all drives to the same output if you wish as long as the current draw isnt higher than the max output of the CSMIO (250mA if I recall)
Hood

Offline sdow

*
  •  67 67
    • View Profile
Re: tuning motors
« Reply #9 on: June 09, 2014, 02:15:25 PM »
i will probably use the relays    because my SON (enable ) need to connect to LG (GND) of my drivers .... i will use 4 relays each for one drive connected in parallel  to IO3 of csmio