Hello Guest it is March 02, 2021, 12:09:35 AM

Author Topic: Machine wont zero after Homing  (Read 19623 times)

0 Members and 1 Guest are viewing this topic.

Machine wont zero after Homing
« on: April 17, 2014, 01:43:49 AM »
Hi Guys

Any help much appreciated.

Background....

I have built an Openbuilds OX, 3 axis CNC Mill.
I have installed homeswitches on the x and y axis and added the home switches in ports and pins.
I have setup my table size limits in "Homing/Limits" and i have autozero switched on.
Motors Nema23 - Unknown brand.
TB6600 drivers
HyCNC 125-4L USB Board (Like a smooth stepper).

I used the "Set steps per unit" auto calc thing to set steps per unit for my motors - to move 100mm.
44.52 was the steps per value that made it move the correct distance. Seems low? - but distance moved fairly accurate...
I made velocity 3000, and acceleration 300 - To get a reasonable travel speed.. Is there something else i have to do to config the motors ?

The machine will home, i.e. it will travel until it hits the switches and then reverse until switch untriggered, however when i do this the machine will not zero.
Everytime i press Refall home, the machine homes but the machine and work co-ordiantes seem to decrease by about 3mm (Into the nagative).
So if I am homed - then i zero the work co-ordinates, then home again, the work co-ordinates and machine co-ordinates are decreasing (into negatives) by about 3mm every time i press ref all home.

Anyone got any ideas ?
Cheers
Martin

Offline Graham Waterworth

*
  • *
  •  2,274 2,274
  • Yorkshire Dales, England
    • View Profile
Re: Machine wont zero after Homing
« Reply #1 on: April 17, 2014, 04:40:38 AM »
If you turn off the Auto Zero then Mach3 will set the DRO's to zero, when on it will set the DRO's to the values in the home off entries in the home/soft limits dialog.

See section 5.6 in the Mach3Mill_1.84.pdf manual

http://www.machsupport.com/wp-content/uploads/2013/02/Mach3Mill_1.84.pdf


Without engineers the world stops
Re: Machine wont zero after Homing
« Reply #2 on: April 17, 2014, 07:34:37 AM »
Hi there... Thanks for your reply, however this is not working.

I have Auto Zero enabled and i have home switches.
I press "Ref all home" the machine finds the home switches ok, and reverses a few mm, but then does NOT set the machine co-ordinates to zero or the value of "home off".
It doesent appear to set them to anything.

It seems that the only way i can get machine co-ords to zero is to turn everything off and start again.
Any advice much appreciated.

Cheers
Martin
Re: Machine wont zero after Homing
« Reply #3 on: April 17, 2014, 08:26:56 AM »
Hi Martin,
   Using Version R3.043.057
Auto Zero un-checked (red X), DRO will not zero OR set to the Home Off value.
With Auto Zero checked, the DRO will set to the value set in the Home Off dialog, 0.000 by default.
Russ
 :)
« Last Edit: April 17, 2014, 08:30:02 AM by Overloaded »
Re: Machine wont zero after Homing
« Reply #4 on: April 17, 2014, 08:50:14 AM »
Might be an issue with the HyCNC 125-4L plugin.
Have you contacted them ?

Russ

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Machine wont zero after Homing
« Reply #5 on: April 17, 2014, 02:06:08 PM »
If you are definitely looking at machine coords (and not work offset) then I suspect it is as Russ mentioned, the external controller/plugin that is at fault.
Hood
Re: Machine wont zero after Homing
« Reply #6 on: April 18, 2014, 07:03:37 AM »
I have a simular setup, shut down mach3 software, unplug the usb cable, turn off the power to the motors, move all your axis to their zero point
power up the motors,  plugin the usb cable and run mach3.

highlight / enable machine cord's button and press the zero buttons, all the values will zero.

not sure if this is the correct way to do it but it works


Re: Machine wont zero after Homing
« Reply #7 on: April 18, 2014, 07:08:03 AM »
ignore that, got the wrong end of the stick
Re: Machine wont zero after Homing
« Reply #8 on: April 18, 2014, 07:55:16 PM »
Thanks guys.

But now i've got multiple problems. They are as follows.

1. Motors sound like they are randomly skipping beats as the axis moves up and down.

I assume this means that the motors are missing steps and that probably led to no 2.

2. I tried to cut my first part today - (A dust guard attachment to attach my hoover to), and the result is wildly off what was it was supposed to be. I mean like between 3-5mm errors across the piece.
Circles not circular etc. A complete waste of time...

Just to say - I have lost count of how many times i have set calibration across all axis with "set steps" and an accurate ruler, and it seems reasonably accurate in Jog Mode.
When you run gCode the head seems to wonder. It certainly never returns to 0,0,0 in the work co-ords.

3. Machine Co-ordinates won't zero as mentioned previously.

Could it be the HyCNC 125 USB board that is causing the inaccuracies and skipping, or is it more likely to be the stepper drivers?
Is it a set-up thing. I have spent all week on it and have got nowhere. Trying all kinds of settings.

I have these tb6600 drivers, and i have tried several mirco step options - 1/16  and 1/8th...
I have also adjusted the ampage pot up and down which made no difference.

http://www.mib-instruments.com/servlet/the-3453/TB6600-Stepper-Motor-Driver/Detail

Also these motors....
http://www.cnccheap.com/index.php?route=product/product&path=73_76&product_id=54

Seriously considering sending all of these electronics back. I can't spend much more time messing around with Chinese stuff to end up with no result.

Thanks for any help you can give me to get started....

Best Regards
Martin
Re: Machine wont zero after Homing
« Reply #9 on: April 18, 2014, 07:56:59 PM »
Piccyman - Yes thats what i have been doing to get a machine zero. Surely there must a problem.