Hello Guest it is March 06, 2021, 12:43:55 PM

Author Topic: Machine wont zero after Homing  (Read 19635 times)

0 Members and 1 Guest are viewing this topic.

Offline Tweakie.CNC

*
  • *
  •  8,664 8,664
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Machine wont zero after Homing
« Reply #10 on: April 19, 2014, 05:26:56 AM »
Hi Martin,

Sorry to hear that you are having problems getting everything to run correctly.

Just to be sure - you have set motor directions so that the origin (X zero – Y zero) is with the cutter at the bottom left hand corner of the work ??

It’s open to debate but this is what I would suggest…

Initially, I would recommend setting up your motor tuning steps per unit using 1/8 micro-stepping (there is little or no advantage in going to 1/16).
Set your motor current so that the motors will run warm to the touch but not so hot that you cannot hold your hand on them with comfort.

Check your wiring runs…
Inputs (limit / home switches, e-stop etc.) should be connected using shielded wiring, with the shield connected to a single point earth at the controller end. All other earth connections, including the machine frame, should connect to this single point earth. (If your wiring looks like a rats nest then that is asking for problems).

Mains wiring should be routed separately to the signal wiring (Inputs).

Perhaps posting a picture of what you have at present (layout of the wiring) may help with suggestions.

Hope this is of assistance,

Tweakie.
KEEP SAFE !
Re: Machine wont zero after Homing
« Reply #11 on: April 19, 2014, 09:11:40 AM »
Hello Martin,


I am using the 60khz version of the same card and the same Stepper Motor Driver, i had the skipping problem too, i set the motor driver on the nema 23's to 1/16 and 10000mm/m and acceleration to 125
I also switched to vista, that made a difference, for some reason a clean install of vista made a big difference, try doing a clean install of your OS and see if that helps.


My problem that Hood is looking at is, after moving away from the homing switch after homing the A axis won't stop moving away  :(

John
Re: Machine wont zero after Homing
« Reply #12 on: April 20, 2014, 01:36:53 AM »
Hi Guys.

Thanks for your replies.

I have not got shielded wiring. Do you really think that's the problem?
I made the decision about that after reading that it doesen't make much difference in a home environment and speaking to robocutters.co.uk where i got my kit from.
I couldent get the shielded wires in my carriers.....

I haven't got my A Axis driver yet, so i am not expecting the machine to be highly accurate, as the A lags behind slightly the Y.
However not 5mm out which is my experience so far!

Piccyman: I tried setting up a slaved A axis in Mach3. Then my Y homing switch did not stop the carriage at all.
Even though the light lit up on the diagnostics screen in Mach3, the machine did not stop when homing and pressing the switch.
I tested this a dozen times. The x still worked. So i think this is going to be another problem...
I was not planning on having any switches on the A Axis as i thought that would just follow the Y Axis. Is that not the case ?

Does your machine reset the machine co-ordinates when homed?

Running on Windows 7 - 64 Bit. Not keen on a fresh install to be honest, this machine is my main pc and has so much stuff on it. I honestly don't think thats the problem as its a top of the line PC with loads of power and graphics.

Tweakie: I tried the x axis on 1/8 and that made no difference to the skipping.

Yesterday i reinstalled mach3 and noticed that when i first fired up the machine that there was no skipping. Brilliant i thought. Fixed.
After 10 minutes the skipping seemed to return getting worse as time went on.

What would be the dogs in terms of alternatives to these electronics?
Reading the smoothstepper forum, it seems as some of those guys have similar problems as well - So i'm not sure that would necessarily help.

I have invested over £1000 in this machine, and i just can't accept a crap result in the parts that come out.

Thanks again for your help
Martin
Re: Machine wont zero after Homing
« Reply #13 on: April 20, 2014, 01:38:51 AM »
PS. Who is Hood ?
Re: Machine wont zero after Homing
« Reply #14 on: April 20, 2014, 02:36:48 AM »
Pics attached...

Motors skipping straight away this morning..

Cheers
Martin
Re: Machine wont zero after Homing
« Reply #15 on: April 20, 2014, 02:38:37 AM »
More Pics
Re: Machine wont zero after Homing
« Reply #16 on: April 20, 2014, 02:45:43 AM »
PS. My steps per seem really low compared to others i have read......
What makes my machine measure correctly in the auto set-up "Set Steps per unit" in mach3 is....

Steps Per : 44.31168831
Velocity : 1500
Acceleration : 300

Does that seem wrong?

Cheers
Martin
« Last Edit: April 20, 2014, 02:47:54 AM by mturneruk »
Re: Machine wont zero after Homing
« Reply #17 on: April 20, 2014, 03:28:15 AM »
What gears are you using on the y axis?

Offline Tweakie.CNC

*
  • *
  •  8,664 8,664
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Machine wont zero after Homing
« Reply #18 on: April 20, 2014, 03:58:45 AM »
Hi Martin,

Again, just my opinion…

Despite what you may have been told you do need to replace your inputs, switch wiring with shielded cables.
Looking at your pics you also need to change your ‘PSU to drivers’ wiring with a more substantial size of wire and connect ‘point to point’ not ‘daisy chained’.

Your Velocity and Acceleration settings look fine.

Tweakie.
KEEP SAFE !
Re: Machine wont zero after Homing
« Reply #19 on: April 20, 2014, 04:13:12 AM »
I have

Y Axis 36 tooth  pulley @ 2mm pitch, the steps/mm are 53.8354 vel: 10000 acc 125
X axis 20 tooth pulley @ 3mm pitch, 53.7268 gel: 20000 acc 125