Hello Guest it is June 26, 2019, 11:32:26 PM

Author Topic: tool change problem  (Read 2510 times)

0 Members and 1 Guest are viewing this topic.

tool change problem
« on: March 04, 2007, 06:31:12 PM »
here is a funny one too. when I program a M6 Comand and give a tool number, say T3 . in the program. when I exicute this. it will change the tool number on the program run screen but it does not load the tool offset until I manually click on the tool number, change it to a different tool number and then change it back????. almost ruined a very expensive part. but thanks to my trusty big red button, the crisis was averted. anyone know how to correct this? :o

Offline Chaoticone

*
  • *
  •  5,515 5,515
  • Precision Chaos
    • View Profile
Re: tool change problem
« Reply #1 on: March 04, 2007, 10:31:56 PM »
Hey GNBG,
    I would download the latest version and see if that helps with this one and the run from here issue.


Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!

Offline poppabear

*
  • *
  •  2,231 2,231
  • Briceville, TN, USA
    • View Profile
    • S S Systems, LLC
Re: tool change problem
« Reply #2 on: March 05, 2007, 08:26:40 AM »
Just for fun try putting in your program:

Tx M06 Hx     (put in the matching hiegth offset for that tool).

Scott
Commercial Mach3 & Mach 4, Design/Build/Retrofit CNC and Industrial machines.
http://www.ss-systems-llc.com/

Offline MarkC

*
  •  94 94
    • View Profile
Re: tool change problem
« Reply #3 on: March 05, 2007, 08:25:05 PM »
Try this:
Txx M06
G0 G90 G54 ********* Yxx etc, etc
G43 Hxx Zxx (H value matches T value)

And at end of tool, a G49 to cancel offset
Mark