Hello Guest it is November 15, 2019, 08:10:18 PM

Author Topic: outputs 4 and 5 on CSMIO  (Read 19839 times)

0 Members and 1 Guest are viewing this topic.

outputs 4 and 5 on CSMIO
« on: October 15, 2013, 03:46:50 PM »
just setting up mu ports and pins settings for my VFD  have configured the spindle CW to output 4 and CCW to output 5 and set the pins in the output signals to (output 4 port 10 pin 12) and (output 5 to port 10 pin 13 ) both enabled , but its not switching on the relay on the CSMIO ?? if i set the CW or CCW spindle settings to either 1,2,or 3 outputs they all energies but not 4 or 5 ?? what am i doing wrong ?
Re: outputs 4 and 5 on CSMIO
« Reply #1 on: October 15, 2013, 04:10:08 PM »
fixed ! was setting the output pins wrong !! its getting late

Offline MXJ

*
  •  14 14
    • View Profile
Re: outputs 4 and 5 on CSMIO
« Reply #2 on: July 16, 2014, 08:05:25 AM »
I am having the same problem!

Can you please send screen captures of your Mach 3 and CSMIO configuration screens?

Cheers

Max

Offline MXJ

*
  •  14 14
    • View Profile
Re: outputs 4 and 5 on CSMIO
« Reply #3 on: July 25, 2014, 09:51:18 PM »
Hi Guys

I can not get Output 4 changing state on or off, selecting the Spindle CW F5 button or using the M3 and M5 command, but I can put it on and off via the CSMIO Motion control Configuration changes
Can you please assist?
This is my set up->
Output 4 (No 1 relay) so Channel 10 Pin 12
In the Motor output Tab I have set the spindle Step Pin to 12 and the Step Port to 10
In the Output Signal Tab I have Enable ticked, Port set to 10, Pin number set to 12
In the Spindle setup Tab, Relay control, I selected Clockwise(M3) Output# to 4
CCW Output# to 4
In the motor control selected Use spindle motor control and Step/Dir Motor
In the CSMIO Motion control Configuration, Misc IO I have Output Nr selected to Output 4
When I selecting the Spindle CW F5 button, on the Mach3 Diagnostic screen output 4 comes on, but it is a slow flashing red, but Output 4 (No 1 relay) says low(off)
Where am I going wrong?

Cheers

MXJ
outputs 4 and 5 on CSMIO
« Reply #4 on: July 26, 2014, 11:59:11 PM »
Hi MXJ. What controller are you running. Also what type of drive are you trying to control.
If it is a Version 2 CSMIO/IP-S pin 12 is output number 14.
Let me know any details you can and I will try to help


Alan

Offline MXJ

*
  •  14 14
    • View Profile
Re: outputs 4 and 5 on CSMIO
« Reply #5 on: July 27, 2014, 12:08:23 AM »
Hi Alan

I am using a CSMIO/IP-M 4-axis Ethernet Motion Controller (step/dir) with version 2.1

Regards

Max
outputs 4 and 5 on CSMIO
« Reply #6 on: July 27, 2014, 03:24:01 AM »
Hi MXJ,

Can you please post a picture of the Spindle tab for the CSMIO plug in screen.


Alan

Offline MXJ

*
  •  14 14
    • View Profile
Re: outputs 4 and 5 on CSMIO
« Reply #7 on: July 27, 2014, 03:38:39 AM »
Hi Alan

Here is the spindle page.

Cheers

Max
outputs 4 and 5 on CSMIO
« Reply #8 on: July 27, 2014, 03:40:45 AM »
Hi Max,
From the plug in screen. Not the mach screen


Alan

Offline MXJ

*
  •  14 14
    • View Profile
Re: outputs 4 and 5 on CSMIO
« Reply #9 on: July 27, 2014, 03:52:18 AM »
Hi Alan

Here is the spindle page

Cheers

Max