Hello Guest it is December 15, 2019, 07:54:46 AM

Author Topic: Importing gcode changes format  (Read 1857 times)

0 Members and 1 Guest are viewing this topic.

Importing gcode changes format
« on: September 26, 2013, 07:04:52 PM »
Im running all week making a owl project suddenly today all the previous code that ran fine yesterday is bad.  Im using VCP and Cut3d.  Zero the machine all manual jogging reflects the correct movement in scale everythings ok.  Load up some new gcode from VCP and the numbers in mach 3 DRO jump to 300 moving the axis manually the 300 numbers stay in that scale feedrates jump to 2000. (Im thinking Im losing steps) I load up some old gcode from last summer and the numbers and DRO's jump back to normal single and double digital numbers.  The machine cant be losing steps.  Ive restarted rebooted everything removed replaced good mach3 config file.  Thinking of reinstalling VCP and Mach 3 What is causing this software glitch?

Offline BR549

*
  •  6,916 6,916
    • View Profile
Re: Importing gcode changes format
« Reply #1 on: September 26, 2013, 07:50:38 PM »
Sounds like the CODE was switched from G20 to G21 Inch to metric in the new code.  IF OLD code works fine then I would look at the CAM.

(;-) TP
Re: Importing gcode changes format
« Reply #2 on: September 26, 2013, 08:55:15 PM »
Is there a way to check the g20/g21 code? So something in vcp with an imported cut3d file imbedded in the vcp gcode is changing to metric in mach 3? Maybe my Cut3d file that is imported into VCP got switched to mm causing VCP to be switching itself into mm as well?  Attached is my xml file.
« Last Edit: September 26, 2013, 09:10:21 PM by robjeffking »
Re: Importing gcode changes format
« Reply #3 on: September 26, 2013, 10:21:37 PM »
Fixed I feel so dumb somehow  then toolpath output switched to Maxh 3 arcs to mm instead of inches