Hello Guest it is March 06, 2021, 12:39:37 PM

Author Topic: csmio  (Read 11929 times)

0 Members and 1 Guest are viewing this topic.

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: csmio
« Reply #10 on: June 23, 2013, 03:03:12 PM »
Does your servo drive have inputs such as Forward Clamp/Reverse Clamp?
Hood

Offline jve

*
  •  128 128
    • View Profile
Re: csmio
« Reply #11 on: June 27, 2013, 02:10:08 AM »
I managed resolve the spindle I installed a analog to analog isolated card and now the spindle is changing direction and very smooth now I need to install the encoder on the CSMIO ENC I have a 2500p/r would this be ok for the ENC?
the turret now it is indexing but I still need to fine tune the script so the only thing left is the encoder on the spindle and I will do some test

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: csmio
« Reply #12 on: June 27, 2013, 02:57:47 AM »
Sorry I forgot to look to see how I had done it :( But as you have it working now thats all that matters :)

Yes that encoder should be fine, that will be 10,000 counts per rev.

Hood

Offline jve

*
  •  128 128
    • View Profile
Re: csmio
« Reply #13 on: June 27, 2013, 10:49:02 AM »
I got it working the CSMIO ENC I change my mind and I made a encoder 200pulses that comes 800 pulses per revolution it seems it is working excellent even the dro (true spindle) it is exectly as the speed command value now I notice that I have a problem on the coolant pump and I will shortly test the machine
about the softlimits are they working on the mach3 turn?

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: csmio
« Reply #14 on: June 27, 2013, 01:44:48 PM »
Yes softlimits work exceptionally well with the CSMIO :)
Hood

Offline jve

*
  •  128 128
    • View Profile
Re: csmio
« Reply #15 on: June 28, 2013, 07:38:52 AM »
I notice that when I input code t606m6 the work coordinates come ok but when I input code t616m6 the work coordinates come the same as t606m6 then if I input again t616m6 the work coordinates change the value as it should be so I have to input t616m6 2 times is there any setting that im missing?

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: csmio
« Reply #16 on: June 28, 2013, 10:08:59 AM »
If you are using 066 or 067 version of Mach that could be the issue as there were problems I reported regarding tool offsets and tool numbers with one or both of these versions.
If its not one of these versions then attach your xml.
Hood

Offline jve

*
  •  128 128
    • View Profile
Re: csmio
« Reply #17 on: June 28, 2013, 10:38:39 AM »
yes it is 66 what is the best one?

Offline Chaoticone

*
  • *
  •  5,626 5,626
  • Precision Chaos
    • View Profile
Re: csmio
« Reply #18 on: June 28, 2013, 12:30:35 PM »
May want to wait for Hood to confirm or deny but I think he likes the 3.043.057 flavor.  You can find it and others at this link. ftp://machsupport.com/Mach/

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!

Offline jve

*
  •  128 128
    • View Profile
Re: csmio
« Reply #19 on: June 28, 2013, 12:47:03 PM »
I found  an other problem I tried a program in the air (without stock) and when it came for treading it went to reset but I am using the G76 as a treading cycle does it work with the csmio ?