Hello Guest it is January 22, 2022, 05:46:55 AM

Author Topic: Home/Limits  (Read 18596 times)

0 Members and 1 Guest are viewing this topic.

Home/Limits
« on: April 14, 2013, 08:42:42 AM »
Hi
Newbie desperately needing assistance from the leaned members of the forum please!

Machine specs:                    Home built 3 axis gantry driven router (1200 x 1200 x 100 mm work area).
                                        TB6560AHQ - 4 axis blue driver board - Mach3 software
                                        X & Y rack and pinion (mod 1.5 rack with 18 tooth spur gear driven from belt and pulleys 3:1 ratio)
                                        (motor 20 tooth,spur gear 60 tooth)
                                        4th axis slaved to X to drive gantry.
                                        Z axis is a directly driven 1/2"-10 5 start acme rod.
                                        SBC4 xml file over written into the Mach3 folder
                                        Limit switches are mechanical micro switches wired NC in series; each axis being wired to its own pin of the driver boards DB9 socket.

                          {Some manual adjustment to the xml file have been made while configuring Mach3 whilst setting up Input and Homing/Soft limit settings}

With the machine set with the SB4 xml file, with the A slaved to X, both the motors drive in the same direction without changing the config>ports & pins>motor output - dir active low setting of either motor.
All axis drive in the correct direction using either keyboard or jog buttons on the pop out mpg controller of Mach3.
However as soon as one checks and sets the pins for the config>ports & pins>input signals (as per driver-board manual) and sets up the config>home/soft limits as per Mach3 manual and tutorial videos; the direction in which the axis travel is reversed/opposite to what they did before setting up the home/limit switch settings. To get them driving in the correct direction the config>motor output>dir active low had to be checked for X to drive correctly together with the slaved motor. The setting was also checked for the Y and Z axis to also get them traveling correctly again.

When referencing the X axis; the master X axis motor drives in the positive direction, whilst the slaved A axis motor drives in the negative direction. A Mach3 stop is required to prevent the 2 sides of the axis from tearing themselves apart (no e-stop wired up). Once the e-stop has been triggered only the Ref A led turns to green.
I also notice that when trying to reference the master X motor drives in the positive direction and not towards the home side of the table.

From the driver board manual, the pins for the config>ports & pins>input signals can only be set:  X++   pin 10;     X--  pin 10;     Xhome  pin 10
                                                                                                                                             Y's to pin 11
                                                                                                                                             Z's to pin12

Does this effectively mean that the X-- and Xhome cannot be set to limit and a home switch when referencing (similarly for the Y and Z axis). In other words there are limitations to this board; as Mach3 states one can set for example: X++ to pin 10;   X-- & Xhome to pin 11

I also notice in the driver board manual: that the page depicting the settings for config>ports & pins>input signals the pin setting for the 4th axis is also showing pin 12. { should not the 4th axis be set to the same pin as the axis it is slaved to}

Also noticed in the manual and settings of the SBC4 xml file that the motor output> enable setting for all the axis is pin 14........ is this not an output pin for Mach3?

It seems I am confused as heck and in dire need of help in putting me on track.
Regards
Gary  ??? :o

Offline Chaoticone

*
  • *
  •  5,626 5,626
  • Precision Chaos
    • View Profile
Re: Home/Limits
« Reply #1 on: April 15, 2013, 10:29:06 PM »
I have sent you a PM.

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: Home/Limits
« Reply #2 on: April 16, 2013, 11:52:40 AM »
Hi
Having 2HDD's in the router's PC, I started fresh on the other HDD!(drives are booted separately from the BIOS)
The SBC4 xml file is supplied with the driverboard for basic configuration to get the motors moving .........supposedly!
I have done screen shots as a way of explanation/clarification of settings using the SBC4 file over writing the existing, my own motor tuning and my manual fiddling with the input, home limits and slaving settings. The only other change made by myself was the dir low active of Z to get it to travel in correct direction.
Other than the above I have not touched a thing......promise!

For now the following:
1. motors run fairly decently although a little slow and a slight resonance. Resolution....... will adjust motor tuning.
2. the mtrs drive the axis in the correct directions. e.g: press right arrow (keyboard) or X+ ( pop-out screen MPG) the axis moves in the positive direction away from home.
    the tuning was done individually and then A slaved to X ........ no other setting done to get them to run together in same and correct direction.
3. initially the Z axis went in the wrong direction i.e. press PgDn/Z- the axis traveled up toward home (negative dir.). Resolved ........ I changed the dir active low setting int motor          
    outputs. Will this have any bearing with home/soft limit settings, i.e. soft Max and soft Min?[/color]
4. When triggering either of the limit switches all 3 LED's light up for that particular axis. I accept this as the board states X++ X-- Xhome as pin 10 similary for Y and Z pins 11& 12. Pin                
    13 reserved for and E-stop switch. Is there a way around this so one can still use the limit switch as a home switch when referencing the axes?

Re: Home/Limits
« Reply #3 on: April 16, 2013, 11:54:40 AM »
The balance of screen shots
Re: Home/Limits
« Reply #4 on: April 16, 2013, 12:15:01 PM »
next

Offline Chaoticone

*
  • *
  •  5,626 5,626
  • Precision Chaos
    • View Profile
Re: Home/Limits
« Reply #5 on: April 16, 2013, 12:15:47 PM »
Post your xml file.  It looks like it is the standard Mach3Mill.xml  It can be found in your C:/Mach3 folder.  You will have to rename it to post it as the forum can not handle 2 files with the same name.

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: Home/Limits
« Reply #6 on: April 16, 2013, 12:17:59 PM »
had to change file names to get them posted
Re: Home/Limits
« Reply #7 on: April 16, 2013, 12:48:58 PM »
sent xml to your work mail address
Re: Home/Limits
« Reply #8 on: April 16, 2013, 12:59:42 PM »
The xml file is as the machine is with the above screen shots.

Offline Chaoticone

*
  • *
  •  5,626 5,626
  • Precision Chaos
    • View Profile
Re: Home/Limits
« Reply #9 on: April 16, 2013, 01:12:13 PM »
Gary, how does it do if you go to config./general config. and change the angular properties for the a axis to linear?  Its on the left top.

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!