Hello Guest it is May 08, 2021, 09:40:44 AM

Author Topic: unwanted creep in jog mode?  (Read 13685 times)

0 Members and 1 Guest are viewing this topic.

Offline comet

*
  •  325 325
    • View Profile
unwanted creep in jog mode?
« on: January 15, 2013, 08:36:45 AM »
Hi my mach3 set up has developed a strange fault,occasionally while jogging (i have 2 mpg's fitted) an axis will creep on continuosly without having the handle turned? and it will carry on creeping at about 30mmpm until you hit reset. it is random apart from it generally happens when you have been doing alot of jogging,ie setting up,I have actually broke a couple of tools now so any help will do.
  thanks
    Tony

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: unwanted creep in jog mode?
« Reply #1 on: January 15, 2013, 01:55:37 PM »
Do the DROs in Mach reflect the movement?
Do you have in step mode when using MPG?
Do you have a fairly low acceleration set for the axis?
Hood

Offline comet

*
  •  325 325
    • View Profile
Re: unwanted creep in jog mode?
« Reply #2 on: January 15, 2013, 02:00:13 PM »
Do the DROs in Mach reflect the movement?    Yes
Do you have in step mode when using MPG?   No
Do you have a fairly low acceleration set for the axis?    No

hope that helps

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: unwanted creep in jog mode?
« Reply #3 on: January 15, 2013, 02:03:39 PM »
Not really ;D was hoping at least one was the case ;D
Could still be noise on the encoder input but unlikely.
Can you attach your xml and I will look and see if there are any issues in it.
Hood

Offline comet

*
  •  325 325
    • View Profile
Re: unwanted creep in jog mode?
« Reply #4 on: January 15, 2013, 02:48:01 PM »
Sure ill brave the cold and nip out to the garage and copy it!

Tony

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: unwanted creep in jog mode?
« Reply #5 on: January 16, 2013, 02:56:53 AM »
looks like you froze on the way ;D

Hood

Offline Tweakie.CNC

*
  • *
  •  8,706 8,706
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: unwanted creep in jog mode?
« Reply #6 on: January 16, 2013, 03:18:29 AM »
Interesting problem this and I wonder what the solution will be.

This creep, very occasionally, happens to me but I have made a few observations…

When opening Mach3 the Reset is flashing – if it can be cancelled using the keyboard  ‘  character then the creep never happens. If the Reset can only be cancelled by clicking on the Reset button then creep can occur. My solution is to close and re-open Mach3 and only run it when the Reset can be cancelled by the keyboard  ‘  character.
I know it is just a work-around but it works for me.
My suspicion is that it is related to the way in which my PC handles USB keyboard etc. communications but I would love to know the definitive answer.

Tweakie.
KEEP SAFE !

Offline comet

*
  •  325 325
    • View Profile
Re: unwanted creep in jog mode?
« Reply #7 on: January 16, 2013, 03:46:48 AM »
tweaky, thinking about it this has only started since i put a cheap chinese usb button pendant on,which i would like to continue to use cos its so usefull, ill try your solution but as its random i doubt i'll have a quick answer. Hood, Yes it was just too cold here just south of birmingham (worcester UK) even colder today!

    Tony

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: unwanted creep in jog mode?
« Reply #8 on: January 16, 2013, 04:01:54 AM »
Ha ha lucky you dont live up in the Highlands, was -13.5C last night in some places.

Interesting about the keyboard, I dont use keyboard shortcuts at all.
Hood

Offline Hal

*
  •  60 60
    • View Profile
Re: unwanted creep in jog mode?
« Reply #9 on: January 16, 2013, 11:52:47 AM »
I wonder if the Chinese pendant is sticking or randomly resending the command? Is the creap the same as the last botton on the pendant? Can you try a ps/2 keyboard?

Hal