Hello Guest it is January 18, 2020, 04:02:57 PM

Author Topic: Mach 3 wants to start much lower than ZERO, tool offset IS turned off  (Read 4900 times)

0 Members and 1 Guest are viewing this topic.

Hey guys,

Can someone please enlighten me on what I might be doing wrong.  I'm using mach 3 with Vectric aspire.  It's been a couple months since my last cut and suddenly it has a mind of it's own.  I touch off the surface of the material with Z and Zero it out.  I'm not using any tool offsets and I did verify that it is turned off.  When I start the run, Z is plunges down MUCH further than it should be.  It should be going down to my Safe Z (0.2) and going on into the program from there. 

Anyone got any ideas?

Thanks.
Re: Mach 3 wants to start much lower than ZERO, tool offset IS turned off
« Reply #1 on: October 28, 2012, 07:40:59 PM »
does vectric call a toolchange at the start of the code, and set an offset. ?
Re: Mach 3 wants to start much lower than ZERO, tool offset IS turned off
« Reply #2 on: October 28, 2012, 07:52:49 PM »
Hi.  Thanks for trying to help. I verified an it's using Tool #1.  Actually everything I run is tool 1.  If there is multiple tool uses (end mill, vbit, ballnose), in my job, I break them up into multiple jobs.  1 job for each tool.
Re: Mach 3 wants to start much lower than ZERO, tool offset IS turned off
« Reply #3 on: October 28, 2012, 07:58:08 PM »
is the z axis going the right way, + up and - down

can you put the first dozen or so lines of code up. When Hood gets on here he'll look at your xml, so it might be worth posting that.
« Last Edit: October 28, 2012, 07:59:58 PM by angel tech »
Re: Mach 3 wants to start much lower than ZERO, tool offset IS turned off
« Reply #4 on: October 28, 2012, 08:41:23 PM »
Hi, Yes absolutely.  I will post a few lines of the gcode and the g540.xml file.  Yes, the Z does go in the right direction.  Just goes too far.

Thanks.

Offline ger21

*
  • *
  •  6,291 6,291
    • View Profile
    • The CNC Woodworker
Re: Mach 3 wants to start much lower than ZERO, tool offset IS turned off
« Reply #5 on: October 28, 2012, 08:56:07 PM »
Do you have a tool length in the tooltable? You're code uses a G43 length offset, so that could be doing it.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Mach 3 wants to start much lower than ZERO, tool offset IS turned off
« Reply #6 on: October 28, 2012, 09:06:29 PM »
HI Ger,  Thanks for attempting to help out.  I'm out in the garage look at the screen right now.  Tool 1 & ALL the rest of the tools are ZEROES across the board.  How can I turn that G43 off?

EDIT:  Are you saying the gcode has the g43 or the xml?
« Last Edit: October 28, 2012, 09:11:36 PM by Rotax91 »
Re: Mach 3 wants to start much lower than ZERO, tool offset IS turned off
« Reply #7 on: October 28, 2012, 09:43:16 PM »
I see this line:    N140G00G43Z0.8000H1

I have no idea what is telling it to put in a G43 though.     
Re: Mach 3 wants to start much lower than ZERO, tool offset IS turned off
« Reply #8 on: October 28, 2012, 10:30:28 PM »
I just edited the vectric mach 3 .PP post processor and took the G43 out of the header.

Gonna go try it now.

Does anyone have a newer vectric .pp file.  Mine is dated 12/15/09
Re: Mach 3 wants to start much lower than ZERO, tool offset IS turned off
« Reply #9 on: October 28, 2012, 10:57:28 PM »
Back in business!!!!  Taking that G43 out of the vectric mach3 post processor header did it.   I actually edited the .pp file to prevent G43 from getting put in ever again.