Hello Guest it is May 15, 2021, 02:04:00 PM

Author Topic: Unwanted Step Pulses  (Read 7195 times)

0 Members and 1 Guest are viewing this topic.

Offline Tweakie.CNC

  • *
  •  8,706 8,706
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Unwanted Step Pulses
« Reply #20 on: April 29, 2012, 12:58:01 PM »
Hi Alan,

My apologies, I did not mean to suggest that your software was not genuine I just wanted to clarify that you were not using trial or demo versions.


Offline RICH

  • *
  •  7,419 7,419
    • View Profile
Re: Unwanted Step Pulses
« Reply #21 on: April 29, 2012, 05:06:14 PM »
Good that you found the culprit Alan.........now I can go back to a good snooze. :D

Re: Unwanted Step Pulses
« Reply #22 on: April 30, 2012, 09:00:34 PM »
Just found this thread.  Glad you got it solved with the new lpt port.

I didnt see anything that listed any mach 3 settings.  I am willing to bed that your original problem was the step and direction pulse width.  I have seen this before a couple times.  Mainly when running very large Gcodes with tons of Z axis moves.

Upping the step and direction pulse widths cured the problems.

Offline kcib

  •  75 75
    • View Profile
Re: Unwanted Step Pulses
« Reply #23 on: May 01, 2012, 10:42:32 AM »
Hi Fixittt
thanks for your response , as a matter of curiosity could you tell me what settings you use on your "Z" axis ?? velocity and acceleration as well as pulse widths ?
Many thanks
Re: Unwanted Step Pulses
« Reply #24 on: May 02, 2012, 12:36:37 AM »
If it shows up again (now that I see it was fixed) I had a problem way back in releases that had to do with mach3 not handling a consecutive sequence of very small moves well.  The cam software I was using for 3D surfaces was set to allow scallops of nothing higher than .0001".  So there were a lot of very small moves that were stacked-up in the gcode and they were going plus/minus on all three axis. I can't remember what fixed it - maybe something to do with look ahead?  I might have had backlash enabled to correct for .002" or something and maybe turned it off?  It could have also been a release upgrade that fixed it.  You might want to try a test where you make steps or blocks that are only a few mil high and in straight lines.

« Last Edit: May 02, 2012, 12:38:52 AM by cncjerry »