Hello Guest it is July 20, 2019, 06:07:30 AM

Author Topic: z axis does not move  (Read 4240 times)

0 Members and 1 Guest are viewing this topic.

z axis does not move
« on: April 28, 2012, 04:12:13 AM »
hi everyone,

i have a cnc router which have 3 axis. my problem is two axis work fine but, axis z sometimes move just one direction sometimes it never moves sometimes it moves both directions for a very short time. could you please help me?

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: z axis does not move
« Reply #1 on: April 28, 2012, 05:00:49 AM »
Sounds like a wiring issue, check all wires are secure.
Hood
Re: z axis does not move
« Reply #2 on: April 28, 2012, 06:47:42 AM »
thank you hood,

i control the machine with an old laptop dell 505. when i start the z axis alone it works but when i start 3 axis simultanously only x and y move z does not. what do you think about the problem?

Online RICH

*
  • *
  •  7,342 7,342
    • View Profile
Re: z axis does not move
« Reply #3 on: April 28, 2012, 07:14:08 AM »
Using the MDI  type G0 X1 Y1 Z1 Then swap the cables or pin out in configuration for the Y and Z and do the same command in the MDI.
What happens?

RICH
Re: z axis does not move
« Reply #4 on: April 28, 2012, 07:27:21 AM »
hi,

when i do g0x20y20z20 and then g0x0y0z0 x and y always work. but z sometimes moves 20 sometimes not and also sometimes moves to 0 sometimes not
Re: z axis does not move
« Reply #5 on: April 28, 2012, 07:39:39 AM »
hi,

i changed the ports but main certain problem only two axis work. 3 of them do not work together

Online RICH

*
  • *
  •  7,342 7,342
    • View Profile
Re: z axis does not move
« Reply #6 on: April 28, 2012, 07:53:10 AM »
When you changed the pinout (same as physicaly swapping wires) the Z didn't move/ was still the problem?
RICH

Online RICH

*
  • *
  •  7,342 7,342
    • View Profile
Re: z axis does not move
« Reply #7 on: April 28, 2012, 07:54:39 AM »
Are you using steppers?
RICH
Re: z axis does not move
« Reply #8 on: April 28, 2012, 09:33:34 AM »
yes i am using step motors
Re: z axis does not move
« Reply #9 on: April 28, 2012, 09:35:34 AM »
x-y-z axis sometimes x-y work z does not, sometimes x-z works y does not, sometimes y-z work z does not.