Hello Guest it is January 29, 2020, 02:27:28 AM

Author Topic: Config problems - FTDI USB Driver Error  (Read 13011 times)

0 Members and 1 Guest are viewing this topic.

Config problems - FTDI USB Driver Error
« on: November 18, 2011, 10:44:10 AM »
Tried configuring my SS with the lockdown version of Mach (3.043.022) and the latest dev version (3.043.053) with the same result each time.
When I try to OK the SS configs in Mach (setting controller freq and axis step freqs etc) I get an error:

SmoothStepper_v17efb
Error returned from USB function FT_Write.
Error: FTDI USB Driver Error

Error = FT_INVALID_HANDLE

Bytes requested: 64
Bytes written: 26

This looks to me like the driver isn't correctly installed.  Also, I'm never getting anything other than a solid power light and solid INIT light on the SS.  Nothing to confirm the firmware has been successfully uploaded to it.

I'd appreciate any ideas anyone might have.  Thanks.
Re: Config problems - FTDI USB Driver Error
« Reply #1 on: November 26, 2011, 08:46:06 PM »
I'm having the same problem.  Switched to my desktop to make sure it wasn't the SS board.  Joy on the desktop, so there is an issue with the drivers (since my ports are working correctly).  Will let you know and what I didn't when I get it fixed on my desktop.
Re: Config problems - FTDI USB Driver Error
« Reply #2 on: November 27, 2011, 04:44:57 AM »
I haven't had a chance to work on the system since I found the error.  If I fix it I will post too.  Good luck and I look forward to hearing of your success.

Offline Jeff_Birt

*
  •  1,107 1,107
    • View Profile
    • Soigeneris
Re: Config problems - FTDI USB Driver Error
« Reply #3 on: November 27, 2011, 09:55:47 AM »
What version of the SmoothStepper driver and plug-in are you using? Try the latest plug-in and the dev version of Mach. Warp9 found that Mach had changed the way it worked with plug-ins and built the latest plug-in to work with the dev version of Mach.
Happy machining , Jeff Birt
 
Re: Config problems - FTDI USB Driver Error
« Reply #4 on: November 28, 2011, 06:39:52 AM »
Ok I have tried some more permutations, I can't get this to work.

Mach ver. 3.043.022 (lockdown version) with both 2.08.02 and 2.08.14 versions of the SS USB driver.
Mach ver. 3.043.053 (current dev version) with both 2.08.02 and 2.08.14 versions of the SS USB driver.

I'm using SS Plugin v17efb in all cases.

I get the same behaviour with all.  I have also tried 2 USB cables.  My computer is running Win XP if it makes any difference.

I notice you have Mach 3.042.040 and SS USB driver 2.08.02 on your site Jeff.  I'm going to try this as I guess this is a known 'good' combo.
Re: Config problems - FTDI USB Driver Error
« Reply #5 on: November 28, 2011, 10:30:18 AM »
Having trouble downloading Mach 3.042.040.
In the mean time I tried Mach ver. 3.043.053 (current dev version) with version 2.08.14 of the SS USB driver (current version) on a completely different PC running Win 7 64bit.  I get exactly the same message and apparent failure to upload the firmware to the SS.  Surely lots of people must have seen this?

Offline Jeff_Birt

*
  •  1,107 1,107
    • View Profile
    • Soigeneris
Re: Config problems - FTDI USB Driver Error
« Reply #6 on: November 30, 2011, 09:43:09 AM »
I use/sell a lot of SmoothSteppers and have not run into the issues you are having. The first thing I woudl do is uninstall everything. Then plug just the SmoothStepper in and look in Device Manager, what does it show up as?
Happy machining , Jeff Birt
 
Re: Config problems - FTDI USB Driver Error
« Reply #7 on: November 30, 2011, 11:14:36 AM »
Hi Jeff,
I have just fixed the issue.
When starting Mach up and selecting the use the SS plugin rather than the PPort driver, I would then be confronted with a message saying that some of the SS settings were not set (pulse frequencies etc that you configure in the Plugin Control menu).  There was an option to select to load some defaults (YES button) or load nothing and manually configure it in the aforementioned config dialog (NO button).  I was clicking NO and manually configuring it.  In the end I clicked yes and at that point the firmware was obviously flashed to the SS and the lights started flashing.  Everything was ok then.  The only problem is all of my settings have been wiped (ports and pins, motor tuning).  Small price to pay though.

Offline Jeff_Birt

*
  •  1,107 1,107
    • View Profile
    • Soigeneris
Re: Config problems - FTDI USB Driver Error
« Reply #8 on: November 30, 2011, 01:27:35 PM »
Glad to hear you got it sorted!
Happy machining , Jeff Birt
 
Re: Config problems - FTDI USB Driver Error
« Reply #9 on: December 12, 2011, 07:30:06 AM »
Sorry for being out so long, but work was taking up a lot of my free time.  I finally sorted out my problem, and it was simple.  My laptop runs Win7.  The desktop Vista 64.  All I had to do to solve my problem on the laptop was set the launch icon for Mach3 to run as administrator.  All the problems disappeared after that and I've not had any problems since.  I didn't have to do this with my desktop.