Hello Guest it is September 21, 2019, 08:30:09 PM

Author Topic: Mach3 stops and looses control  (Read 6985 times)

0 Members and 1 Guest are viewing this topic.

Offline Mogal

*
  •  76 76
    • View Profile
Mach3 stops and looses control
« on: November 09, 2010, 10:32:52 AM »
Hi guys, I'm kinda stumped here and need some help.
I have had my machine just over a month now, and still learning things(Its a home made unit)

I've made about a dozen things now, everything turned out as expected except for two items.
For whatever reason, the machine 'just stops' and I can not get the machine to restart.
The computer has not crashed, just that Mach3 stops executing the code. No error, and no reason.
Also if I try to jog the machine after its stopped, the DRO's change, but the machine still does not move loosing my references.
The only way to get control of the machine back, is to shut down Mach3 and restart it.
After doing that I run the code again(doing a ghost pass) and the entire code runs correctly.
I reset my axis and proceed to cut the new piece, and it cuts completely without error.

With no error code, and no known reason why it does this has me stumped. any thoughts?

My system:
P4C800E-Dlx with 2.4Ghz and 2gig mem.
Keling C10 breakout board and 425oz steppers
Windows 7 32bit, all (known) extras shut off (power save/screan saver ect...)
Mach3 for control and Vectric software to generate the GCode

Thanks for any input.
Chris

Offline Hood

*
  •  25,853 25,853
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 stops and looses control
« Reply #1 on: November 09, 2010, 10:46:53 AM »
Sounds like you may have something taking over control of the port, check you have no printers installed.
Hood

Offline Mogal

*
  •  76 76
    • View Profile
Re: Mach3 stops and looses control
« Reply #2 on: November 09, 2010, 11:10:20 AM »
Okay, thanks Hood. I'll check tonight after work.
Its a fresh install of Win7, and never had a printer installed, but there might be one by default.
I'll snoop around a little more for port hicups.

Chris

Offline Hood

*
  •  25,853 25,853
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 stops and looses control
« Reply #3 on: November 09, 2010, 11:20:44 AM »
I have never used W7 but I dont think there would be a printer installed as default, so not likely the issue.

When it stops do you see the Reset flashing?
Are there any messages in the ticker window at the bottom of the screen?

Hood

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: Mach3 stops and looses control
« Reply #4 on: November 09, 2010, 11:36:58 AM »
Sounds like maybe your drives are overheating and shutting down?

Art has said that if the DRO's show movement, then steps are being sent out. So if it's not moving when the DRO's change, it's most likely in your electronics.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html

Offline Mogal

*
  •  76 76
    • View Profile
Re: Mach3 stops and looses control
« Reply #5 on: November 09, 2010, 12:19:40 PM »
There is no flashing reset, there is no error codes. No indication of something wrong.
Gerry, I was (somewhat) thinking the same, but the system is cool to the touch. The cooling fan
doesn't kick in, as the system isn't warm enough.(its also pretty cool in the basement ;o))

Both times the system failed, it had only been running a couple of mins(maybe 20)
Even then, I would ghost pass the GCode imediately after, and then run again cutting without issue.
The electronics are warm, they've never really been hot(cooling fan would kick in periodically)
Its a pretty sparatic issue... only happening twice so far.

Thanks for the inputs... anything else I may try?

Offline Hood

*
  •  25,853 25,853
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 stops and looses control
« Reply #6 on: November 09, 2010, 04:17:50 PM »
It seems strange that Mach just stops, if it was just the machine that stopped then I would say electrical but as its Mach halting then I think it must be something in Mach. Would expect an error message of some sort though.
Do you have any Brains or Plugins or a macropump running?
Hood

Offline Mogal

*
  •  76 76
    • View Profile
Re: Mach3 stops and looses control
« Reply #7 on: November 09, 2010, 05:38:52 PM »
I'm so new this this, I have not dared to try any add-ons yet.
System is as installed. No brains(installed in the software or operater ;o))
No plugins or macropumps.
I'm not even sure what enhancements these provide yet.

Offline Hood

*
  •  25,853 25,853
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 stops and looses control
« Reply #8 on: November 09, 2010, 05:41:17 PM »
Can you attach your xml, might find something in there that is the problem.

Hood

Offline Mogal

*
  •  76 76
    • View Profile
Re: Mach3 stops and looses control
« Reply #9 on: November 09, 2010, 06:33:40 PM »
Here is the file, thanks for helping Hood!

Chris