Hello Guest it is August 18, 2019, 07:46:37 AM

Author Topic: Mach3 stops and looses control  (Read 6925 times)

0 Members and 1 Guest are viewing this topic.

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 stops and looses control
« Reply #10 on: November 09, 2010, 06:56:50 PM »
Dont see anything wrong with the xml. I see you have SoftLimits enabled, is there a chance that it is them that stop motion?

Hood

Offline Mogal

*
  •  76 76
    • View Profile
Re: Mach3 stops and looses control
« Reply #11 on: November 09, 2010, 07:49:44 PM »
No, I'm 99.99% sure its not the soft limits.
Its in the middle of the table, and when it happens the machine comes to a sudden stop...
doesn't gradually slow to a stop, also... no warnings...

I'll play with my hardware a little more, and see if I can come up with something.

Thanks Hood, muchly appreciated!

Chris

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 stops and looses control
« Reply #12 on: November 10, 2010, 02:30:59 AM »
So Mach definitely stops as well as the machine stopping but you get no messages, is that correct?
If you then press start again Mach, as well as the machine, will do nothing?

Hood

Offline Mogal

*
  •  76 76
    • View Profile
Re: Mach3 stops and looses control
« Reply #13 on: November 10, 2010, 09:32:49 AM »
So Mach definitely stops as well as the machine stopping but you get no messages, is that correct?
If you then press start again Mach, as well as the machine, will do nothing?

Hood

Correct, when the machine has stopping, pressing start again will do nothing.
I can press the buttons to jog the machine, but the machine does not move, although the
DRO does increase/decrease accordingly. I can flip pages, I can scroll through the code.
but no matter what I do, the machine will not move the code will not restart.

I have to shut down Mach3, reload it, load the code, and then it continues without error.

I know, weird huh? Could it be the hardware? causing this?

I did do through the computer last night, there was a default printer, Microsoft's XPS doc writer(whatever that does)
I also went through Black Viper website and selected the 'Safe' configuration, so a few more services where disabled.
([url]http://www.blackviper.com/Windows_7/servicecfg.htm[/url

Offline Mogal

*
  •  76 76
    • View Profile
Re: Mach3 stops and looses control
« Reply #14 on: November 10, 2010, 10:20:53 AM »
My machine is down at the moment, but if this ever happens again, I'll try to get some video of whats happening.
Hope to have it running again this weekend. (busted collet)

Offline docltf

*
  •  353 353
    • View Profile
Re: Mach3 stops and looses control
« Reply #15 on: November 10, 2010, 10:44:01 AM »
check your control power leads to your drivers.( both + -     ) it might be your 5 volt supply is cutting out or breaking down.


bill

Offline Glad

*
  •  19 19
    • View Profile
Re: Mach3 stops and looses control
« Reply #16 on: November 10, 2010, 08:09:28 PM »
Had similar problem, turnout to be an antivirus running on a background. Turned if off and no issues since.

Glad.

Offline Mogal

*
  •  76 76
    • View Profile
Re: Mach3 stops and looses control
« Reply #17 on: November 10, 2010, 10:00:44 PM »
Had similar problem, turnout to be an antivirus running on a background. Turned if off and no issues since.

Glad.
Hi, I have no AV on this computer... but MS's malicious software removal tool is/was running.
I now have is disabled thanks to Black Vipers website. Hope that deals with it!

Offline Mogal

*
  •  76 76
    • View Profile
Re: Mach3 stops and looses control
« Reply #18 on: December 01, 2010, 10:14:01 AM »
Hi Hood, anything with the XML file?
Asking, because after about 3 weeks of downtime, my first run, the machine did it again.
came to a clunking hult, and could not be restarted. I lost all control of the machine.

DRO would not move while trying to jog the machine.
I could flip between screens, I could press the start/stop buttons.
the timer would stop/reset, but the machine just would not move.

I took a picture of the screen, but didn't have time to upload it before work.
(will do it after work) oh, I took a small video too... but its pretty big, I have
to make it smaller and host it somewhere...

So after the machine came to a halt, I restarted Mach3, reran the code,
(From the begining with a new board) and it completed without issue.
So I don't think it can be the code.

Getting frustrated, as there seems to be no rhime or reason for this happening.

Thanks
Chris

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 stops and looses control
« Reply #19 on: December 06, 2010, 06:14:00 AM »
Sorry had a lightning strike on my router and have just taken delivery of the new one due to the bad snow conditions.

Your xml looked fine, are you still having problems?
Hood