Hello Guest it is January 26, 2022, 06:26:47 AM

Author Topic: Go Home  (Read 13965 times)

0 Members and 1 Guest are viewing this topic.

Offline Hood

*
  •  25,835 25,835
  • Carnoustie, Scotland
    • View Profile
Re: Go Home
« Reply #40 on: February 03, 2011, 10:34:26 AM »
Regards rge machine Zero, you need Auto Zero checked on the Homing and Limits page. If your Home position is not with the tool fully negative in X and Y and fully positive in Z then Home off values would be needed.
Hood

Offline rickw

*
  •  110 110
    • View Profile
Re: Go Home
« Reply #41 on: February 03, 2011, 11:08:21 AM »
Done! now I have all axis' enabled and homed but "A" (slaved to "X") on pin 12 and X, Y, and Z on pin 13 on the inputs signals screen. Now how do I set up home so when "machine coord's" is lit, to display machine 0,0? In other words, how do I set up homing correctly now that my inputs are correct and motors are running correctly? 

Offline rickw

*
  •  110 110
    • View Profile
Re: Go Home
« Reply #42 on: February 03, 2011, 11:15:32 AM »
Regards rge machine Zero, you need Auto Zero checked on the Homing and Limits page. If your Home position is not with the tool fully negative in X and Y and fully positive in Z then Home off values would be needed.
Hood

I want home position to be when X and Y are fully neg but when I travel to the switches, which are set to X,Y, and A home neg, the machine does not show 0,0. All are already set t Auto Zero by default and I have not changed them.

Offline Hood

*
  •  25,835 25,835
  • Carnoustie, Scotland
    • View Profile
Re: Go Home
« Reply #43 on: February 03, 2011, 11:24:05 AM »
Are you definitely looking at machine coords?
If so please attach your xml and I will simulate here and see if i can find the issue.
Hood

Offline rickw

*
  •  110 110
    • View Profile
Re: Go Home
« Reply #44 on: February 03, 2011, 12:26:01 PM »
The machine coord light is on and I it is not at 0,0. If I have the correct setting, and I trip the switch which is set to home and auto zero, shouldn't it auto zero on the DRO?

Offline Hood

*
  •  25,835 25,835
  • Carnoustie, Scotland
    • View Profile
Re: Go Home
« Reply #45 on: February 03, 2011, 12:34:09 PM »
Its working fine here in simulation so not sure whats wrong. Try disabling the A Axis home and limits and see if that helps for the time being.
What I did was simulated your Home switches, pressed ref all and Z starts moving up and I sim the switch it backs off stops and sets the machine coords DRO to zero then Y then X.
Justin case, r Machine coords is when button has red showing round it.
Hood

Offline rickw

*
  •  110 110
    • View Profile
Re: Go Home
« Reply #46 on: February 03, 2011, 12:50:07 PM »
No, it works, I clicked on ref all home and it did work great! I didnt know thats the button to use because it screwed up the tracking when I didnt have "A" set on its own pin. I get t now.

thanks Hood, if it weren't for you I would be hanging from a bridge..........