Hello Guest it is October 19, 2019, 06:55:46 PM

Author Topic: Machine not backing off switch when homing  (Read 10751 times)

0 Members and 1 Guest are viewing this topic.

Machine not backing off switch when homing
« on: March 31, 2010, 09:08:57 AM »
I recently upgraded Mach to 3.04 from 1.96. I thought the homing looked a little different. Upon a closer look the the X and y axises are not backing off the limit switchs when homing. The carridge hits the limit ,stops, and zeros out. Is there something in the Config area that I have not set correctly? I'm assuming I should be backing off the switch until it clears. This isn't a problem (I believe) untill I have to use the Plasma portion, will that change or effect my switch offset?

Thanks
Mike

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Machine not backing off switch when homing
« Reply #1 on: March 31, 2010, 09:24:27 AM »
sounds like your switches are a bit bouncy and you are needing to set some Debounce Interval, try setting to 2000 and if it helps reuce until you get the problem again then increase slightly. You will find it on the General Config page.

Hood
Re: Machine not backing off switch when homing
« Reply #2 on: March 31, 2010, 10:08:49 AM »
sounds like your switches are a bit bouncy and you are needing to set some Debounce Interval, try setting to 2000 and if it helps reuce until you get the problem again then increase slightly. You will find it on the General Config page.

Hood

Hi Hood,

I set it between debounce 2000 and 50000 and the gantry does not back off the switches. It zeros the DRO but the led remains red. If I manually jog off the switch about .250 the DRO turns green. Could it be a setting in the config area for homing switch settings. I'm fairly NooB at this so I appreciate your help very much.

Mike

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Machine not backing off switch when homing
« Reply #3 on: March 31, 2010, 11:21:17 AM »
No, there is no setting, it would seem for some reason Mach is seeing your switches close momentarily just after you have hit them. If you can try making up a fresh profile, even if its just with the basic settings for one axis to test. There have been a load of changes between your old version and the new and maybe its too many for your old profile to be good.
 Have you done anything else to the machine recently that may affect things?

Hood
Re: Machine not backing off switch when homing
« Reply #4 on: March 31, 2010, 11:26:27 AM »
Mike if you have to back off .25 try lowering the speed percentage in homing/limits under the config menu i have mine set between 10% &  20%

Phil
The Good Thing About Mach3, Is It's very Configurable

The Bad Thing About Mach3, Is It's Too Configurable
Re: Machine not backing off switch when homing
« Reply #5 on: April 01, 2010, 01:44:37 PM »
Well I could not get 3.04 to back off the homing switch no matter what the debounce and interval settings were. So uninstalled 3.04 and reinstalled 1.9, I set debounce to 600 and interval to 300, guess what , it homed and backed off the switch just as it should. ;D Figuring I had it "made in the shade" I uninstalled 1.9 reinstalled 3.04 set them to 600 and 300 and CRAP :-[ in stops dead on the switch and won't back off. ??? Are the units the same between 1.9 and 3.04. All settings were "as near as I could tell" the same between the versions. I must be missing a switch or something simple. I would like to stay with the latest version but if I can't get the homing to work properly I may be stuck with 1.9.

Any thoughts are mucho appreciated
Mike

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Machine not backing off switch when homing
« Reply #6 on: April 01, 2010, 02:53:23 PM »
Shouldnt make any difference but then again I have never had to use  debounce interval on any of my machines.
Are you using the same profile?

Hood
Re: Machine not backing off switch when homing
« Reply #7 on: April 01, 2010, 04:59:16 PM »
Shouldnt make any difference but then again I have never had to use  debounce interval on any of my machines.
Are you using the same profile?

Hood


Same profile, yes

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Machine not backing off switch when homing
« Reply #8 on: April 01, 2010, 05:39:37 PM »
Maybe worth trying one of the other recent versions to see what they are like, you will find them on the ftp site.
ftp://anonymous@machsupport.com/Mach/

Dont use R3.043.000 though as that was an experimental revision for tool comp and has known issues.
Hood
Re: Machine not backing off switch when homing
« Reply #9 on: April 02, 2010, 11:03:53 AM »
Maybe worth trying one of the other recent versions to see what they are like, you will find them on the ftp site.
ftp://anonymous@machsupport.com/Mach/

Dont use R3.043.000 though as that was an experimental revision for tool comp and has known issues.
Hood

Hi Hood
  The link seems to be broke.
 I have temporarily(I hope) downgraded back to 1.96 to get up and running. I can't seem to get 3.04 to home properly.

Thanks for everyones help
Mike