Hello Guest it is August 03, 2021, 04:11:09 AM

Author Topic: XBox360 Controller Plugin New User Info  (Read 121432 times)

0 Members and 1 Guest are viewing this topic.

Re: XBox360 Controller Plugin New User Info
« Reply #120 on: April 19, 2017, 08:50:47 AM »
Hi Thanks for the reply Lee, forget about it. Ive managed to replicate the same fault just using the Keyboard so it seems its the uc100 or its plugin at fault I coudnt replicate it like this before but just must have been a coincidence. sorry to bother you about it, i'll chase it up with the maker.
 
Re: XBox360 Controller Plugin New User Info
« Reply #121 on: July 15, 2017, 12:57:20 AM »
I see this is still an active thread, that is good.

i am building a new machine and have tried to get an x-box 360 wireless controller for windows to work. The plug-in worked ok, but when I tried to config, it said I need "dotNetfx3.5". I downloaded and tried to install it, and it said it needed more programs and to connect the PC to the internet. i do not have internet or even a phone line in my shop, so i cannot easily do this.

This is a brand new windows 10 with all the latest updates done to it.

Short of me taking it all apart, and putting it all back together in the house, to download this program, only to take it all apart again to take it back out to the shop...... any ideas?

Basically, I cannot open the button setup screen(after hitting config in Mach), and currently the controller will only move the X axis (if I push 3 buttons at once, while holding my tongue in the right place), and even then, it only sometimes worked.

Thanks for any insite.

ray

Offline Leed3

*
  •  162 162
    • View Profile
Re: XBox360 Controller Plugin New User Info
« Reply #122 on: July 15, 2017, 11:23:40 AM »
I see this is still an active thread, that is good.

i am building a new machine and have tried to get an x-box 360 wireless controller for windows to work. The plug-in worked ok, but when I tried to config, it said I need "dotNetfx3.5". I downloaded and tried to install it, and it said it needed more programs and to connect the PC to the internet. i do not have internet or even a phone line in my shop, so i cannot easily do this.

This is a brand new windows 10 with all the latest updates done to it.

Short of me taking it all apart, and putting it all back together in the house, to download this program, only to take it all apart again to take it back out to the shop...... any ideas?

Basically, I cannot open the button setup screen(after hitting config in Mach), and currently the controller will only move the X axis (if I push 3 buttons at once, while holding my tongue in the right place), and even then, it only sometimes worked.

Thanks for any insite.

ray

Hi Ray,

About the only option is to do as you suggested. I don't know what other files Windows 10 wants. Sorry I can't offer a better solution.

Lee
Re: XBox360 Controller Plugin New User Info
« Reply #123 on: July 15, 2017, 11:32:41 AM »
Ok, Thanks Lee
Re: XBox360 Controller Plugin New User Info
« Reply #124 on: June 27, 2018, 03:51:38 PM »
I'Ve installed the plugin but I can't get it to work. I'm using a clone controller from Speedlink and when I input the VID (1A34) and PID (0802) it won't save. It's not a read-only issue since I can change the button mapping without a problem. I can also save the correct values in the config file when input through an XML-editor. As long as I don't start Mach3 they remain correct but as soon as I start the values are returned to 0x0000. I must be doing something wrong but I can't for the life of me think what it is.

BTW the controller is fine. Windows diagnostics work and if I install the joystick plugin I can get X and Y moving.

Any help would be greatly appreciated.

Thanks
DB

Offline Leed3

*
  •  162 162
    • View Profile
Re: XBox360 Controller Plugin New User Info
« Reply #125 on: June 28, 2018, 12:56:00 AM »
I'Ve installed the plugin but I can't get it to work. I'm using a clone controller from Speedlink and when I input the VID (1A34) and PID (0802) it won't save. It's not a read-only issue since I can change the button mapping without a problem. I can also save the correct values in the config file when input through an XML-editor. As long as I don't start Mach3 they remain correct but as soon as I start the values are returned to 0x0000. I must be doing something wrong but I can't for the life of me think what it is.

BTW the controller is fine. Windows diagnostics work and if I install the joystick plugin I can get X and Y moving.

Any help would be greatly appreciated.

Thanks
DB

The plugin sets the values to 0 because the plugin does not recognize the controller as being valid. Some of the Speedlink controllers do not send valid packets to the driver so the driver doesn't know what to do with it.  Basically, you just need to get a different controller. The XBox360 controllers are pretty inexpensive.  Sorry I can't be more help.
Re: XBox360 Controller Plugin New User Info
« Reply #126 on: June 28, 2018, 01:33:26 AM »


The plugin sets the values to 0 because the plugin does not recognize the controller as being valid. Some of the Speedlink controllers do not send valid packets to the driver so the driver doesn't know what to do with it.  Basically, you just need to get a different controller. The XBox360 controllers are pretty inexpensive.  Sorry I can't be more help.


Thanks, Lee. At least I know it's not a case of my sanity.

Re: XBox360 Controller Plugin New User Info
« Reply #127 on: July 31, 2018, 11:57:24 AM »
Wondering if I could get some help installing an Xbox360 wireless controller to run
Mach3 on an XP computer.
I have installed the Microsoft software that came with the controller. Plugged the
receiver into the back of the  pc. The controller appears to have linked up to the
receiver since the green light in the upper left quadrant is on. Xbox 360 appears in
config plugins in Mach. It has been activated and I went into config and selected the options for the controls. The vendor ID and product ID are populated. I restarted the pc and opened Mach3 but the controls will not move any axis. 
Went into device manager and found Xbox360 peripherals and confirmed the driver
was loaded and the device shows as working correctly.
Checked Human interface Devices and per a trouble shooting document it should have
two files,  a USB human interface device and  HID-compliant game controller.
The HID-compliant game controller is missing which could be the problem but
not sure  how to install it.  Should it have been loaded with the software load or does it get installed some other way?

Thanks for any help
Richard

Offline Leed3

*
  •  162 162
    • View Profile
Re: XBox360 Controller Plugin New User Info
« Reply #128 on: August 02, 2018, 11:41:04 AM »
Sorry for not responding sooner but I have been pretty busy.  Are you still having problems with the controller?

Lee

Wondering if I could get some help installing an Xbox360 wireless controller to run
Mach3 on an XP computer.
I have installed the Microsoft software that came with the controller. Plugged the
receiver into the back of the  pc. The controller appears to have linked up to the
receiver since the green light in the upper left quadrant is on. Xbox 360 appears in
config plugins in Mach. It has been activated and I went into config and selected the options for the controls. The vendor ID and product ID are populated. I restarted the pc and opened Mach3 but the controls will not move any axis. 
Went into device manager and found Xbox360 peripherals and confirmed the driver
was loaded and the device shows as working correctly.
Checked Human interface Devices and per a trouble shooting document it should have
two files,  a USB human interface device and  HID-compliant game controller.
The HID-compliant game controller is missing which could be the problem but
not sure  how to install it.  Should it have been loaded with the software load or does it get installed some other way?

Thanks for any help
Richard

Re: XBox360 Controller Plugin New User Info
« Reply #129 on: August 02, 2018, 12:57:08 PM »
Thanks for responding. No, I finally got it working. It turned out to be a preset option on the controller that disables all the buttons when active. I disabled it and everything is working.
There is one thing you may be able to help me with. I have optioned all the buttons but I cant figure out how to option the controller to work the z axis touch probe. Any advice on how to get it working would be greatly appreciated.

Regards
Richard