Hello Guest it is July 13, 2020, 11:59:40 AM

Author Topic: New Mach User Interface - MachMe - Beta  (Read 25161 times)

0 Members and 1 Guest are viewing this topic.

New Mach User Interface - MachMe - Beta
« on: April 16, 2009, 04:17:59 PM »
This UI is  'Windows' oriented.  Contains seperate widgets for Jog, Spiindle, GCode.
It allows for the creation of USER DEFINED BUTTONS panels that contain buttons that contain GCode, VB Script or OEM buttons. These may be saved and reloaded when desired.  No need for scream4.
It also has a user defined LEDs panel for containing OEMLEDs.
Widgets can be scaled larger or smaller and there are multiple skins to select from to change the appearance.

There is a help file that explains each feature.

Zip file contains an installer and ReadMe.txt
It does not modify any Mach files or settings.
Upon installation you will have a menu folder for MachMe, that contains an uninstaller that removes the application.  There is an option on installation for a desktop shortcut.

I would appreciate any feedback on:
   Whether this approach is useful.  If so I can extend the UI to incloude DRO and Var panels.  Other widgets: Offsets, Tooling, Limits...
   What 'essential' controls are missing.
 
My machine does not have a spindle so any feedback on that widget is greatly appreciated.
I would like to know how this runs on other machines.  Specifcally older, slower and small memory machines.

TIA
RT

Offline Greolt

*
  •  956 956
    • View Profile
Re: New Mach User Interface - MachMe - Beta
« Reply #1 on: April 16, 2009, 06:37:28 PM »
RT

I have only just loaded your MachMe and have not got far

It did not ask for Mach3 location or profile.  Can I manually set these?

Can't get far till that is set.  Just says "IMach not Set"

Greg
Re: New Mach User Interface - MachMe - Beta
« Reply #2 on: April 16, 2009, 07:20:42 PM »
I think I'm seeing a pattern here.  Was Mach already loaded when you started MachMe?  If so, would you close it and start MachMe again?

To answer more directly, the registry should have an entry

HKEY_CURRENT_USER\Software\Mach3 controller\Settings\Mach Location

and

HKEY_CURRENT_USER\Software\Mach3 controller\Settings\Mach Profile

that are set the first time that MachMe is run.  I didn't think of the case that users would have Mach open on the first time, Doh!

Let me know.

Offline Greolt

*
  •  956 956
    • View Profile
Re: New Mach User Interface - MachMe - Beta
« Reply #3 on: April 16, 2009, 07:27:03 PM »
I think I'm seeing a pattern here.  Was Mach already loaded when you started MachMe?  If so, would you close it and start MachMe again?


No I did not even get that far.  It objected to a date and did not enquire further.

Greg
Re: New Mach User Interface - MachMe - Beta
« Reply #4 on: April 16, 2009, 07:43:25 PM »
Your a Brit aren't you?!

Sorry about that.  I will have to think more about international conventions.  Email me and I will send you another zip with proper English settings, I think. It will take me a while to figure how to get the localization data. Thanks for making the effort.

RT

Offline Greolt

*
  •  956 956
    • View Profile
Re: New Mach User Interface - MachMe - Beta
« Reply #5 on: April 16, 2009, 07:52:08 PM »
No, I could take offence at that.  ;D ;D ;D

I'm an Aussie.  There is a whole world out there that is not the USA.  ;D ;D ;D

Sent you a PM

Greg

By the way, why does it care what the date is?  Mach3 doesn't
« Last Edit: April 16, 2009, 08:01:33 PM by Greolt »
Re: New Mach User Interface - MachMe - Beta
« Reply #6 on: April 16, 2009, 08:47:18 PM »
Hi RT,
  I loaded this per instructions/readme and when I start it, it starts over and over...58 times before it stops.
Just me or what ?
Looks neat....what I can see of it.
Thanks
RC
Re: New Mach User Interface - MachMe - Beta
« Reply #7 on: April 16, 2009, 08:58:35 PM »
Looks don't mean diddly!

It sounds like you didn't choose a xml profile on the first startup.

could you check the registry for:
 
HKEY_CURRENT_USER\Software\Mach3 controller\Settings\Mach Profile

and let me know the entry?

Were these 58 times telling you something about missing DLLs"
Re: New Mach User Interface - MachMe - Beta
« Reply #8 on: April 16, 2009, 09:47:55 PM »
RT,
You're absolutely right about diddly!
I chose Mach3Mill XML when prompted.
Am dwnloading again..I un-installed. Dial up takes a few.
Will check reg. then.
During the 58 loadings (several minutes), your little screen just blinks and goes black erratically till done.
Thanks
Re: New Mach User Interface - MachMe - Beta
« Reply #9 on: April 16, 2009, 09:48:20 PM »
To answer more directly, the registry should have an entry

HKEY_CURRENT_USER\Software\Mach3 controller\Settings\Mach Location

and

HKEY_CURRENT_USER\Software\Mach3 controller\Settings\Mach Profile

I just tried this, and these entries were blank.  I didn't get prompted for a mach directory, or profile.  What should be in these registry values?  Full paths to mach.exe or just the directory and/or file.