Hello Guest it is October 17, 2019, 03:03:57 PM

Author Topic: New Mach User Interface - MachMe - Beta  (Read 23955 times)

0 Members and 1 Guest are viewing this topic.

Re: New Mach User Interface - MachMe - Beta
« Reply #10 on: April 16, 2009, 09:56:09 PM »
Tanks for trying.

the entries should be:

machLoc:   'C:\mach3\Mach3.exe' if that is where mach executable resides.

Profile:   'Mach3Mill' if your profile is Mach3Mill.xml

Did you also have Mach open when you first ran MachMe?  Trying to track down why the registry values were not written.
Re: New Mach User Interface - MachMe - Beta
« Reply #11 on: April 16, 2009, 10:09:22 PM »
Did you also have Mach open when you first ran MachMe?  Trying to track down why the registry values were not written.

No, I didn't have mach3 open, but I have a locked down box and install as Administrator.  I tried running both as a regular user and admin, but I still didn't get prompted.

Should I run machme before, or after I run mach3?

Other things to note...
- The application starts up underneath mach3.  I thought it was going be "always on top".
- If I run machme, without mach3 running, I get the "IMach not Set." when I hit the jog button.  If I hit the jog button a second time, the jog window comes up.  If I then hit one of the jog buttons, I get "Access violation at address 00491736 in module 'MachMe.exe'.  Read of address 00000000."
- If I hit the Editor button, I get "Access violation at address 005ad228 in module 'MachMe.exe'.  Read of address 0000004c."  Hitting it a second time brings it up.
Tanks for trying.

the entries should be:

machLoc:   'C:\mach3\Mach3.exe' if that is where mach executable resides.

Profile:   'Mach3Mill' if your profile is Mach3Mill.xml

Did you also have Mach open when you first ran MachMe?  Trying to track down why the registry values were not written.
Re: New Mach User Interface - MachMe - Beta
« Reply #12 on: April 16, 2009, 10:10:16 PM »
Tanks for trying.

the entries should be:

machLoc:   'C:\mach3\Mach3.exe' if that is where mach executable resides.

Profile:   'Mach3Mill' if your profile is Mach3Mill.xml

Did you also have Mach open when you first ran MachMe?  Trying to track down why the registry values were not written.

When I exit MachMe, it erase the registry entries!
Re: New Mach User Interface - MachMe - Beta
« Reply #13 on: April 16, 2009, 10:14:28 PM »
After new install, no prompt for files and still runs rampant.
I'm not familiar with the registry access procedure.
Is it simple enought to explain here ? O do I need a book ?
Thanks for any help,
RC
btw..I am in the Late Great USSA

Offline Greolt

*
  •  956 956
    • View Profile
Re: New Mach User Interface - MachMe - Beta
« Reply #14 on: April 16, 2009, 10:16:57 PM »
Probably need to edit the registry without MachMe running.

Yes staying on top would be good.  Maybe that is a setting.

Feedrate max to 200 is a bit limiting.  ;D

Still not remembering the skin despite having that option selected. 

Greg

Offline Greolt

*
  •  956 956
    • View Profile
Re: New Mach User Interface - MachMe - Beta
« Reply #15 on: April 16, 2009, 10:46:41 PM »
It occurs to me that you probably meant the feedrate setting to change the FRO percentage.

It sets the feedrate instead.

Greg
Re: New Mach User Interface - MachMe - Beta
« Reply #16 on: April 16, 2009, 10:51:32 PM »
RT,
 I fumbled around and ended up with this.
The little screen is good now but get errors on nearly every buton press.
Thanks,
RC
Re: New Mach User Interface - MachMe - Beta
« Reply #17 on: April 16, 2009, 10:58:53 PM »
MachLoc should be:  c:\Mach3\Mach3.exe  not c:\mach3
Re: New Mach User Interface - MachMe - Beta
« Reply #18 on: April 16, 2009, 11:19:52 PM »
Looking MUCH better now RT, thanks for sticking in there.
Looking more "DIDDLY" by the moment.
One weird one...Jog Control, Z, when I jog Z to any negative DRO value, it returns to ZERO when releasing the button.
RC

Offline Greolt

*
  •  956 956
    • View Profile
Re: New Mach User Interface - MachMe - Beta
« Reply #19 on: April 16, 2009, 11:23:52 PM »
I am not seeing that one RC.

However while MachMe has the focus I can not jog with normal keyboard keys.  MachMe jog panel showing or not.

Greg


Another thing,  (sorry RT)  is that no matter how many trailing zeros are shown in the DROs, all numbers are rounded to two decimal places.
« Last Edit: April 16, 2009, 11:27:00 PM by Greolt »