Hello Guest it is July 22, 2019, 05:22:55 PM

Author Topic: need help w/ initial set up of superior electric drives w/ mach3  (Read 12369 times)

0 Members and 1 Guest are viewing this topic.

I'm having difficulty setting up mach for the first time. I've never seen my motors run and can't get them to jog. My driver test comes out "system excellent". I've done everything in the videos for setting "ports & pins", motor outputs, and motor tuning. My guess is it needs an odd configuration in mach. Power supply is good. The motors have good holding torque but will not jog. I am entirely new to cnc & mach although I have had my machine a couple of years and have been watching the mach videos since. Any help at all would be greatly appreciated.
Rick

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: need help w/ initial set up of superior electric drives w/ mach3
« Reply #1 on: April 16, 2009, 10:52:50 AM »
Do the DRO;s show movement when you jog an axis? If not check the Jog Control is active.
Hood
Re: need help w/ initial set up of superior electric drives w/ mach3
« Reply #2 on: April 16, 2009, 12:10:45 PM »
yes, the DRO's show movement

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: need help w/ initial set up of superior electric drives w/ mach3
« Reply #3 on: April 16, 2009, 03:37:14 PM »
You got a link to a manual for the drives?
Can you attach your xml also?
Hood
Re: need help w/ initial set up of superior electric drives w/ mach3
« Reply #4 on: April 17, 2009, 02:33:38 PM »
Here is the address to my drive, MD808. Hate to sound completely ignorant...my xml ??? Thanks for your help.

http://mcsupplyco.com/uploads/images/drawings/pdf1/md808.pdf
« Last Edit: April 17, 2009, 02:40:38 PM by appalachiatools »

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: need help w/ initial set up of superior electric drives w/ mach3
« Reply #5 on: April 17, 2009, 02:42:54 PM »
Your xml is the Mach config file, you will find it in the Mach3 folder on your drive, if you use the standard mill profile it will be called Mach3Mill.xml, if you have a custom profile it will be the name of the profile.xml.
 Copy it to your desktop and then rename to appalachiatools.xml and attach using the additional options on the reply page.
Hood
Re: need help w/ initial set up of superior electric drives w/ mach3
« Reply #6 on: April 17, 2009, 03:29:51 PM »
I'm thinking this is what you want...I appreciate your help
--Rick

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: need help w/ initial set up of superior electric drives w/ mach3
« Reply #7 on: April 17, 2009, 04:04:33 PM »
Ok your xml looks fine assuming you have the pins asigned correctly with what you actually have connected. Your port address is non standard so I assume it is a PCI card, if so just confirm you have the address correct. If all checks out then remove the cable from the port and put a voltmeter between a Dir Pin and a Gnd pin and jog that axis one way then the other, the meter should show 0v one way and 5 the other, let me know how these tests work out and if needed we can go further.
Hood
Re: need help w/ initial set up of superior electric drives w/ mach3
« Reply #8 on: April 17, 2009, 04:31:42 PM »
I tested at my c10 parallel port card and got no reading at all on my dir (pin 3) ???. I've pulled the cable and will read at the pin itself in about 5 minutes when my son gets home...need a third hand. I'll let you know what I find. Thanks.
--Rick
Re: need help w/ initial set up of superior electric drives w/ mach3
« Reply #9 on: April 17, 2009, 04:51:11 PM »
OK...2.5 vdc constant on pin 3. Nothing changes when I jog in either direction. Same voltage on pin 2 and same results. When I plug the cable into the parallel port card, I get no reading at the pin (terminal) dir or pulse. The led on the card is on and there is 2.5vdc at the 5v terminals.
If you were referring to the I/O range setting for LPT1, it is 0378. There is another range under that that has a low of 0778. I had it set to that when I sent you the xml but changed it back. I have been trying everything I can think of in the ports & pins settings.
--Rick