Hello Guest it is July 12, 2020, 12:05:23 AM

Author Topic: How do I reverse the x-axis direction of travel?  (Read 40170 times)

0 Members and 1 Guest are viewing this topic.

Hood

*
Re: How do I reverse the x-axis direction of travel?
« Reply #30 on: July 18, 2006, 02:44:42 PM »
Make sure you click apply when you change a setting, probably not what was wrong but just a thought. Did you get any doccumentation with your setup? Or is it stuff you bought and connected yourself, ie Geckos or Rutex etc, PMDX, CNC4PC, SoundLogic breakouts?
Hood
Re: How do I reverse the x-axis direction of travel?
« Reply #31 on: July 18, 2006, 03:07:10 PM »
My setup is a K2 KG3925 CNC Router that I bought used with very low mileage. Everything is stock except that I have ABBA heavy duty ballscrews on the machine (there's a photo of it earlier in this thread) Motors appear to be Made by DGM. Not sure who made the limit swiches..

When not being jogged, the servos make a very feint creaking sound about every 2 seconds. I heard there's a setting in Mach3 whene you can limit power to the motors when not in use.
« Last Edit: July 18, 2006, 03:08:53 PM by Bagpipes »

Hood

*
Re: How do I reverse the x-axis direction of travel?
« Reply #32 on: July 18, 2006, 04:12:55 PM »
Just had a quick look at the K2 site but dont see any real details such as pins etc. Dont know anything about servos I am afraid as I only have had steppers on my mills.
There is a XML for Mach2 on their site and although I dont really know much about them it seems to look like you have one switch for each axis and they seem to be set for x=11 y=12 and z=13
 So go to config ports and pins, inputs and set as pic below.
If you then go to the Diagnostic page and your limits are lit go back and change the low active settings for each axis.
 Hood

« Last Edit: July 18, 2006, 04:27:16 PM by Hood »

Hood

*
Re: How do I reverse the x-axis direction of travel?
« Reply #33 on: July 18, 2006, 04:23:33 PM »
Also looks like you may need to set up the limit override as Port 1 pin 10 again not sure about whether active low should be ticked or not (eyes are going funny looking at all the text in the xml ;) ).
BTW this setting is lower down on the Inputs page. I am not sure what it is actually for but I presume you must have a button to disable your limits if they have been hit, pressing the button will allow you to jog off of them. There is also another way you can do this but if you have the button there is no need to go into that :)
Hood
Re: How do I reverse the x-axis direction of travel?
« Reply #34 on: July 18, 2006, 09:58:36 PM »
That's very helpful Hood - I will apply that to my settings and see what happens. I was trying to figure out those settings earlier this afternoon. Thanks for taking the time to dig through that xml. Will advise on my success/failure...
Re: How do I reverse the x-axis direction of travel?
« Reply #35 on: July 18, 2006, 10:24:05 PM »
Hood - great solution! Based on your .gif above I updated my settings. I was able to manually trip each limit switch by hand and got the expected lit up led's to confirm. Reset to continue, then I jogged each axis onto its limit switch and everything worked!! Hit the override and jogged off. Then tried hitting the Ref All Home button. The Z and Y axis referenced themselves correctly off the limit switches but the x-axis took off at a leisurely pace away from the limit switch towards the opposite end of the table. Obviously this has something to do with me reversing the x-axis direction.

Any thoughts on that?

Hood

*
Re: How do I reverse the x-axis direction of travel?
« Reply #36 on: July 19, 2006, 02:12:32 AM »
I think you need to go into config - homing and limits and change the Home Neg for that axis, possibly might even be the reversed option as was mentioned above by afn09556. You might also want to set up your soft limits while there and make sure that there is a tick in the Auto Zero for each axis.
Hood
Re: How do I reverse the x-axis direction of travel?
« Reply #37 on: July 19, 2006, 01:03:02 PM »
afn09556 and Hood - Many thanks .... enabling the Home Neg for the x-axis worked fine. Now all 3 axes know where home is and roll onto and back off the limit switches as they should when I hit "Ref All Home"..

I admit I don't know how to set up soft limits. What do they do?

Also - my DROs are reading much faster than the actual table travel. By eye - it looks like the DROs are registering one inch for each turn of the leadscrews. How to I calibrate that?

Hood

*
Re: How do I reverse the x-axis direction of travel?
« Reply #38 on: July 19, 2006, 01:26:15 PM »
Soft limits are basically an extra safety measure and also they save having to re-reference if you jog a bit too far. Normally if you did that you would hit a limit and have to re-reference (Home) but if you have the software limits set up the axis will stop before a limit is actually hit and you can just jog off and your reference is not lost. To set them up go to config then homing and limits then just put in the numbers for each axis, min will be 0 or maybe just above 0 and max will be the travel of each axis or just below. You can also set a slow zone so that the axis will start to slow as a soft limit is being reached and will help prevent overshoot and the hardware limit being tripped when the axis is doing a rapid.

 For your DRO reading too much you need to set up the steps per unit for the motors on each axis, there is a very easy way to do this, go to the settings page and you will see a Set Steps button. Click that button and follow the instructions for each axis, you will need a dial gauge or some other means of measuring actual distance travelled.
Hood
« Last Edit: July 19, 2006, 01:28:03 PM by Hood »
Re: How do I reverse the x-axis direction of travel?
« Reply #39 on: July 19, 2006, 02:53:58 PM »
So far so good - I set up the soft limits although it's hard to see if anything as been affected. Got the motors calibrated through set steps. That seems to be OK.

The only thing that remains unresolved is that, no matter what I check and un check in config/homing, my Y axis reads + goiing toward home and minus moving away from home. If I change checkboxes, I can reverse the +/- readout on the DRO but it thinks the limit switch is at the other (far) end and tries to go home at the wrong end. After trying endless combinations of checkboxes it's either on or the other :-(