Hello Guest it is November 24, 2020, 07:21:12 AM

Author Topic: Homing gantry with smooth stepper  (Read 11744 times)

0 Members and 1 Guest are viewing this topic.

Homing gantry with smooth stepper
« on: December 07, 2008, 09:15:08 PM »
Hello

Synopsis of problem:
I am having a problem with homing my gantry.  I don't know if it is something I am doing wrong with mach3 or it is a problem with smooth stepper. We upgraded to a smooth stepper board with a cnc4pc c23 breakout board then added a second limit to square up the gantry shortly after, so I never had a chance to test the parallel port second limit switch vs the second limit switch on smooth stepper.   The homing routine works fine the first time around (the gantry moves to the homes, backs off, then the slave axis moves back to the switch, everything zeros) but then it freezes my button macros and the mdi line, and I need to restart mach3 to get everything working again.

I read there has been some problems with the smooth stepper homing routine.  Is my problem the smooth stepper or something I am doing wrong.

below is a more detailed explanation of what I did that I wrote earlier today.

software specs:

•   Mach version: 3.041 upgraded to 3.042.020 (well get to that)
•   Smooth stepper: beta2 ver 015m
o   Fpga 34
o   Driver 2.04.05

Shortly after installing the SS and breakout we added another limit to our gantry router, to add auto squaring.  Before the maker of the router had the two drives hooked up in parallel to the y signal port, now we have them as Y and A slaved.

Upon getting the new limit to work seemingly properly I could not get it to square the gantry properly.
When I would adjust the numbers in the home/limits-home offset for our y and slaved A both the y and slave would move to the Y amount even though the numbers are different.  (I have, “home slave with master axis” unchecked in general config, but I have tried it both ways)
Another interesting thing that happened after this is after I would hit the home button I could not run any of my macro buttons or MDI line until I hit escape.
Another problem is sometimes when I hit home then I get both drive move toward home they back off the slave then keeps moving away from the switch even and the master stays put until everything binds up.

So today I downloaded and installed mach 3.042.020 and now when I hit home I cannot access the macros even after hitting escape.  They work fine before I hit home.
When I use the individual homing buttons on the diagnostic page they all work and don’t cause the hang up except for the slaved axis when I use it just homes doesn’t back off and I get a “cannot use g53 incremental”.  Then everything is frozen and I have to restart Mach3 to get things running again.
Upon writing this I just tried getting rid of my switch offsets all together in the home/limits.  Our switches are about an inch negative of where we want our origin.  And then everything seems to work fine after hitting home, until I enter g91 command, when I do that everything freezes after moving around and I get the g53 error again.  if I use g90 commands after homing i can re-home fine, with out the g53 error.


At one point we had a g100 installed, if that could cause some sort of conflict with the SS.


Thanks
Troy

Offline jimpinder

*
  •  1,232 1,232
  • Wakefield, West Yorks, UK
    • View Profile
Re: Homing gantry with smooth stepper
« Reply #1 on: December 08, 2008, 04:11:24 AM »
I have no idea about using axis as slaves - but reading your post, it would seem to me that perhaps the "home" input of the slave axis is not working properly. You say that your gantry will move to home, hit the switches - then you seem to say that one axis backs off and stops, but the other backs off, but carries on until the thing physically locks up. The keyboard etc is frozen until you hit reset.

It seems to me that the secong "pulse" on the second axis is not being detected. When homing, the switches are hit and go either positive or negative (depending on how you have it wired up), The direction of the motor is changed until your switch opens (or closes) again and gives the second signal to stop. It seems to me that the second signal (of the secod switch) is not getting to the computer. The computer is still waiting for the second signal, and therefore appears to be locked up.

If it is possible, I would run the gantry with each side alternatly free wheeling - remove the drive belt or something, so that the gantry can move, and the computer thinks all the electronics are fastened up. Then run the homing routine, and see if each side runs properly. I don't know how big a gantry you are talking about, and you might have to give it a gentle helping hand to keep straight, or whatever, but you sould see the basic movement at the switches.

Another possiblility has come to mind - I take it both switches home almost "together" time wise. I do not know whether you have these on the same circuit, or different circuits. As I understand Mach 3, the limit and home switches can be wired together. If "homing" is chosen, the system works as "homing" switches, until such time as the homing function is finished, and it then reverts to "limit" switches.

In your scenario - could the system be operating "home" switches  together - until one switch completes the cycle, and then the other switch becomes a limit switch. This woulld normally stop the system - unles you have "Auto limit overide" selected, which will allow it to carry on and back off the switch, therefore locking up your gantry.

If this is the case, you could probably write at Vis basic macro, so that homing takes place, using the drives together (but only one switch), then after the first axis has finished, moving the other axis (using the A drive on its own) "home". This should work.




Not me driving the engine - I'm better looking.

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Homing gantry with smooth stepper
« Reply #2 on: December 08, 2008, 04:15:07 AM »
I think there may be some issues with the slaved homing and the SmothStepper.  I will ask Greg to have a look here and maybe he can give you some advice. In the mean time check out the forum for the SS http://www.warp9td.com/index.php?option=com_fireboard&Itemid=33  and you may find some info.
Hood

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Homing gantry with smooth stepper
« Reply #3 on: December 08, 2008, 04:41:27 AM »
I have just spoken to Greg and he will look in as soon as he can.
 His father is about to go in for major heart surgery in the next few hours so his mind is understandably on things other than the SS at the moment.
  He gave me a link to a new plugin that addresses some slight homing issues, it is untested at the moment so test it with caution, here is the link http://warp9td.com/files/s/SmoothStepper_Beta2_v015meg.m3p It may or may not help out with your problems but again I will stress that its untested so proceed with caution and a hand on the E-Stop.

Hood
Re: Homing gantry with smooth stepper
« Reply #4 on: December 08, 2008, 10:22:45 AM »

I am pretty sure it is seeing the switches ok.  On the diagnostics page I can see both come on in a predictable manner.  The homing seems to work fine and predictable the first time around, and the second if I don't enter any commands, it sort of seems it happen only if I have gone into g91, or if I put home offsets in the home/limits dialog.  It is only after that that I get the weird behaviors.    It seems like the smooth stepper could be the culprit since it sounds like there have beens some problems with homing.

I have two circuits and only have them set up as independent home switches not limit switches.

I will sign up for the smooth stepper forum, in the mean time I will try that plug in out.


Offline Greolt

*
  •  956 956
    • View Profile
Re: Homing gantry with smooth stepper
« Reply #5 on: December 08, 2008, 03:54:01 PM »
Troy

If you suspect that the G91 being active is doing something odd to the SS why not add,

Code "G90"

to the beginning of the homing macro.  Worth a try just to see what happens.

Greg
Re: Homing gantry with smooth stepper
« Reply #6 on: December 08, 2008, 05:18:52 PM »
I am not sure about g91 being anything more then a symptom.

Todays observations with he new plug in.

When I home the gantry, when it is out of square, and the slave is leading the the master axis(slave hits its switch first)  the gantry keeps moving forward until the master hits its switch, then they both back off exept the master stops and the slave keeps going until everything binds.

When I hove the gantry, when it is out of square, and the slave is following the master axis (master hits its switch second) the gantry stops backs of the switches and everything works fine except the gantry is not square.
Re: Homing gantry with smooth stepper
« Reply #7 on: December 08, 2008, 06:24:49 PM »
Well

I unhooked the Smooth Stepper and went back to parlallel ports everything works great no matter how out of square the gantry is the homing routine re-squares it.  Although I have to live with more pulses per inch, which isn't as smooth.


Another observation with the smooth stepper I was able to jog the slave axis individually when I used the 4+- buttons on the jog screen you get when you hit tab.  Under straight mach3 I can no longer do this.  (it was only handy when I was trying to debug)
Re: Homing gantry with smooth stepper
« Reply #8 on: August 22, 2009, 08:02:24 AM »
I am updating a gantry & was wondering if the HOME SLAVING smothstepper problem has been fixed.

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Homing gantry with smooth stepper
« Reply #9 on: August 22, 2009, 08:08:57 AM »
I think it is fine if you have a home switch on both sides but cant be 100% sure as I dont have that. I know that on the coil winder I have two axis (spindles set as rotary axis) and they dont home properly as I only have a home switch on one. What happens is they both home together as they should but once the first switch is seen then the other axis will start searching for a switch. I have just disabled homing as I dont really need it in my application.
Hood