Hello Guest it is March 01, 2021, 11:52:29 PM

Author Topic: long pause on tool change in simulation  (Read 5651 times)

0 Members and 1 Guest are viewing this topic.

Offline ataxy

*
  •  31 31
    • View Profile
long pause on tool change in simulation
« on: November 27, 2008, 09:58:03 AM »
OK i have a little problem with the simulation mode i don't know if this is normal but is there a way to change the wait period on tool change in simulation when mach3 hits a line with a tool change it can wait sometime for an hour of simulated time before going on with the simulation. so a part that should have taken 1hr will take 4hr in simulation mode

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: long pause on tool change in simulation
« Reply #1 on: November 27, 2008, 10:46:21 AM »
What version of Mach? Do you have a toolchanger and custom macro?
Hood

Offline ataxy

*
  •  31 31
    • View Profile
Re: long pause on tool change in simulation
« Reply #2 on: November 27, 2008, 11:32:00 AM »
version 3.041, and no to both, i use it on a syilX4+

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: long pause on tool change in simulation
« Reply #3 on: November 27, 2008, 11:39:22 AM »
Try with the latest lockdown 3.042.020, if that doesnt help then attach your xml and might find something in that.
Hood

Offline ger21

*
  • *
  •  6,289 6,289
    • View Profile
    • The CNC Woodworker
Re: long pause on tool change in simulation
« Reply #4 on: November 27, 2008, 11:56:55 AM »
A lot of things don't work correctly in Simulation mode. It used to work fine, but I noticed it acting up somewhere around V 2.040. I used to use it all the time prior to 2.40 for testing code, but ever since then, I've needed to install the driver for accurate testing.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html

Offline ataxy

*
  •  31 31
    • View Profile
Re: long pause on tool change in simulation
« Reply #5 on: November 27, 2008, 12:13:17 PM »
ok ill try the lock down in any case here is the xml i am using

Offline ataxy

*
  •  31 31
    • View Profile
Re: long pause on tool change in simulation
« Reply #6 on: November 27, 2008, 12:32:53 PM »
nope still the same with the lockdown i get around 1hr wait period per tool change

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: long pause on tool change in simulation
« Reply #7 on: November 27, 2008, 01:27:40 PM »
Can you also please attach the code you are having a problem with, I have tried with 4 or 5 of the programmes I have and they are simulating fine.
 Also when you say simulating are you doing this on the machine itself or is it on another computer that doesnt have the driver installed like Ger has mentioned?
Hood

Offline ataxy

*
  •  31 31
    • View Profile
Re: long pause on tool change in simulation
« Reply #8 on: November 27, 2008, 01:52:06 PM »
no same computer

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: long pause on tool change in simulation
« Reply #9 on: November 27, 2008, 02:32:59 PM »
Is that the file that takes 4hrs in simulation for you?
Hood