Hello Guest it is June 19, 2019, 11:50:45 AM

Author Topic: GetOEMDRO(815) returns zero? Why?  (Read 2753 times)

0 Members and 1 Guest are viewing this topic.

Offline Zaae

*
  •  115 115
    • View Profile
GetOEMDRO(815) returns zero? Why?
« on: September 24, 2008, 11:25:24 PM »
Hello,

I've spent hours on the silliest problem. I have a script that uses
GetOEMDRO(815)
GetOEMDRO(814)

These are supposed to be for estimated time and elapsed time.

They both return zero, even though I can apply that value to a DRO in screen4 and the boxes count like they should.

When I try to go:
Myvar = GetOEMDRO(815)
or
msgbox GetOEMDRO(815)

it returns zero. I thought maybe I needed to dimension a variable to hold a date or time, and that just returns "12:00:00PM"


The purpose of all of this was to save the elapsed and estimated time to a file every minute or so, so the file could be read remotely to see how much time remains. I also have a lot of experience with AutoHotkey, and so far, I have been unable to extract the value of the text boxes either. I'm really stuck.


What am I doing wrong?

TYIA!
Z
« Last Edit: September 24, 2008, 11:53:14 PM by Zaaephod »

Offline zealous

*
  •  492 492
  • HI!
    • View Profile
    • Artsoft Solutions
Re: GetOEMDRO(815) returns zero? Why?
« Reply #1 on: September 26, 2008, 09:06:00 AM »
Hi,
You cannot return those values in Mach using VB...you can only return those values in Flash.
It will have to be a requested addition that you will have to ask Brian for.

I would also like to also mention that the limited VB that we do get from Mach does not support many date and time functions either :(

Offline zealous

*
  •  492 492
  • HI!
    • View Profile
    • Artsoft Solutions
Re: GetOEMDRO(815) returns zero? Why?
« Reply #2 on: September 26, 2008, 09:08:16 AM »
I would use a Flash screen and connect directly to your server...no need to even right to a file :)