Hello Guest it is June 17, 2019, 03:26:59 AM

Author Topic: TURN Macro Need Help  (Read 3663 times)

0 Members and 1 Guest are viewing this topic.

TURN Macro Need Help
« on: August 20, 2008, 09:46:28 AM »
:)
Little Macro, M778

ActivateSignal(OUTPUT3)
Code"G4 P2"
DeActivateSignal(OUTPUT3)

OUTPUT3 Enabled, Port 1, Pin 1, Active High    (PMDX 122 on-board relay)

Step through in the Editor screen and it works fine,
MDI M778, get nothing except the DWELL LED comes on for the duration of the G4.

Thanks for any HELP,
RC

Offline Chaoticone

*
  • *
  •  5,502 5,502
  • Precision Chaos
    • View Profile
Re: TURN Macro Need Help
« Reply #1 on: August 20, 2008, 10:11:38 AM »
RC, post your xml profile please.

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: TURN Macro Need Help
« Reply #2 on: August 20, 2008, 10:25:28 AM »
 :)

Offline Chaoticone

*
  • *
  •  5,502 5,502
  • Precision Chaos
    • View Profile
Re: TURN Macro Need Help
« Reply #3 on: August 20, 2008, 10:45:30 AM »
RC, Output 3 is not enabled in the XML you posted.

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: TURN Macro Need Help
« Reply #4 on: August 20, 2008, 10:48:57 AM »
Hmmmm...I'll go out and check again...but I would have sworn it was.
My home PC blew up, I'm temp. on an antique laptop.
Be Right Back,
Thanks Brett
Re: TURN Macro Need Help
« Reply #5 on: August 20, 2008, 11:03:04 AM »
Ahhh....Brett, I had 3 temporarily disabled while enabling the A axis dir pin to operate a relay instead.
3 is enabled now but still, MDI M778 is as mentioned before. Step through the editor ... it works..but not with MDI.
Re: TURN Macro Need Help
« Reply #6 on: August 20, 2008, 11:05:32 AM »
Also....I can toggle the Pin 1 Active High/Low check-box and the relay operates as it should.

Offline Hood

*
  •  25,843 25,843
  • Carnoustie, Scotland
    • View Profile
Re: TURN Macro Need Help
« Reply #7 on: August 20, 2008, 11:05:45 AM »
RC
Try this

Hood


ActivateSignal(OUTPUT3)
Code"G4 P2"
While IsMoving()
Wend
DeActivateSignal(OUTPUT3)
Re: TURN Macro Need Help
« Reply #8 on: August 20, 2008, 12:35:05 PM »
Hood, what you suggested works....but not at first.
Only after restarting Mach.  weird  Should one have to restart for a macro to work ?
Mach was also stuck as I could not open another GCode file.
After restart, all is GOOD.
Thanks a bunch guys,
RC

Offline Hood

*
  •  25,843 25,843
  • Carnoustie, Scotland
    • View Profile
Re: TURN Macro Need Help
« Reply #9 on: August 20, 2008, 01:40:05 PM »
No should work after its been written and saved but then again this is computers we are talking about ;)
 Actually sounds like your VB was caught in a loop and the restart killed it.

Hood