Hello Guest it is July 11, 2020, 05:23:48 PM

Author Topic: How to start spindle after upgrade from Mach2  (Read 2272 times)

0 Members and 1 Guest are viewing this topic.

How to start spindle after upgrade from Mach2
« on: July 19, 2008, 01:53:17 PM »
Hi guys. I promised to move to Mach3 and all has gone smoothly, bit by bit. I can move xyz no problem, but I can't start the spindle. I have read and reread, and tried every combination of settings, but no. I guess the info I need is in the mach 2 settings, but I can't spot it.
Any ideas where to look, what to select?

Thanks,
 Jim

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: How to start spindle after upgrade from Mach2
« Reply #1 on: July 19, 2008, 03:00:58 PM »
Please look in your Mach2 and Mach3 folders and  zip and attach to the forum both of the xml's . If you are using the standard mill profiles the xmls you are wanting is Mach2Mill.xml and Mach3Mill.xml

Hood
Re: How to start spindle after upgrade from Mach2
« Reply #2 on: July 21, 2008, 01:05:30 PM »
Thanks Hood.
Here are the files. When using mach2 I select the profile routerg, which I attach also.
I have had a brief try earlier, and now I can't get any movement, it may be me being a numpty, maybe it's something in the files you can tell me about. Anyway, here they are.
Thanks
Jim

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: How to start spindle after upgrade from Mach2
« Reply #3 on: July 21, 2008, 03:47:01 PM »
OK first thing I noticed is on Ports and Pins then Spindle setup, you have the relays both set for OutPut1 and you have  them as Output 3 and 2 in Mach2.
Also you have Enables 2,3 and 4 active and using same pins as other outputs, you need to disable them.
Again on Ports and Pins, Spindle Setup you have the flood disabled and also you need to set it up to Output 1.

Try these things and get back if its still not working and I will look again.
Hood