Hello Guest it is June 25, 2019, 04:56:54 PM

Author Topic: z-axis problem  (Read 7050 times)

0 Members and 1 Guest are viewing this topic.

Online Chaoticone

*
  • *
  •  5,514 5,514
  • Precision Chaos
    • View Profile
Re: z-axis problem
« Reply #20 on: June 30, 2008, 11:59:02 PM »
Euro, If it is the code that changed it, it would probably be a G20 or a G21 but the ratio isn't 10-1. It will put your machine in Imperial or metric units. Go to MDI and typr in G 20 G 50 and hit enter. Now type G1 X1 F10. Does it travel 1 inch? 

Micro steps are not set in Mach, they would be set on the drives. If you haven't changed anything mechanically, I doubt this is the case. Some drives change this option with dip switches, others with jumpers I think (possibly one fell off due to vibration?) and others aren't adjustable.

Brett
« Last Edit: July 01, 2008, 12:01:59 AM by Chaoticone »
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: z-axis problem
« Reply #21 on: July 01, 2008, 12:04:19 AM »
I dont know how the G code could change it to where a G50 would not clear it if it was scaled. I'm almost certain that it would not change the configuration settings in Mach.
Did you CLOSE the G code in Mach before you did the jogging ?
There could be an active G51 in the loaded code...if there is a program loaded.
Anyway, G50 Z.378 in MDI would clear it.....I think,
RC
Re: z-axis problem
« Reply #22 on: July 01, 2008, 12:17:26 AM »
Euro, I see in your first post now ...you said you jogged the X axis UP. I mistook this for the Z axis. Sorry
Good luck guys,
I'll check back tomorrow.

Brett, I just thought we could verify with the steps per setting before going into the hardware panel.
AMF,
RC

Offline euro

*
  •  14 14
    • View Profile
Re: z-axis problem
« Reply #23 on: July 01, 2008, 01:40:43 AM »
you were right brett the moter tunning was wrong thanks,everything is good now,back to relax,this is a great forum

Online Chaoticone

*
  • *
  •  5,514 5,514
  • Precision Chaos
    • View Profile
Re: z-axis problem
« Reply #24 on: July 01, 2008, 02:07:42 AM »
No problem, glad you are sorted.  :)

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!