Hello Guest it is May 24, 2019, 05:42:39 AM

Author Topic: feedrate override and G00's  (Read 3700 times)

0 Members and 1 Guest are viewing this topic.

feedrate override and G00's
« on: June 29, 2008, 11:19:24 PM »
I was cutting some steel for the first time on my X3 yesterday and decided it could go a bit faster than my conservatively set feedrate so I used the feedrate override (to 160%) and immediately lost position on Z when it hit a G00 which means it was trying to move faster than the "tuned" speed. Is FRO supposed to keep the feedrate under the tuned speed?



Re: feedrate override and G00's
« Reply #1 on: June 29, 2008, 11:49:32 PM »
 There is no way to exceed the motor velocity and acceleration that is set in motor tuning. The FRO will go to that point and no further.
The Rapid Override only goes to 100%, which is the maximum set in Motor Tuning.
Your cutter might have had a chip load on it when it made its Z move, along with the high velocity may have caused it to miss steps.
Just one possible explanation, probably more.
RC
Re: feedrate override and G00's
« Reply #2 on: June 30, 2008, 12:55:45 AM »
That's how I thought it was supposed to work. Spindle was going up when it lost steps BTW so no chip load. I heard it happen and the z motor definitely sounded like it was trying to spin faster than it should. I'll edit the g-code with a longer z-up move to see if I can see what the feedrate is really doing.

Offline Hood

*
  •  25,816 25,816
  • Carnoustie, Scotland
    • View Profile
Re: feedrate override and G00's
« Reply #3 on: June 30, 2008, 03:03:42 AM »
What version are you using, this was a common problem with the later versions the rapids should never exceed motor tuning.
Hood
Re: feedrate override and G00's
« Reply #4 on: June 30, 2008, 03:57:23 AM »
version is R2.63.

Just did a test by setting the tuning to 100mm/min on all 3 axes and I can definitely override the feeds (either g00 or g01) past the tuning values.

Offline Hood

*
  •  25,816 25,816
  • Carnoustie, Scotland
    • View Profile
Re: feedrate override and G00's
« Reply #5 on: June 30, 2008, 03:59:45 AM »
yes you need the latest version, 2.63 didnt have the RRO option as far as I remember.

Hood
Re: feedrate override and G00's
« Reply #6 on: June 30, 2008, 06:06:07 AM »
downloaded version 3.041 and it seems to be behaving. Don't often mess with the override on my router but while getting a feel for a new milling machine (and first time cutting something harder than aluminium) I started out slow.

Thanks
--

Jon

Offline Hood

*
  •  25,816 25,816
  • Carnoustie, Scotland
    • View Profile
Re: feedrate override and G00's
« Reply #7 on: June 30, 2008, 06:36:45 AM »
Also have a look in the General config page, you will see an option to lock the RFRO to FRO, if this is checked your Rapid should still not go over the max in motor tuning however it will slow your rapids by the % you set for the FRO. If you wish to have totally independant FRO and RFRO then uncheck this option and use the FRO and RFRO sliders to control each.
Hood
Re: feedrate override and G00's
« Reply #8 on: June 30, 2008, 07:17:42 AM »
Hood, I wasn't aware of that "BUG" in the earlier version, a quick search revealed this:
http://www.machsupport.com/forum/index.php/topic,1919.0.html
Thanks

Jallitt, sorry if may have mislead you, just never experienced that myself.
Glad Hood got you going in the right direction.
Regards,
RC