Hello Guest it is June 19, 2019, 01:37:57 AM

Author Topic: Progressive Move Error with X and Y  (Read 35617 times)

0 Members and 1 Guest are viewing this topic.

Progressive Move Error with X and Y
« on: June 29, 2008, 01:38:43 PM »
I'm not sure how to word this and read through some of the posts but didn't see anything that applied.  I finally got to cutting some parts after many tests and realized I have a problem when moving both the x and y axis in G90 or G91 mode.  If I move each axis independently, it always returns to the exact same point.  However, if I move from x0y0 to x1.5y1.5, and back to x0y0 and then finally to x1.5y1.5 I will be off by about 0.042 thousands.  If I repeat this, it is progressive and goes to about 0.084 thousands roughly.

I just don't know where to start with this problem.  The independent x/y movements I believe indicate that my basic motor setup is correct.  So I'm not sure how the xy movement together can cause a progresive move error.  Is the computer itself suspect and possibly not sending the right information or could it be missed steps for some reason when doing both axis?  If it were missed steps, I would have thought it would show up when doing single axis movements too?!

If anyone has any ideas, it would be greatly appreciated.

Best Regards.

Carl

Offline jimpinder

*
  •  1,233 1,233
  • Wakefield, West Yorks, UK
    • View Profile
Re: Progressive Move Error with X and Y
« Reply #1 on: June 29, 2008, 02:04:08 PM »
If you have a progressive error, your steps per unit will probably wrong.

You do not say what machine you are using, or how you have set it up.
We will assume it is up and working.
You now must calibrate it accurately, and then first thing to do is set the steps per unit - see Config/Motor tuning, bottom left hand corner. Whatever your units are, inches or millimeters, you must calculate how many steps your motors need to move your axis I inch (or mm)
This is a round figure. My Gecko drives have 10 microsteps, my motors requie 200 steps per rev, I have a 3 to 1 step down gear to my leadscrew, and my leadscrew turns 10 times per inch. My steps per unit is therefore 10 x 200 x 3 x 10 = 60,000 steps per inch.

Art included a system for the machine to calculate this, but it involved measuring, so it is flawed, since you cannot measure accurately. It is alright to check your figure with this and see that you are not out by some rediculous amount, but the steps per unit is the calculated figure, not the measured one.

You can then run your machine to 1 inch, 2 inches, 3 inches - in fact as far as you can measure. I am not saying you will get a precisely accurate 1 inch measurement - it might be 0.998 or 1.001 - but over the rest of the measurements the accuracy will stay within these limits, because the errors on the system are not repeatable.

Always remember when taking measurements to move the table right, stop, zero everything, then carry on moving right. Or the other way, move left, stop, zero everything, then start measuring. This will get rid of backlash.

Once you have you steps per unit set, then you can configure backlash.


Not me driving the engine - I'm better looking.

Offline Hood

*
  •  25,844 25,844
  • Carnoustie, Scotland
    • View Profile
Re: Progressive Move Error with X and Y
« Reply #2 on: June 29, 2008, 02:33:31 PM »
Check the voltage of your power supply when moving axis simultaneously, it should stay contstant (or nearly) if it drops off too much there is a good chance you will loose steps.
Hood

Offline Chip

*
  • *
  •  2,057 2,057
  • Gainesville Florida USA
    • View Profile
Re: Progressive Move Error with X and Y
« Reply #3 on: June 29, 2008, 02:55:47 PM »
Hi, Carl

If your losing steps, Try reducing your Acceleration and Velocity settings some.

Tell us a little more about your Machine, Steppers, Controller type, Computer speed ....

If your Step, Dir "Pulses" are set to 0, Set them to 5 also.

More info Needed, Chip
Re: Progressive Move Error with X and Y
« Reply #4 on: June 29, 2008, 03:10:29 PM »
Thanks for the replies.  As for the setup, I have Nema 34 steppers on the x/y axis, Nema 23 stepper on y axis, gecko 201s, cnc4pc breakout board, 48v unregulated power supply, and Mach 3. 

I thought I already set it up properly and did many tests to ensure it moved 1 inch forward and 1 inch backward in both the x and y direction along with many other tests.  I ran testing circles 1, 2, 3, and 4 inches in diameter and it worked fine.   I then moved on to some test runs with aluminum to enure the program ran properly.  Everything seemed to checkout.

The gear I pictured was crossed out using the program I ran.  the interesting thing is that the it appeared to drift as it cut each quadrant but cut each quadrant properly!  At that point I did some more test as follows:

Test 1:
1. Zero all axis in Mach3.
2. G90X1.5Y1.5
3. X0Y0

I'm now off by 0.042 thousands.

Test 2 continuing from Test 1 above I did:

1. X1.5Y1.5
2. X0Y0

I'm now off about 0.084 thousands.

Test 3 starting over zeroing everything:

1. G90X1.5
2. X0
3. X1.5
4. X0

I could do the above as many times as I like and it was spot on when returning zero.

Test 4 starting from Test 3 above.

1. G90Y1.5
2. Y0
3. Y1.5
4 Y0

I could do the above as many times as I like and it was spot on returning to zero.

I then did all test in G91 mode and the results where the same when moving a single axis vs both at the same time.  Very confusing?!  How can movements with a single axis be spot on and movements with both axis at the same time produce drift?  I would have thought that the single axis moves and the circle tests confirmed that I setup the motors correctly in Mach3.  Maybe there's more to the setup than I realized but I can't find it.

Hood, I'll check the voltage and see if it's changing. I assume you mean at the supplyl output source correct?  These tests were all done at 10 ipm and it's a 48v unregulated power supply so hopefully it's not fluctuating at these speeds but it's somehting to check.  Thanks again for the feedback.

Best Regards.

Carl
Re: Progressive Move Error with X and Y
« Reply #5 on: June 29, 2008, 03:45:41 PM »
More information:

1. The voltage with G90F5X3 from zero is 54.4 contstant.
2. The voltage with G90F5X3Y3 from zero is 53.8 constant.
3. I have been unable to change the Step "Pulses" and even have tried what others have recommended in a separate post.  The Gecko feedback I got was to set it to 2 but it always remains at 1 no matter what I do to save the new setting.
4. I will try and see if I can set the DIR "Pulses".  Got this confused when I first read it.

My motor tuning configuration that finally seemed to produce reliable results is below.

Thanks again to everyone for the feedback.  I'm stumped and need fresh ideas to track this down.

Best Regards.

« Last Edit: June 29, 2008, 03:49:29 PM by cmnewcomer »
Re: Progressive Move Error with X and Y
« Reply #6 on: June 29, 2008, 06:38:02 PM »
Your last screenshots show the Pulse at 1.....Did you try as Chip suggested setting it to 5 ? (Hit enter after changing)
You could also try Sherline Mode in Config...That sets the Pulse at 40.
Might be worth a try, it sometimes helps.
RC
« Last Edit: June 29, 2008, 06:39:43 PM by Overloaded »
Re: Progressive Move Error with X and Y
« Reply #7 on: June 29, 2008, 08:35:13 PM »
Yes, I've tried to set it higher but it won't save.  I have a separate thread discussing this problem but have not found a solution.  I was looking at some of the xml files thinking I may be able to set it there but know that may not be a supported solution.

If you have some suggestions on how to get the new setting to persist, I would greatly appreciate it.

Best Regards.
Re: Progressive Move Error with X and Y
« Reply #8 on: June 29, 2008, 08:50:10 PM »
Instead, try the Sherline mode...or did you already ? You have to restart for it to take effect.
Re: Progressive Move Error with X and Y
« Reply #9 on: June 29, 2008, 08:53:31 PM »
Put 5 in.....then click SAVE AXIS SETTINGS, then click OK.
Maybe that'll do it.
RC