Hello Guest it is June 17, 2019, 03:41:15 PM

Author Topic: Can't get enable2 to work in Turn mode  (Read 3425 times)

0 Members and 1 Guest are viewing this topic.

Can't get enable2 to work in Turn mode
« on: June 22, 2008, 01:10:36 AM »
I need to use a second enable line for my lathe. For some reason when I activate enable2 and give it the port and pin I want to use, the enable2 led will not turn on in the diagnostic screen nor does the output change state when I reset the machine. This works fine when I run Mach3Mill but does not work when I run Mach3Turn.

Can anyone suggest what I may be doing wrong?

Thanks
Shawn

Offline jimpinder

*
  •  1,233 1,233
  • Wakefield, West Yorks, UK
    • View Profile
Re: Can't get enable2 to work in Turn mode
« Reply #1 on: June 22, 2008, 03:17:20 AM »
I don't know - I have just tried enabling "enable" on both my Mill Screen and Lathe screen and both worked OK.  I am trying this on my "office" computer - not in the workshop.

However on both my screens (1024.set and 1024.lset) only three of my enable leds lit up out of the six, even with all enabled.

I tried active high and active low - but it made no difference to anything. The leds were still lit (or not)

There was one thing I did notice and that was the settings were common to both set and lset, so whatever I had set on the mill transferred to the lathe when I changed the screen. Are you trying to get different settings on different screens???
Not me driving the engine - I'm better looking.
Re: Can't get enable2 to work in Turn mode
« Reply #2 on: June 22, 2008, 11:32:15 AM »
I am not exactly sure how setting get changed between the mill and the lathe. When I installed mach3 it put 2 icons on my desktop, One for Mill and one for lathe. I have been using the Mill profile for years with my Taig mill. I just got a MaxNC lathe so I have been trying to set that up.

When I switch from one to the other the settings are definitely not common. Any changes I make only affect the one profile.

Shawn

Offline Hood

*
  •  25,844 25,844
  • Carnoustie, Scotland
    • View Profile
Re: Can't get enable2 to work in Turn mode
« Reply #3 on: June 22, 2008, 02:10:00 PM »
Never tried with two enables in Turn before but have just tried and I get the same result. ie 1 changes with reset  but 2 never changes. Will see what I can find out from Brian.
Hood

Offline Hood

*
  •  25,844 25,844
  • Carnoustie, Scotland
    • View Profile
Re: Can't get enable2 to work in Turn mode
« Reply #4 on: June 22, 2008, 02:27:48 PM »
OK just talked to Brian, he says axis needs to be enabled and then it sunk in. Enable 1 will be mapped to X axis and Enable 3 is mapped to Z axis.
Hood
Re: Can't get enable2 to work in Turn mode
« Reply #5 on: June 24, 2008, 12:29:01 PM »
Thanks, that fixed the problem. I enabled the Y axis motor even though it is not connected and now enable 2 works. I do not understand why it is this way but its working now.

Shawn

Offline Hood

*
  •  25,844 25,844
  • Carnoustie, Scotland
    • View Profile
Re: Can't get enable2 to work in Turn mode
« Reply #6 on: June 24, 2008, 01:15:31 PM »
Mach started off as Mill only, well actually it was probably even before it was called Mach. In Mill X would be mapped to enable 1, Y to enable 2, Z to enable 3 and A to enable 4. When Mach Turn came on the scene it was probably easiest just to leave things the way the way they were, might have needed a lot of code changes otherwise. Because Turn uses X and Z axis then all you need to do is use enable 1 and 3, you dont actually need to enable the Y axis but if it works for you that way then go for it :)
Hood