Hello Guest it is October 26, 2021, 05:52:45 PM

Author Topic: Lathe Flash OEM screen for Mach3 (testing and comments wanted).  (Read 44633 times)

0 Members and 1 Guest are viewing this topic.

Offline poppabear

*
  • *
  •  2,233 2,233
  • Briceville, TN, USA
    • View Profile
    • S S Systems, LLC
Here is a Mach3 Turn screen, it recreates "Steve Blackmores" (mach turn's OEM turn screen).

I have attached the Source File for the .swf as a Zip file.

There are some minor glitches, that I suspect I have been staring at it to long now, to see the bug.

i.e. Some of the LEDs, like: Coolent, Dwell, and a few others, will turn on with the button, but wont toggle off, unless you navigate off that page and return to it.......  A little agrevating, but I can't find what I am missing.

"F1" brings out the "MPG/Shuttle" page, you hitting the F1 again will not flip you back, you have to push the button in the lower right corner that brings you back to the Run page.

But everything else is running/working.

Please, I ask if you see the errors please fix them in the source, and repost it with your fix, what you did, where it was etc.


Scott
Commercial Mach3 & Mach 4, Design/Build/Retrofit CNC and Industrial machines.
http://www.ss-systems-llc.com/
Re: Lathe Flash OEM screen for Mach3 (testing and comments wanted).
« Reply #1 on: June 16, 2008, 05:11:15 PM »
Scott

I can help with the Coolant  (not Coolent incidentally), Dwell etc. The LEDs are defined with Frame Names Dead, Red, Yellow, Green but the watch code calls up

gotoAndStop ("off")

Changing these to:

gotoAndStop ("dead")

works fine.

As you say, one of those things you can stare at for ever and miss.

John Prentice

Offline poppabear

*
  • *
  •  2,233 2,233
  • Briceville, TN, USA
    • View Profile
    • S S Systems, LLC
Re: Lathe Flash OEM screen for Mach3 (testing and comments wanted).
« Reply #2 on: June 16, 2008, 10:55:25 PM »
John,

   Thank you Sir!!!!  You are a Peach!!  I knew I just couldnt see it.  I am reposting the new fixed .swf and source file.
I changed all the states of ALL Leds to "dead" that way every thing is the same........ 
also, I fixed the Coolant labels....

Thanks again for eyeballin it John,  Poke at this one, and see if there are more bugs.......

scott
« Last Edit: June 16, 2008, 10:58:30 PM by poppabear »
Commercial Mach3 & Mach 4, Design/Build/Retrofit CNC and Industrial machines.
http://www.ss-systems-llc.com/
Re: Lathe Flash OEM screen for Mach3 (testing and comments wanted).
« Reply #3 on: June 17, 2008, 09:28:35 AM »
Very nice screen set, but darn now I have to upgrade my shop computer to run flash.

Seriously, very nice work, looks great to me.  I will play with is some and see what I can turn up.  Thanks also for including the source file.

John Guenther
'ye Olde Pen Maker'
Sterling, Virginia

Offline poppabear

*
  • *
  •  2,233 2,233
  • Briceville, TN, USA
    • View Profile
    • S S Systems, LLC
Re: Lathe Flash OEM screen for Mach3 (testing and comments wanted).
« Reply #4 on: June 17, 2008, 10:36:13 AM »
Ok,

     I think I may have got them all (the bugs that is). 
NOTE: to "Tab out" the MPG/Jog window, you have to hit the "F1" key, that is because in flash, using the tab key will cycle through your displayed DRO's..........

Bugs Fixed: 
1). All the LEDs Work, Please test them all on your set up, in case I missed one.........
2). Fixed the Units/rev-min smart label, (this was a work around since Brian will have to add support for this Smart Label and a few others as he can).
3). Global Action Script Frame, I changed this to one Giant Frame that covers the entire screen sets, this is code that hits many of the same things
over and over again on the pages. It will allow quick changes to the scripts for all pages that they effect.

current .swf, and updated source attached.

Scott
Commercial Mach3 & Mach 4, Design/Build/Retrofit CNC and Industrial machines.
http://www.ss-systems-llc.com/
Re: Lathe Flash OEM screen for Mach3 (testing and comments wanted).
« Reply #5 on: June 17, 2008, 03:49:37 PM »
Why is there a small button in the upper left corner of most of the screens for the Daignostics page? 

Not a problem, just a quetion.

Thanks

John Guenther
'Ye Olde Pen Maker'
Sterling, Virginia

Offline poppabear

*
  • *
  •  2,233 2,233
  • Briceville, TN, USA
    • View Profile
    • S S Systems, LLC
Re: Lathe Flash OEM screen for Mach3 (testing and comments wanted).
« Reply #6 on: June 17, 2008, 03:53:18 PM »
I recreated "Steve Blackmores" screens exactly, as much as able, since everone was used to them, no other reason.
Commercial Mach3 & Mach 4, Design/Build/Retrofit CNC and Industrial machines.
http://www.ss-systems-llc.com/
Re: Lathe Flash OEM screen for Mach3 (testing and comments wanted).
« Reply #7 on: June 17, 2008, 04:25:12 PM »
Scott,

Ok, I had not noticed that before, but then I don' t normally use those screens since they will not work on my shop computer without being downsized to 640x480.  I have a screen set that I made for my mini lathe that does what I need it to so I rarely use the default screen sets.

I will be upgrading the shop computer to allow the flash screens to work on it.

Thanks

John Guenther
'Ye Olde Pan Maker'
Sterling, Virginia

Offline klmark

*
  •  107 107
    • View Profile
Re: Lathe Flash OEM screen for Mach3 (testing and comments wanted).
« Reply #8 on: June 17, 2008, 04:42:31 PM »
Hi
 I can't load Flash screens on my computer What dose a guy do to get it working I am a FLASH Guy I downloaded the new fla but it in my Plugins folder what alse do I need to do    Thank you   klmark   

Offline poppabear

*
  • *
  •  2,233 2,233
  • Briceville, TN, USA
    • View Profile
    • S S Systems, LLC
Re: Lathe Flash OEM screen for Mach3 (testing and comments wanted).
« Reply #9 on: June 17, 2008, 05:22:59 PM »
Ha,

    Thanks to Jason "Grand Master Flash" Zealous, he gave me the code to do the MPG/jog window toggle correctly, it now works as it should, with the F1 Key, which when pressed brings out the MPG/jog page, when pressed again, it takes you back to the screen you where last on.

You will need to have the latest Flash plug in installed to run this screen. Here is the link, download the Zip file attachement from that post, for the Flashdll.zip

http://www.machsupport.com/forum/index.php/topic,7042.0.html

Also, you have to have the above Flash Plugin for the Smart Labels to work!!!!

there have been reports of Flash crashing peoples computers there are some steps you HAVE to do.

1). You have to download and install Flash ActiveX player 9

LINK:  http://www.artsoftcontrols.com/forum/index.php?topic=3905.0

go down to post #4 by Jason and download the install zip file.

2). You need to Enable the Flash  Plug in once you put the .dll in the plugins folder, once enabled, close and reopen mach.

3). Drag and Drop the new .swf file into the main Mach 3 directory, open up mach, if already open that is ok, go to view, load screens, on file type pick ".swf" scroll until you see the .swf you want hit ok.

4). Once the Flash screen loads, YOU HAVE TO CLOSE MACH, AND RE OPEN MACH,  so it gets written to the .XML.

It should run fine after that.

If you Computer is Crashing with Flash here is some other things that Jason said, could be the cause:

-Not using the latest Flash Plug’ in
-Not installing the Flash Active X controller
-Not running Mach version 3.*********
-Running Mach in demo Mode
-Antivirus system not allowing Flash to run (you could be blocking any Adobe product from running on your system)

if none of that works try things like turning off Hardware acceleration on your Vidio card to see if it makes a difference.

Past these things, it is an Art or Brian Question........

Attached are the source for lathe and the .swf (version 5), I also put a Flash Version 8 source file, for those running Flash 8.

Scott



Commercial Mach3 & Mach 4, Design/Build/Retrofit CNC and Industrial machines.
http://www.ss-systems-llc.com/