Hello Guest it is July 17, 2019, 01:14:51 PM

Author Topic: Fried 2nd Computer (Newbie)  (Read 16500 times)

0 Members and 1 Guest are viewing this topic.

Re: Fried 2nd Computer (Newbie)
« Reply #40 on: June 09, 2008, 08:52:57 PM »
Hi Trev

Sorry to read you are having such a bad time. The 12v to the BOB, is this for a vfd, otherwise you only need 5v. Like Jim says connect a bit at a time

I simple way of getting 5v and 12v is to use a surplus PC power supply, there is some re wiring to do. Have you got any buddies that can help you check what you are doing is correct.

Here is the link of the power supply mod http://www.wikihow.com/Convert-a-Computer-ATX-Power-Supply-to-a-Lab-Power-Supply

This might be useful to other peeps

Good luck
Phil_H
The Good Thing About Mach3, Is It's very Configurable

The Bad Thing About Mach3, Is It's Too Configurable
Re: Fried 2nd Computer (Newbie)
« Reply #41 on: June 10, 2008, 12:11:19 AM »
The probotix board shows step, dir, ground and enable connectors on each axis. Are you sure that's compatible with the kellig drivers which don't have a ground connection on the logic side? Last time you tried to plug in the BOB did you have the step/dir wires connected to the BOB? 

Do you need to connect the axis ground to both the DIR- and STEP- on the driver and the STEP from the BOB to the STEP+  and DIR from the BOB to DIR+? That's a question BTW not a suggestion...

Offline jimpinder

*
  •  1,233 1,233
  • Wakefield, West Yorks, UK
    • View Profile
Re: Fried 2nd Computer (Newbie)
« Reply #42 on: June 10, 2008, 01:44:29 AM »
I am getting a bit upset that we are giving you advice which you are not heeding. Either that, or there is too much advice and you are getting confused.

It seems to me that your knowledge is a little lacking, and you will have to, therefore take things step by step. You will insist in connecting everything up and switching on and hoping for the best. This is not a scientific way of doing it.

You had better give your computer the once over first and see if signals are still coming out of the LPY1 port. . Is this a standard shop bought computer, or one you have put together yourself. Is the chassis earthed.
Connect a cable to the LPT1 port and turn on the computer. Do not connect anything else. If you have Mach 3 on the screen then fine. Has Mach 3 properly loaded onto your computer, with the drivers running. Have you run a driver test. Do all this before going any further.

With Mac 3 running check with a volt meter, or a logic probe, the signals coming out of your printer port. What voltage are they at. Check each wire 1 to 17 against one of the signal return wires 18 to 25. The pin numbers are stamped on the plug (somewhere).
What voltage is the sheathing showing ???

The sheathing should be at 0v and pins 18 to 25 should show 0v to each other and the sheathing. No other pin shoud have a voltage on it greater than 5 volts. If there is anything wrong - particularly stray voltage on the sheathing, FIND OUT WHERE IT IS COMING FROM  before you do anything else.

Moving to your Bob board - it sounds like you have now bought one of the opto-isolated variety. WHY DO YOU INSIST ON CONNECTING 12 VOLTS FROM YOUR FAVOURITE VOLTAGE REGULATOR TO IT. This is a recipe for disaster. The opto isolated board - if it is from the same stable as your last board has a simple connector - a USB connector, which you plug into your computer and into the Bob board. This provides power to the Bob. Since it is from the computer, then all voltages must be the same.

If you LPT1 cable checks out, then plug it in, fasten up the USB link and the Bob should now work. I cannot percieve anything more simple than that. DO NOT CONNECT ANYTHING ELSE TO THE BOB UNTIL YOU HAVE TESTED IT.

That is enough diatribe - if you get that far (and live) and want some more, come back.



« Last Edit: June 10, 2008, 01:46:25 AM by jimpinder »
Not me driving the engine - I'm better looking.

Offline da21

*
  •  87 87
    • View Profile
    • M-Machine
Re: Fried 2nd Computer (Newbie)
« Reply #43 on: June 10, 2008, 03:19:50 AM »
stop trying to jump to far too quick , otherwise we will not find the problem for you , and More damage WILL HAPPEN
is this the bob you are using ? http://www.probotix.com/diagrams/PBX-RF_diagram.gif

looking at this bob there are 2 supplys needed one for the pc side of the bob and another for the controller side , you can not run them from one supply, has the regulator pcb you made fitted with supply filtering caps on the input and output side ,their are a few areas suspect , do you have the transformer wired correctly , did you fit 100uF caps across the 7812 on both the input and output sides , is the common 0V the same to  both the motor driver and 7812 power supplys.

using an old pc power supply as suggested , is a good idea although for this application of realy only supplying power to the bob is overkill
 

as the problem manifests it's self when you connect the pc then i'd suggest you dont have the second power supply fitted or your not supplying power from the USB socket 

also a simple check is if you have an old printer you can connect to the printer port and see if it's working ok , if your not comfortable pokeing around with a multimeter .

if you wish contact me on skype or email me , i dont mind helping you further , but it seems that without either someone local to you or interactive help you may struggle , you'd probably at the moment be better off using the standard breakout board rather than the isolated one
as they can induce other problems of their own doing , changing things half way through can only move the underlying problem around not solve it  .

Dave








 


 

 
Re: Fried 2nd Computer (Newbie)
« Reply #44 on: June 11, 2008, 01:36:47 AM »
Success !!! You will never believe this ! I checked the ground on the AC side. I could kick myself in the ass for not thinking of this first. NO GROUND.  I pulled all the receptacle  plate covers off to discover I only have one receptacle with a ground. All the others in my garage do not have a ground.

I want to thank everyone for being patient with me and seeing me through this. Mach Support is theBEST!!!
Everything is running smooth.

Thank you

Travis
Re: Fried 2nd Computer (Newbie)
« Reply #45 on: June 11, 2008, 01:52:53 AM »
To Jallitt


Yes the probotix breakout boards are compatable. You only need to hook up the step and dir to the Dir- and Step- on the logic side of the driver. The Step+ and Dir+ take +5 volts from the Breakout board. The probotix board is awesome because of the onboard LM317 which you can use your 12 volt supply that you use to poewr your cooling fan and hook up to the breakout board and the onboard regulator steps down to +5 volts and you can solder a wire to the idc +5 volt pin and supply the driver this way. Everything is marked very clearly on the board. Any of the Probotix Breakout boards will work with Geckos, Keling, or any driver that accept step and dir signals. I have purchased the Probotix unipolar stepper drives to try next.

Thanks

Travis

Offline jimpinder

*
  •  1,233 1,233
  • Wakefield, West Yorks, UK
    • View Profile
Re: Fried 2nd Computer (Newbie)
« Reply #46 on: June 11, 2008, 01:56:05 AM »
You should have tried that with the 240 volts across here. All electrical work over here (at mains voltage) now has to be certificated. Having done most of my own electrical work over the years, I was upset when this regulation came in - but I can see why !!
Not me driving the engine - I'm better looking.

Offline Chip

*
  • *
  •  2,057 2,057
  • Gainesville Florida USA
    • View Profile
Re: Fried 2nd Computer (Newbie)
« Reply #47 on: June 11, 2008, 02:26:59 AM »
Hi, Travis

Well go figure that one, Get a socket tester to make sure the neutral & hot leads aren't reversed while your fixing the Gnd problem.

Glad you found the problem.

Chip