Hello Guest it is July 23, 2019, 08:09:57 AM

Author Topic: How do I install the shuttle pro plugin, I don't see a menu for installing the p  (Read 6252 times)

0 Members and 1 Guest are viewing this topic.

Works perfect thanks guys!   I just installed it on all my machines!  Anyway to configure a button to do this:

g00 x0y0

I do that move a lot instead of go to z

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
You can open your screenset with Screen4 (should be in Mach3 folder, if not you can download it) You can then add a button to the screenset and set it as a G Code button and add the code to it. If you dont use the Go to Zero button then you could change that to a  G Code button.
 When you have changed or added a button save the screenset with a different name and then when you open Mach again go to the view menu and browse to the saved screenset and load it. The reason its best to change the name is if you update to a newer version of Mach your adapted screen wont get overwritten.
Hood
One more quick question, something installed today has significantly slowed down my axis when I change direction in the axis.  I'm sure I can't be the first person this has happened to, is  there a thread that discuss' this?  I did a quick search and found nothing on it.

I rapid at 50 IPM and when I change direction, it starts, then slows down to zero then ramps up to 50.

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Do you have backlash enabled?
Hood
Yes, I have always had it enabled, cause there is .001 in the system.  It has always done it to a small degree, but never can I recall it compensating for backlash and just stopping dead before it jogs.  Maybe my memory is just fuzzy and I'm more aware of it now cause I'm making changes............

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
OK think Backlash changed in the newer versions, Brett has the settings that seem to work for most, heres what he says "shuttle accel  is set to .05 and speed in backlash to 200."

Give that a go and see, the shuttle acell is on the Config menu then General config page if I remember correctly.
Hood
Wow, that fixed everything!  Even running better than before!!

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile