Hello Guest it is July 23, 2019, 08:13:46 AM

Author Topic: How do I install the shuttle pro plugin, I don't see a menu for installing the p  (Read 6253 times)

0 Members and 1 Guest are viewing this topic.

plugin under the menu items in Mach 3.

Thanks in advance for the help, I was able to download the plugin file.  Just don't know what to do with it now

Offline da21

*
  •  87 87
    • View Profile
    • M-Machine
place the shuttle pro dll in your mach3 plugins directory ,
restart mach3
go to config menu , select config plugins , you should then get a popup message box showing plugins , you should find a green tick to the left of shuttle pro  this shows it's enabled (  if not select the red x and it will change to a green tick )
mouse click on the yellow config box , should bring up your shuttle pro configuration screen

Dave
When I go to www.machsupport.com/plugins.php  I download the shuttle pro file it is a .m3p file, not a dll file.  So I guess I'm confused, where do I get the dll file?

When I open mach 3, and go to the config menu, there is no option for "Config plugins".  Do you have to have the dll there? 

My mach 3 subdirectory only has "addons, bitmaps, gcode, help, macros, subroutines, turnaddons, xmlbackups" as subdirectorys, none called "plugins".

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
What version of Mach are you running?
Hood
I can provide screenshots if you all think it will help.  I've been using mach3 for over a year, almost daily.  This is the first upgrade I've ever tried, it has always worked perfectly for me.  I have three CNC machines running mach 3 right here in my home shop.

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
I am meaning what Version of Mach3, you will find it if you go to the Help Menu then clcik onĀ  About.
 If its a very old version of Mach3 it probably doesnt support the plugins.
 To install the plugin you should just have to double clcik on the m3p and it should auto install but probably wont if your Mach 3 version is too old.

Hood
1.84?  Where do I go to upgrade, I didn't even know there were updates out there, sorry about this.
Ok, I'm installing the newer version now, sorry about this

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
If you scroll up to the top of the page you will see a downloads tab, clcik on the Mach & LazyCAM  tab that pops up then you will see the available versions. 2.63 is the latest lockdown and there is also a Development version there which should be ok,  certainly has been for me. Might be best to stick withthe lockdown though.
Hood